Modify

Opened 7 days ago

Closed 7 days ago

#17909 closed defect (duplicate)

Moving two or more relation members down results in re-arragment

Reported by: pl71 Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description (last modified by pl71)

What steps will reproduce the problem?

  1. Get a relation with at least three members, open Relation Editor
  2. Select at least 2 relation members, but not the last ones,
  3. Try to shift them down using provided button on Relation Editor

"Move the currently selected members down (Alt-Down)"

What is the expected result?

Moving selected members down in the list.

What happens instead?

Some are moved, some - not.

Please provide any additional information below. Attach a screenshot if possible.

Note: Moving up is working as supposed.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2019-07-09 01:01:06 +0200 (Tue, 09 Jul 2019)
Build-Date:2019-07-08 23:02:00
Revision:15237
Relative:URL: ^/trunk

Identification: JOSM/1.5 (15237 bg) Windows 7 64-Bit
OS Build number: Windows 7 Professional (7601)
Memory Usage: 422 MB / 1820 MB (159 MB allocated, but free)
Java version: 1.8.0_211-b12, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1680x1050
Maximum Screen Size: 1680x1050
Dataset consistency test: No problems found

Plugins:
+ apache-commons (34908)
+ ejml (35049)
+ geotools (34908)
+ imagery_offset_db (34908)
+ jts (34908)
+ log4j (34908)
+ utilsplugin2 (34977)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/ParkingLanes&zip=1

Map paint styles:
+ https://josm.openstreetmap.de/josmfile?page=Styles/ParkingLanes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/PublicTransportV2&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_features_ryg&zip=1

Last errors/warnings:
- W: java.net.UnknownHostException: c.tile.openstreetmap.org
- W: Already here java.net.UnknownHostException: c.tile.openstreetmap.org
- W: java.net.UnknownHostException: c.tile.openstreetmap.org
- W: Already here java.net.UnknownHostException: c.tile.openstreetmap.org
- W: java.net.UnknownHostException: c.tile.openstreetmap.org
- W: Already here java.net.UnknownHostException: c.tile.openstreetmap.org
- W: java.net.UnknownHostException: c.tile.openstreetmap.org
- W: Already here java.net.UnknownHostException: c.tile.openstreetmap.org
- W: Незаписани промени - <html>The relation has been changed.<br><br>Do you want to save your changes?</html>
- W: Незаписани промени - <html>The relation has been changed.<br><br>Do you want to save your changes?</html>

Attachments (0)

Change History (2)

comment:1 Changed 7 days ago by pl71

Description: modified (diff)

comment:2 Changed 7 days ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #17894.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.