Modify

Opened 7 months ago

Last modified 7 months ago

#17897 reopened defect

relation editor: sorting and directions with forward/backward not working properly.

Reported by: skyper Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: template_report relation manager sort connectivity oneway Cc:

Description (last modified by skyper)

What steps will reproduce the problem?

  1. open a 2-way route relation with some members with role forward/backward
  2. select all members and sort them

What is the expected result?

I get a well sorted relation with full connection and direction indication

What happens instead?

  • Sort does not always work, especially, if there are more than one way to sort it and only one way is accepted
  • Perfectly sorted members are rearranged (see above) and connectivity is rendered wrong (not connected)
  • the direction of oneway is interpreted wrong

Please provide any additional information below. Attach a screenshot if possible.

  • I made a small example file.
  • moving some members down/up helps sometimes.
  • reversing simple relations like in the example should also be correct but JOSM does not like them.
URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2019-07-07 14:17:28 +0200 (Sun, 07 Jul 2019)
Build-Date:2019-07-07 12:18:47
Revision:15221
Relative:URL: ^/trunk

Last errors/warnings:
- W: java.io.IOException: Attribution is not loaded yet
- W: Bing: attribution data is not yet loaded.
- W: java.io.IOException: Attribution is not loaded yet
- W: Bing: attribution data is not yet loaded.
- W: java.io.IOException: Attribution is not loaded yet
- W: Bing: attribution data is not yet loaded.
- W: java.io.IOException: Attribution is not loaded yet
- W: Bing: attribution data is not yet loaded.
- W: java.io.IOException: Attribution is not loaded yet
- W: Bing: attribution data is not yet loaded.

Attachments (1)

josm_17897_example.osm.xz (600 bytes) - added by skyper 7 months ago.
example file

Download all attachments as: .zip

Change History (4)

comment:1 Changed 7 months ago by skyper

Description: modified (diff)

Changed 7 months ago by skyper

Attachment: josm_17897_example.osm.xz added

example file

comment:2 Changed 7 months ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #17887.

comment:3 Changed 7 months ago by skyper

Resolution: duplicate
Status: closedreopened

This is also happening with r15221 and is a different story

Last edited 7 months ago by skyper (previous) (diff)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as reopened The owner will remain team.
as The resolution will be set.
to The owner will be changed from team to the specified user.
The owner will change to skyper
as duplicate The resolution will be set to duplicate.The specified ticket will be cross-referenced with this ticket

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.