Modify

Opened 2 years ago

Closed 2 years ago

#17872 closed defect (duplicate)

Faulty treatment of relation members when ways are split

Reported by: osm@… Owned by: osm@…
Priority: major Milestone:
Component: Core Version:
Keywords: turn restriction Cc:

Description

In the last 2-3 days, I came across the following behaviour leading to defective turn restrictions:

  1. Given a turn restriction with ways A and B (as from/to) and node C (as via).
  2. One of the ways is split up so that the newly formed way D now connects to Node C.
  3. Expected behaviour: JOSM should put the new way D into the relation, replacing the old from/to way, in order to keep the TR intact.
  4. Actual behaviour: JOSM does not alter the relation, resulting in an error on upload (from/to not connected to via node).

JOSM 15155, Java 11.0.3 / Kubuntu 19.04.

--ks

Attachments (0)

Change History (5)

comment:1 Changed 2 years ago by Klumbumbus

There was a bug (#17810) which is fixed in the latest version already. Could you please check if you can reproduce the bug with the current latest version? wiki:Download

comment:2 Changed 2 years ago by Klumbumbus

Owner: changed from team to osm@…
Status: newneedinfo

comment:3 Changed 2 years ago by Don-vip

Keywords: turn restriction added

comment:4 Changed 2 years ago by anonymous

Confirmed – the bug described above does NOT appear with josm-latest (15196).

So I’ll be waiting for the release. Ticket may be closed.

--ks

comment:5 Changed 2 years ago by Klumbumbus

Resolution: duplicate
Status: needinfoclosed

Closed as duplicate of #17810.
Thanks for testing.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain osm@….
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.