Modify

Opened 8 weeks ago

Closed 7 weeks ago

Last modified 6 weeks ago

#17861 closed enhancement (fixed)

Refactor of HTTP client to support HTTP/2 in a new plugin requiring Java 11

Reported by: Don-vip Owned by: Don-vip
Priority: normal Milestone: 19.06
Component: Core Version:
Keywords: http java11 Cc:

Description

JDK11 introduced a standardized and modern HTTP client that supports HTTP/2 out of the box (JEP 321):
http://openjdk.java.net/jeps/321

Given my estimations in #17858 it's unlikely we will be able to switch to Java 11 before 2021.

Since #16682 we have the ability to create plugins that require a specific version of Java with Minimum-Java-Version.

I'm going to create a new plugin that takes advantage of the JDK11 HTTP client in order to provide HTTP/2 support to JOSM. It could boost imagery performance for some providers such as Maxar.

Attachments (0)

Change History (9)

comment:1 Changed 8 weeks ago by Don-vip

Ticket #17863 has been marked as a duplicate of this ticket.

comment:2 Changed 7 weeks ago by Don-vip

Component: PluginCore
Milestone: 19.06
Summary: HTTP/2 support in JOSMRefactor of HTTP client to support HTTP/2 in a new plugin requiring Java 11

comment:3 Changed 7 weeks ago by Don-vip

In 15229/josm:

see #17861 - Refactor HTTP client to support HTTP/2 in a new plugin requiring Java 11

comment:4 Changed 7 weeks ago by Don-vip

Initial version of the plugin in [o35053:35054].

Last edited 7 weeks ago by Don-vip (previous) (diff)

comment:5 Changed 7 weeks ago by Don-vip

In 15232/josm:

see #17861 - update scripts/tests

comment:6 Changed 7 weeks ago by Don-vip

In 15233/josm:

see #17861 - last bugfixes

comment:7 Changed 7 weeks ago by Don-vip

In 15234/josm:

see #17861 - ignore http2 plugin in compatibility check when run with Java < 11

comment:8 Changed 7 weeks ago by Don-vip

Resolution: fixed
Status: assignedclosed

comment:9 Changed 6 weeks ago by Don-vip

First plugin issues: #17888 / #17903

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.