Modify

#17747 closed defect (duplicate)

Doesn't open a new Layer

Reported by: anonymous Owned by: Larry0ua
Priority: normal Milestone:
Component: Plugin piclayer Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2019-04-28 04:36:41 +0200 (Sun, 28 Apr 2019)
Build-Date:2019-04-28 02:37:58
Revision:15031
Relative:URL: ^/trunk

Identification: JOSM/1.5 (15031 it) Windows 8.1 64-Bit
OS Build number: Windows 8.1 Pro (9600)
Memory Usage: 305 MB / 455 MB (106 MB allocated, but free)
Java version: 1.8.0_131-b11, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1080
Maximum Screen Size: 1920x1080
Dataset consistency test: No problems found

Plugins:
+ ColumbusCSV (34985)
+ FastDraw (34977)
+ Mapillary (1.5.18)
+ OpeningHoursEditor (34977)
+ PicLayer (34389)
+ apache-commons (34908)
+ apache-http (34908)
+ buildings_tools (34982)
+ contourmerge (v0.1.4)
+ editgpx (34908)
+ ext_tools (34988)
+ indoor_sweepline (34908)
+ jna (34908)
+ jogl (1.2.3)
+ kendzi3d-resources (0.0.2)
+ log4j (34908)
+ measurement (34977)
+ pdfimport (34977)
+ pt_assistant (705)
+ reverter (34999)
+ routing (${version.entry.commit.revision})
+ tageditor (34977)
+ tagging-preset-tester (34908)
+ turnlanes-tagging (281)
+ turnrestrictions (34977)
+ utilsplugin2 (34977)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/Simple_Indoor_Tagging&zip=1

Map paint styles:
+ <josm.pref>\styles\indoor.mapcss

Last errors/warnings:
- W: Fallita la scansione del file 'site-svn.openstreetmap.org-__svn_bc_34392_applications_editors_josm_dist_PicLayer_jar.txt' per le informazioni dell'estensione. Tralascio.
- E: org.openstreetmap.josm.plugins.PluginListParseException: java.io.IOException: Voce non valida nella lista delle estensioni. PK. Causa: java.io.IOException: Voce non valida nella lista delle estensioni. PK
- W: No configuration settings found.  Using hardcoded default values for all pools.
- W: Fallita la scansione del file 'site-svn.openstreetmap.org-__svn_bc_34392_applications_editors_josm_dist_PicLayer_jar.txt' per le informazioni dell'estensione. Tralascio.
- E: org.openstreetmap.josm.plugins.PluginListParseException: java.io.IOException: Voce non valida nella lista delle estensioni. PK. Causa: java.io.IOException: Voce non valida nella lista delle estensioni. PK
- E: Handled by bug report queue: java.lang.NoClassDefFoundError: org/openstreetmap/josm/Main. Causa: java.lang.ClassNotFoundException: org.openstreetmap.josm.Main


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (18) of main
java.lang.NoClassDefFoundError: org/openstreetmap/josm/Main
	at org.openstreetmap.josm.plugins.piclayer.actions.newlayer.NewLayerFromFileAction.actionPerformed(NewLayerFromFileAction.java:90)
	at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
	at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
	at javax.swing.AbstractButton.doClick(Unknown Source)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(Unknown Source)
	at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)
Caused by: java.lang.ClassNotFoundException: org.openstreetmap.josm.Main
	at java.net.URLClassLoader.findClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at org.openstreetmap.josm.plugins.PluginClassLoader.loadClass(PluginClassLoader.java:73)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	... 39 more

Attachments (0)

Change History (1)

comment:1 Changed 20 months ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #17738.
please update your plugins

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Larry0ua.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.