Modify

Opened 6 weeks ago

Closed 4 weeks ago

Last modified 5 days ago

#17723 closed defect (fixed)

NoClassDefFoundError: javax/script/ScriptEngineFactory

Reported by: Puxan Owned by: team
Priority: normal Milestone: 19.05
Component: Core Version:
Keywords: template_report javascript jsr223 java11 linux ubuntu Cc:

Description (last modified by Don-vip)

What steps will reproduce the problem?

  1. the script "SelectNonOrthogonalBuildings does not work

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2019-04-28 04:36:41 +0200 (Sun, 28 Apr 2019)
Revision:15031
Build-Date:2019-04-28 02:37:58
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (15031 ca) Linux Ubuntu 18.04.2 LTS
Memory Usage: 297 MB / 2048 MB (58 MB allocated, but free)
Java version: 11.0.3+7-Ubuntu-1ubuntu218.04.1, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1920x1080
Maximum Screen Size: 1920x1080
Java package: openjdk-11-jre:amd64-11.0.3+7-1ubuntu2~18.04.1
WebStart package: icedtea-netx:amd64-1.8-0ubuntu8~18.04
Java ATK Wrapper package: libatk-wrapper-java:all-0.33.3-20ubuntu0.1
VM arguments: [--add-reads=java.base=ALL-UNNAMED,java.desktop, --add-reads=java.desktop=ALL-UNNAMED,java.naming, --add-reads=java.naming=ALL-UNNAMED,java.desktop, --add-exports=java.desktop/sun.awt=ALL-UNNAMED,java.desktop, --add-exports=java.desktop/javax.jnlp=ALL-UNNAMED,java.desktop, --add-exports=java.base/com.sun.net.ssl.internal.ssl=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.net.www.protocol.jar=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.security.action=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.security.provider=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.security.util=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.security.validator=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.security.x509=ALL-UNNAMED,java.desktop, --add-exports=java.base/jdk.internal.util.jar=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.net.www.protocol.http=ALL-UNNAMED,java.desktop, --add-exports=java.desktop/sun.awt.X11=ALL-UNNAMED,java.desktop, --add-exports=java.desktop/sun.applet=ALL-UNNAMED,java.desktop, --add-exports=java.desktop/sun.applet=ALL-UNNAMED,jdk.jsobject, --add-exports=java.naming/com.sun.jndi.toolkit.url=ALL-UNNAMED,java.desktop, -Dicedtea-web.bin.name=javaws, -Dicedtea-web.bin.location=/usr/lib/icedtea-web/bin/javaws]
Dataset consistency test: No problems found

Plugins:
+ buildings_tools (34982)
+ ext_tools (34988)
+ pointInfo (34908)
+ scripting (30794)
+ todo (30306)
+ utilsplugin2 (34977)

Map paint styles:
+ ${HOME}/josm/Es_Styles_Coloured_buildings-style.mapcss
+ https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_buildings&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/ColourTag&zip=1

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.
- W: Ext_Tools warning: can not load file <josm.userdata>/plugins/ext_tools/tools.cfg
- W: Ext_Tools warning: can not load file <josm.userdata>/plugins/ext_tools/repo.cfg
- W: Region [WMTS_BLOCK_v2] Resetting cache
- E: Handled by bug report queue: java.lang.NoClassDefFoundError: javax/script/ScriptEngineFactory. Causa: java.lang.ClassNotFoundException: javax.script.ScriptEngineFactory
- E: Handled by bug report queue: java.lang.NoClassDefFoundError: javax/script/ScriptEngineFactory


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-1 (25) of JOSM
java.lang.NoClassDefFoundError: javax/script/ScriptEngineFactory
	at org.openstreetmap.josm.plugins.scripting.model.JSR223ScriptEngineProvider.loadScriptEngineFactories(JSR223ScriptEngineProvider.java:162)
	at org.openstreetmap.josm.plugins.scripting.model.JSR223ScriptEngineProvider.<init>(JSR223ScriptEngineProvider.java:169)
	at org.openstreetmap.josm.plugins.scripting.model.JSR223ScriptEngineProvider.getInstance(JSR223ScriptEngineProvider.java:60)
	at org.openstreetmap.josm.plugins.scripting.ui.RunScriptService.deriveOrAskScriptEngineDescriptor(RunScriptService.java:91)
	at org.openstreetmap.josm.plugins.scripting.ui.MostRecentlyRunScriptsModel$RunScriptAction.actionPerformed(MostRecentlyRunScriptsModel.java:147)
	at java.desktop/javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1967)
	at java.desktop/javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2308)
	at java.desktop/javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:405)
	at java.desktop/javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:262)
	at java.desktop/javax.swing.AbstractButton.doClick(AbstractButton.java:369)
	at java.desktop/javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:1020)
	at java.desktop/javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:1064)
	at java.desktop/java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:297)
	at java.desktop/java.awt.Component.processMouseEvent(Component.java:6632)
	at java.desktop/javax.swing.JComponent.processMouseEvent(JComponent.java:3342)
	at java.desktop/java.awt.Component.processEvent(Component.java:6397)
	at java.desktop/java.awt.Container.processEvent(Container.java:2263)
	at java.desktop/java.awt.Component.dispatchEventImpl(Component.java:5008)
	at java.desktop/java.awt.Container.dispatchEventImpl(Container.java:2321)
	at java.desktop/java.awt.Component.dispatchEvent(Component.java:4840)
	at java.desktop/java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4918)
	at java.desktop/java.awt.LightweightDispatcher.processMouseEvent(Container.java:4547)
	at java.desktop/java.awt.LightweightDispatcher.dispatchEvent(Container.java:4488)
	at java.desktop/java.awt.Container.dispatchEventImpl(Container.java:2307)
	at java.desktop/java.awt.Window.dispatchEventImpl(Window.java:2772)
	at java.desktop/java.awt.Component.dispatchEvent(Component.java:4840)
	at java.desktop/java.awt.EventQueue.dispatchEventImpl(EventQueue.java:772)
	at java.desktop/java.awt.EventQueue$4.run(EventQueue.java:721)
	at java.desktop/java.awt.EventQueue$4.run(EventQueue.java:715)
	at java.base/java.security.AccessController.doPrivileged(Native Method)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:85)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:95)
	at java.desktop/java.awt.EventQueue$5.run(EventQueue.java:745)
	at java.desktop/java.awt.EventQueue$5.run(EventQueue.java:743)
	at java.base/java.security.AccessController.doPrivileged(Native Method)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:85)
	at java.desktop/java.awt.EventQueue.dispatchEvent(EventQueue.java:742)
	at java.desktop/java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:203)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:124)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:113)
	at java.desktop/java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:109)
	at java.desktop/java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.desktop/java.awt.EventDispatchThread.run(EventDispatchThread.java:90)

Attachments (0)

Change History (7)

comment:1 Changed 6 weeks ago by Don-vip

Description: modified (diff)
Keywords: javascript jsr223 added
Summary: the script "SelectNonOrthogonalBuildings does not workNoClassDefFoundError: javax/script/ScriptEngineFactory

comment:2 Changed 6 weeks ago by Don-vip

Component: CorePlugin scripting
Owner: changed from team to Gubaer

comment:3 Changed 4 weeks ago by Don-vip

Component: Plugin scriptingCore
Keywords: java11 linux ubuntu added
Milestone: 19.05
Owner: changed from Gubaer to team

comment:4 Changed 4 weeks ago by Don-vip

Resolution: fixed
Status: newclosed

In 15128/josm:

see #16047, see #16498, see #17516, fix #17723

  • add java.scripting module when loading JOSM with Java 11+
  • detect java 12/13 on Linux

comment:5 Changed 5 days ago by Klumbumbus

possibly not fixed: #17839

comment:6 Changed 5 days ago by Don-vip

Ticket #17839 has been marked as a duplicate of this ticket.

comment:7 Changed 5 days ago by Don-vip

It is fixed but I forgot to deploy .jnlp files

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.