Modify

Opened 7 months ago

Closed 7 months ago

Last modified 7 months ago

#17699 closed defect (fixed)

Discrepancy between Filter text caption and working Search string

Reported by: baradam Owned by: team
Priority: minor Milestone: 19.05
Component: Core Version:
Keywords: filter search Cc:

Description

What steps will reproduce the problem?

  1. Go to the filter window.
  2. Create filter.
  3. Example of formats. landuse=* , landuse=farmland , landuse |farmland

The object should go to the background or disappear completely is so selected.

Other landuse that are select seem to work appropriately.

Map location for example: https://www.openstreetmap.org/#map=20/44.21518454459982/-116.94241195039284

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2019-04-28 04:36:41 +0200 (Sun, 28 Apr 2019)
Build-Date:2019-04-28 02:37:58
Revision:15031
Relative:URL: ^/trunk

Identification: JOSM/1.5 (15031 en) Windows 10 64-Bit
OS Build number: Windows 10 Pro 1809 (17763)
Memory Usage: 929 MB / 1820 MB (225 MB allocated, but free)
Java version: 1.8.0_211-b12, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1080, \Display1 1920x1080, \Display2 3840x2160
Maximum Screen Size: 3840x2160
Program arguments: [%UserProfile%\Desktop\Weiser Grid Layer.osm]
Dataset consistency test: No problems found

Plugins:
+ AddrInterpolation (34908)
+ BuildingGeneralization (23)
+ ColorPlugin (1537115529)
+ Create_grid_of_ways (34908)
+ EasyPresets (1537621333)
+ FastDraw (34977)
+ FixAddresses (34977)
+ HouseNumberTaggingTool (34977)
+ ImproveWay (26)
+ PicLayer (34908)
+ ShapeTools (1240)
+ alignways (34977)
+ apache-commons (34908)
+ auto_tools (73)
+ buildings_tools (34982)
+ continuosDownload (82)
+ contourmerge (v0.1.4)
+ dataimport (34908)
+ editgpx (34908)
+ ejml (34908)
+ geojson (124)
+ geotools (34908)
+ imagery_offset_db (34908)
+ importvec (34908)
+ jaxb (34908)
+ jts (34908)
+ measurement (34977)
+ merge-overlap (34972)
+ opendata (34977)
+ osmarender (34908)
+ pbf (34908)
+ pdfimport (34977)
+ photoadjust (34977)
+ reltoolbox (34977)
+ splinex (34908)
+ tageditor (34977)
+ terracer (34977)
+ todo (30306)
+ turnlanes (${version.entry.commit.revision})
+ turnlanes-tagging (281)
+ turnrestrictions (34977)
+ utilsplugin2 (34977)
+ wikipedia (v1.1.1)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/BuildingPreset&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Crafts&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Historical_Objects&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Mountains&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/OneClick&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Playground_Equipment&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Quick-highways&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/PublicTransportOneClick&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/BicycleJunction&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Communication_Towers&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/NewParkingFeatures&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Quick-stops&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Golf_Course&zip=1

Last errors/warnings:
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet

Attachments (1)

2019-05-08_14-08-13.jpg (235.0 KB) - added by baradam 7 months ago.
location of error

Download all attachments as: .zip

Change History (12)

Changed 7 months ago by baradam

Attachment: 2019-05-08_14-08-13.jpg added

location of error

comment:1 Changed 7 months ago by Hb---

Keywords: filter search added; template_report removed
Summary: Farmland does not seem to filter out.Discrepancy between Search string and Filter text (Farmland does not seem to filter out.)

To verify:

  1. Add a filter with the search string building=yes.
  2. Click Submit filter.
  3. Double click this filters Text column in the filter panel. The field becomes editable.
  4. Change the filters Text to building=ys and hit the Enter key. Now the buildings are still disabled. This is the bug.
  1. Click Edit. The search strings appears as building=ys now.
  2. Do not change the search string and click Submit filter.
  3. The filter result is correct now as all buildings are enabled.
Last edited 7 months ago by Hb--- (previous) (diff)

comment:2 Changed 7 months ago by anonymous

My problem is not filtering building but with filtering the landuse of farmland. As it is the building remain, landuse for industrials are removed but farmland seems to not be the correct search word for no matter which format in the Boolean search it does not seem to find the term "farmland".

comment:3 Changed 7 months ago by Hb---

My description above would work with landuse=farmland and landuse=frmland too. I took another string for the ease of the example.

Filtering with landuse=farmland on the location given works fine here. Did you try to verify this bug after a fresh start of JOSM with only one filter?

Last edited 7 months ago by Hb--- (previous) (diff)

comment:4 Changed 7 months ago by anonymous

Let me try after a fresh start of JOSM. I have had this problem for sometime and sure that I've tried it alone but who knows.

comment:5 Changed 7 months ago by anonymous

Funny, it seems to work with any of my filter now. Thx for the fix...

comment:6 Changed 7 months ago by Hb---

Priority: normalminor
Summary: Discrepancy between Search string and Filter text (Farmland does not seem to filter out.)Discrepancy between Filter text caption and working Search string

The discrepancy issue is still open.

comment:7 Changed 7 months ago by anonymous

As in my situation this time, I am using it as a filter to disable content. On other occasions, I have used it as a search function to find specific ways or as in the download data to only get the city boundary. So, search or filter depends on how you use the feature. Some time back, I used it to find a regional error I had uploaded by using the copy tag command. In that instance it was a search but normally I'd call it a filter where I use it not to attach landuse to roads which is a pain to separate when reassigning landuse.

comment:8 Changed 7 months ago by GerdP

If I got that right we can just disable the possibility to edit the field in the list so that one has to press the Edit button?

comment:9 Changed 7 months ago by Hb---

Disabling the field seems to be a valid solution.

Usually a double click opens the dialog to edit the entry. This seems to be the best solution.

Please give #14208 some love too.

Last edited 7 months ago by Hb--- (previous) (diff)

comment:10 Changed 7 months ago by GerdP

Resolution: fixed
Status: newclosed

In 15065/josm:

fix #17699: Make sure that a changed filter is used

comment:11 Changed 7 months ago by Klumbumbus

Milestone: 19.05

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.