Modify

Opened 6 months ago

Closed 5 months ago

#17691 closed defect (fixed)

[PATCH] Fix issue where SimilarNamedWay crashes on a subset of names

Reported by: taylor.smock Owned by: team
Priority: normal Milestone: 19.05
Component: Core validator Version:
Keywords: Cc:

Description (last modified by taylor.smock)

For some reason, the test crashes when "Milwaukee Brat House" and "Who's On Third" are compared.

In this patch, I've added a regression test to SimilarNamedWaysTests and a to make certain we are within the bounds of the string.

In the test case, the important name for testing is "Who's On Third" -- the other just happened to be a nearby building with a name.

From IRC:

@skquinn
(opening_hours=* or service_times=* or collection_times=*) in Wisconsin
can someone with JOSM feed this to the Overpass query wizard and see if they get an error when parsing the data returned?
specifically a java.lang.StringIndexOutOfBoundsException: String index out of range: 15
@Richlv
skquinn, failed for me, but did not give a detailed reason in the ui
@skquinn
Richlv: so you got the same error? so this indeed might be a JOSM bug and not my aging laptop acting throwed off again
@simonpoole
maxerickson
well it isn't an overpass error
and it works for me
latest josm release
@skquinn
hmm
try validating the data
that's what I think triggered it
@simonpoole
yes that crashes
I would very very much suspecta JOSM bug by the looks of where it borks

Attachments (2)

17691.patch (1.5 KB) - added by taylor.smock 6 months ago.
Add test for a previously known crash and fix the crash
17691_v2.patch (1.5 KB) - added by taylor.smock 6 months ago.
Modify the test case to be clear that one name is unnecessary while the other previously crashed and minimize the crash name to the smallest possible string (Third)

Download all attachments as: .zip

Change History (6)

Changed 6 months ago by taylor.smock

Attachment: 17691.patch added

Add test for a previously known crash and fix the crash

comment:1 Changed 6 months ago by taylor.smock

Description: modified (diff)

Changed 6 months ago by taylor.smock

Attachment: 17691_v2.patch added

Modify the test case to be clear that one name is unnecessary while the other previously crashed and minimize the crash name to the smallest possible string (Third)

comment:2 Changed 6 months ago by taylor.smock

Description: modified (diff)

comment:3 Changed 5 months ago by Don-vip

Milestone: 19.05

comment:4 Changed 5 months ago by Don-vip

Resolution: fixed
Status: newclosed

In 15079/josm:

fix #17691 - fix issue where SimilarNamedWay crashes on a subset of names (patch by taylor.smock)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.