Modify

Opened 7 months ago

Closed 7 months ago

Last modified 7 months ago

#17635 closed defect (fixed)

NPE at PropertiesDialog.selectionChanged when selecting object from geojson file

Reported by: ibemerson@… Owned by: team
Priority: normal Milestone: 19.04
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. load geojson file
  2. click on an object

What is the expected result?

The selected object's tags and info should display in the boxes on the right side of screen.

What happens instead?

An error box instantly pops up. Every Time. If error is ignored, JOSM does not display any existing tags for the selected object. All the boxes on the right of screen act as if no object is selected. If I click "Edit" then click "Edit tags" the box that pops up lists all the objects tags and I can edit them there normally.

Please provide any additional information below. Attach a screenshot if possible.

The errors began right after updating to latest version. The geojson files worked fine on previous versions.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2019-03-31 21:17:00 +0200 (Sun, 31 Mar 2019)
Build-Date:2019-03-31 20:25:18
Revision:14945
Relative:URL: ^/trunk

Identification: JOSM/1.5 (14945 en) Windows 7 64-Bit
OS Build number: Windows 7 Professional (7601)
Memory Usage: 695 MB / 989 MB (329 MB allocated, but free)
Java version: 1.8.0_211-b12, Oracle Corporation, Java HotSpot(TM) Client VM
Screen: \Display0 1920x1200, \Display1 1280x1024
Maximum Screen Size: 1920x1200
Dataset consistency test: No problems found

Plugins:
+ DxfImport (1013)
+ ImproveOsm (167)
+ Mapillary (1.5.18)
+ OpenStreetCam (230)
+ apache-commons (34908)
+ apache-http (34908)
+ buildings_tools (34904)
+ changeset-viewer (22)
+ continuosDownload (82)
+ ejml (34908)
+ geochat (34977)
+ geojson (122)
+ geotools (34908)
+ imagery_offset_db (34908)
+ jaxb (34908)
+ jna (34908)
+ jts (34908)
+ measurement (34977)
+ opendata (34911)
+ pdfimport (34977)
+ print (34867)
+ tageditor (34977)
+ turnlanes-tagging (281)
+ turnrestrictions (34977)
+ utilsplugin2 (34977)

Map paint styles:
+ https://josm.openstreetmap.de/josmfile?page=Styles/Admin_Boundaries&zip=1
- https://www.dropbox.com/s/qo3ai47fpv241jf/Styles_Fixme_and_Notes.zip?raw=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Fixme&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Highway_Nodes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Landcover&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/LessObtrusiveNodes&zip=1
+ https://pasharm.github.io/New_basic_style_for_JOSM/New_basic_style.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/ParkingLanes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Noname&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/TigerReviewedNo&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.
- E: Handled by bug report queue: java.lang.NullPointerException
- E: Handled by bug report queue: java.lang.NullPointerException
- E: Handled by bug report queue: java.lang.NullPointerException
- E: Handled by bug report queue: java.lang.NullPointerException
- E: Handled by bug report queue: java.lang.NullPointerException
- E: Handled by bug report queue: java.lang.NullPointerException
- E: Handled by bug report queue: java.lang.NullPointerException
- E: Handled by bug report queue: java.lang.NullPointerException


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (15) of main
java.lang.NullPointerException
	at java.util.TreeMap.compare(Unknown Source)
	at java.util.TreeMap.put(Unknown Source)
	at org.openstreetmap.josm.gui.dialogs.properties.PropertiesDialog.selectionChanged(PropertiesDialog.java:588)
	at org.openstreetmap.josm.data.osm.event.SelectionEventManager$DataListenerInfo.fire(SelectionEventManager.java:57)
	at org.openstreetmap.josm.data.osm.event.SelectionEventManager.fireEvent(SelectionEventManager.java:159)
	at org.openstreetmap.josm.data.osm.event.SelectionEventManager.lambda$selectionChanged$0(SelectionEventManager.java:150)
	at org.openstreetmap.josm.gui.util.GuiHelper.runInEDTAndWaitWithException(GuiHelper.java:238)
	at org.openstreetmap.josm.data.osm.event.SelectionEventManager.selectionChanged(SelectionEventManager.java:150)
	at org.openstreetmap.josm.data.osm.DataSet.lambda$doSelectionChange$5(DataSet.java:684)
	at org.openstreetmap.josm.tools.ListenerList.fireEvent(ListenerList.java:150)
	at org.openstreetmap.josm.data.osm.DataSet.doSelectionChange(DataSet.java:684)
	at org.openstreetmap.josm.data.osm.DataSet.setSelected(DataSet.java:615)
	at org.openstreetmap.josm.data.osm.DataSet.setSelected(DataSet.java:606)
	at org.openstreetmap.josm.actions.mapmode.SelectAction.selectPrims(SelectAction.java:990)
	at org.openstreetmap.josm.actions.mapmode.SelectAction.mousePressed(SelectAction.java:442)
	at java.awt.AWTEventMulticaster.mousePressed(Unknown Source)
	at java.awt.AWTEventMulticaster.mousePressed(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (2)

JOSM_Error.png (216.0 KB) - added by ibemerson@… 7 months ago.
screenshot
BrocktonOpenSpace_WGS84.geojson (246.5 KB) - added by ibemerson@… 7 months ago.
Sample geojson file that triggered error

Download all attachments as: .zip

Change History (6)

Changed 7 months ago by ibemerson@…

Attachment: JOSM_Error.png added

screenshot

Changed 7 months ago by ibemerson@…

Sample geojson file that triggered error

comment:1 Changed 7 months ago by Don-vip

Milestone: 19.04
Summary: Exception error when selecting object from geojson fileNPE at PropertiesDialog.selectionChanged when selecting object from geojson file

comment:2 Changed 7 months ago by Don-vip

In 15014/josm:

see #17635 - make sure primitives can't be created with invalid tags using setKeys method

comment:3 Changed 7 months ago by Don-vip

Resolution: fixed
Status: newclosed

comment:4 Changed 7 months ago by Don-vip

Ticket #17636 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.