Modify

Opened 6 weeks ago

Closed 6 weeks ago

#17427 closed defect (fixed)

HTML in imagery tooltips

Reported by: Zverikk Owned by: team
Priority: normal Milestone: 19.03
Component: Core Version: latest
Keywords: menu tooltips html Cc: stoecker

Description (last modified by Don-vip)

Open the Imagery menu and read tooltips for the entries. They contain <br> tags instead of newlines. I guess they should not.


Attachments (2)

Screenshot 2019-03-06 at 12.12.13.png (149.6 KB) - added by Zverikk 6 weeks ago.
ImageryTooltipCollage.png (86.0 KB) - added by Klumbumbus 6 weeks ago.

Download all attachments as: .zip

Change History (9)

Changed 6 weeks ago by Zverikk

comment:1 Changed 6 weeks ago by Don-vip

Description: modified (diff)
Keywords: html added

comment:2 Changed 6 weeks ago by Don-vip

Cc: stoecker added

Probably related to r11625

comment:3 Changed 6 weeks ago by Don-vip

@stoecker: reverting r11625 fixes the issue on Windows. Can you please check on Linux as well? Maybe this was needed two years ago because of a Java bug since fixed?

  • src/org/openstreetmap/josm/actions/AddImageryLayerAction.java

     
    6969     * @param info The imagery info
    7070     */
    7171    public AddImageryLayerAction(ImageryInfo info) {
    72         super(info.getMenuName(), /* ICON */"imagery_menu", tr("Add imagery layer {0}", info.getName()), null,
     72        super(info.getMenuName(), /* ICON */"imagery_menu", info.getToolTipText(), null,
    7373                true, ToolbarPreferences.IMAGERY_PREFIX + info.getToolbarName(), false);
    7474        setHelpId(ht("/Preferences/Imagery"));
    75         setTooltip(info.getToolTipText().replaceAll("</?html>", ""));
    7675        this.info = info;
    7776        installAdapters();
Last edited 6 weeks ago by Don-vip (previous) (diff)

comment:4 Changed 6 weeks ago by Don-vip

Milestone: 19.03

Changed 6 weeks ago by Klumbumbus

Attachment: ImageryTooltipCollage.png added

comment:5 Changed 6 weeks ago by Klumbumbus

See ImageryTooltipCollage.png
In the preferences it works while in the Imagery menu and the toolbar not. And in the layer list there is a different tooltip. Maybe the tooltips could be unified.

comment:6 Changed 6 weeks ago by Don-vip

OK thanks. With my patch it works both in menu and preferences table.

comment:7 Changed 6 weeks ago by Don-vip

Resolution: fixed
Status: newclosed

In 14862/josm:

fix #17427 - fix imagery html tooltip (regression of r11625?)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.