Modify

Opened 3 months ago

Closed 2 months ago

Last modified 7 weeks ago

#17414 closed defect (fixed)

Wrong translations for fire hydrants

Reported by: rasenack@… Owned by: Hb---
Priority: normal Milestone: 19.03
Component: Core Version:
Keywords: i18n german Cc:

Description

For fire hydrants in the dialog box there are wrong translations for language german:

  • property "form": "underground" is translated to "Tiefgarage" (means underground parking), should be "Unterflur"
  • property "position": "lane" is translated to "Fahrradstreifen" (means bycicle lane), should be "Fahrbahn"
  • property "color of hydrant head": "green" is translated to "Grünfläche" (means green area or lawn), should be "Grün"
  • property "color of caps": same as for "head"

Used version: 14824
It had been correct some version before...

Attachments (2)

17414.png (15.9 KB) - added by Klumbumbus 3 months ago.
17414b.PNG (7.7 KB) - added by Klumbumbus 3 months ago.

Download all attachments as: .zip

Change History (13)

comment:1 Changed 3 months ago by Don-vip

Keywords: i18n german added

The translations are done by the community. I don't speak German, see Translations#Software to see how to fix the translations by yourself.

comment:2 Changed 3 months ago by Klumbumbus

Owner: changed from team to Hb---

@ Hb---: it seems you changed it. An oversight?


Changed 3 months ago by Klumbumbus

Attachment: 17414.png added

comment:3 Changed 3 months ago by Klumbumbus

Milestone: 19.03

Hm, and for colour, bonnet:colour and cap:colour translations context is missing to reuse already existing color translations.

Last edited 3 months ago by Klumbumbus (previous) (diff)

comment:4 Changed 3 months ago by Hb---

It seems that I made that mistake online in Launchpad online.

Turns out that OmegaT cannot has difficulties to handle msgctxt information, https://sourceforge.net/p/omegat/feature-requests/429/ So this "Tiefgarage" is probably not the only error I made.

I will correct the translation as soon as possible. Please feel free to change the preset code.

The attribution in Launchpad between translation and author is not error free. See https://translations.launchpad.net/josm/trunk/+pots/josm/de/636/+translate The translation Sollen Objekte mit Linien, die durch Filter ausgeblendet sind, wirklich verschoben werden? was made by me and not by Stephan. I still need to file a bug for this against Launchpad.

How is it going with Transifex?

Last edited 7 weeks ago by Hb--- (previous) (diff)

comment:5 Changed 3 months ago by Klumbumbus

In 14829/josm:

see #17414, see #15774 - set correct values_context for colour tags in hydrant preset

comment:6 Changed 3 months ago by Hb---

I uploaded the correction to https://translations.launchpad.net/josm/trunk/+imports
In about three hours Launchpad should have computed it and tomorrow josm-latest should be fine again.

  • .po

    old new  
    2381823818msgid "waterway"
    23819 msgstr "Gewässer"
     23819msgstr "Wasserlauf"
    2382023820
     
    2383023830msgid "locality"
    23831 msgstr "Ortschaft"
     23831msgstr "Unbewohnte Örtlichkeit (Gewann, Flur)"
    2383223832
     
    2571825718msgid "pitch"
    25719 msgstr "Reitplatz"
     25719msgstr "Spielfeld"
    2572025720
     
    2695726957msgid "underground"
    26958 msgstr "Tiefgarage"
     26958msgstr "unterirdisch"
    2695926959
     
    2750527505msgid "ground"
    27506 msgstr "Erde"
     27506msgstr "bodenmontiert"
    2750727507
     
    2764927649msgid "green"
    27650 msgstr "Grünfläche"
     27650msgstr "Grün"
    2765127651
     
    2821228212msgid "residential"
    28213 msgstr "Wohngebiet"
     28213msgstr "Ortsstraße"
    2821428214
     
    2846228462msgid "track"
    28463 msgstr "Rennbahn"
     28463msgstr "Feld- oder Waldweg"
    2846428464
     
    2892028920msgid "track"
    28921 msgstr "Rennbahn"
     28921msgstr "Separater Radweg"
    2892228922
     
    2983729837msgid "transportation"
    29838 msgstr "Transportwesen"
     29838msgstr "Einzeltransport"
    2983929839
     
    2984329843msgid "transmission"
    29844 msgstr ">100 kV"
     29844msgstr "Verteilung"
    2984529845
     
    2992629926msgid "underground"
    29927 msgstr "Tiefgarage"
     29927msgstr "Unterflur"
    2992829928
     
    3087430874msgid "Station"
    30875 msgstr "Bahnhof"
     30875msgstr "Station"
    3087630876
     
    3127331273msgid "Service"
    31274 msgstr "Zufahrtsstraße"
     31274msgstr "Autoservice"
    3127531275
     
    3190231902msgid "Beacon"
    31903 msgstr "Leuchtfeuer"
     31903msgstr "Flugnavigationsfunkfeuer"
    3190431904
     
    3192431924msgid "Gate"
    31925 msgstr "Gatter / Tor"
     31925msgstr "Flugsteig/Gate"
    3192631926
     
    3228132281msgid "site"
    32282 msgstr "Gelände"
     32282msgstr "Örtlichkeit"
    3228332283
     
    3261332613msgid "Fuel"
    32614 msgstr "Tankstelle"
     32614msgstr "Heizmaterial"
    3261532615
     
    3334133341msgid "wall"
    33342 msgstr "Mauer"
     33342msgstr "Wand"
    3334333343
     
    3345533455msgid "lane"
    33456 msgstr "Radfahrstreifen"
     33456msgstr "Fahrbahn"
    3345733457
     
    3374533745msgid "Shelter"
    33746 msgstr "Unterstand"
     33746msgstr "Unterkunft"
    3374733747
     
    3384833848msgid "pillar"
    33849 msgstr "Überflurhydrant"
     33849msgstr "Säule"
    3385033850
     
    3385433854msgid "lamp"
    33855 msgstr "Lampe"
     33855msgstr "Hängend (an Lampe oder Pfosten)"
    3385633856
     
    3386033860msgid "wall"
    33861 msgstr "Mauer"
     33861msgstr "Eingelassen"
    3386233862
     
    3389433894msgid "Notes"
    33895 msgstr "Hinweise"
     33895msgstr "Geldscheine"
    3389633896
     
    3419934199msgid "Hide"
    34200 msgstr "Verstecken"
     34200msgstr "Ebenerdig"
    3420134201
     
    3441434414msgid "pitch"
    34415 msgstr "Reitplatz"
     34415msgstr "Spielfeld"
    3441634416
     
    3444734447msgid "track"
    34448 msgstr "Rennbahn"
     34448msgstr "Laufbahn"
    3444934449
     
    3460234602msgid "pitch"
    34603 msgstr "Reitplatz"
     34603msgstr "Bahn"
    3460434604
     
    3464234642msgid "track"
    34643 msgstr "Rennbahn"
     34643msgstr "Strecke"
    3464434644
     
    3500635006msgid "pitch"
    35007 msgstr "Reitplatz"
     35007msgstr "Bahn"
    3500835008
     
    3501835018msgid "track"
    35019 msgstr "Rennbahn"
     35019msgstr "Bahn"
    3502035020
     
    3507635076msgid "service"
    35077 msgstr "Zufahrtsstraße"
     35077msgstr "Wirtschaftsgebäude"
    3507835078
     
    3527935279msgid "public"
    35280 msgstr "öffentlich"
     35280msgstr "Öffentliches Gebäude"
    3528135281
     
    3530635306msgid "residential"
    35307 msgstr "Wohngebiet"
     35307msgstr "Wohngebäude"
    3530835308
     
    3539735397msgid "main"
    35398 msgstr "Haupt"
     35398msgstr "Haupteingang"
    3539935399
     
    3540335403msgid "service"
    35404 msgstr "Zufahrtsstraße"
     35404msgstr "Nebeneingang"
    3540535405
     
    3584135841msgid "Beacon"
    35842 msgstr "Leuchtfeuer"
     35842msgstr "Bake"
    3584335843
     
    3603036030msgid "wall"
    36031 msgstr "Mauer"
     36031msgstr "Wand"
    3603236032
     
    3624936249msgid "underground"
    36250 msgstr "Tiefgarage"
     36250msgstr "unterirdisch"
    3625136251
     
    3715737157msgid "suspension"
    37158 msgstr "Hängebrücke"
     37158msgstr "Aufhängung"
    3715937159
     
    3717537175msgid "branch"
    37176 msgstr "Zweig"
     37176msgstr "Nebenstromleitung"
    3717737177
     
    3734137341msgid "bipole"
    37342 msgstr "bipole"
     37342msgstr "Doppelmast"
    3734337343
     
    3742937429msgid "single"
    37430 msgstr "einfach"
     37430msgstr "1 - einfach"
    3743137431
     
    3884438844msgid "Administrative"
    38845 msgstr "Behörde"
     38845msgstr "Innerstaatlich"
    3884638846
     
    3902039020msgid "Locality"
    39021 msgstr "Unbewohnter Ort"
     39021msgstr "Unbewohnte Örtlichkeit (Gewann, Flur)"
    3902239022
     
    3923539235msgid "agricultural"
    39236 msgstr "Landwirtschaftlicher Verkehr gestattet"
     39236msgstr "Landwirtschaftlich"
    3923739237
     
    3926539265msgid "Wood"
    39266 msgstr "Holz"
     39266msgstr "Naturwald"
    3926739267
     
    3997539975msgid "State"
    39976 msgstr "Bundesland"
     39976msgstr "Bundesstaat (v.a. USA)"
    3997739977
     
    4754647546msgid "City"
    47547 msgstr "Großstadt"
     47547msgstr "Stadt"
    4754847548
     
    4970249702msgid "section"
    49703 msgstr "Waldstückgrenze"
     49703msgstr "Abschnitt"
    4970449704

comment:7 in reply to:  6 Changed 3 months ago by Klumbumbus

Resolution: fixed
Status: newclosed

Replying to Hb---:

tomorrow josm-latest should be fine again.

Nah, only after a manual i18n update in the josm svn. However since the changes are imported in Launchpad we can close this ticket.

comment:8 Changed 3 months ago by Klumbumbus

Btw, the translation for lane in hydrant context is now marked as translated by dirk in 2011. So maybe thats the reason why you sometimes see other translators, because someone already translated it the same way in a previous version.


Last edited 3 months ago by Klumbumbus (previous) (diff)

Changed 3 months ago by Klumbumbus

Attachment: 17414b.PNG added

comment:9 Changed 2 months ago by Klumbumbus

Ticket #17446 has been marked as a duplicate of this ticket.

comment:10 Changed 2 months ago by Hb---

Resolution: fixed
Status: closedreopened

I placed a note on the StartupPageSource@2505:2507 to prevent further bug reports until the corrected translations is published.

comment:11 Changed 2 months ago by Don-vip

Resolution: fixed
Status: reopenedclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Hb---.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.