Modify

Opened 8 weeks ago

Closed 5 weeks ago

#17391 closed enhancement (fixed)

complain about unreasonably narrow highway=pedestrian

Reported by: mkoniecz Owned by: team
Priority: normal Milestone: 19.03
Component: Core validator Version:
Keywords: template_report Cc:

Description (last modified by mkoniecz)

What steps will reproduce the problem?

  1. Create way
  2. Tag it highway=pedestrian width=0.5 name=Foobar
  3. Run validator

What is the expected result?

Validator offers automatic fix to highway=footway

What happens instead?

Nothing.

Please provide any additional information below. Attach a screenshot if possible.

I propose 2 m as the edge value. Optionally 1 m.

Inspired by https://lists.openstreetmap.org/pipermail/tagging/2019-February/043221.html

Venice is a globally unique (or maybe almost unique) exception anyway, but
what we currently have there is the result of people reclassifying all the
footways as pedestrian roads, even if they are 50 cm wide. I have started
in the past several attempts to open a discussion on this, but it felt like
Don Quixote. See this as an example:
https://www.openstreetmap.org/way/488627565/history I have surveyed it
myself, like many others, where I began to reclassify the very narrow
footpaths from pedestrian to footway, but I am not local and people destroy
the finer grained distinction of footway and pedestrian as soon as you add
them, I guess they do not want the red dots. It is unfortunate, because it
makes the Venice map much harder to read and less useful. If you are local,
please try to improve the situation, we do not need new tags, it would be
sufficient to apply the existing ones consistently rather than
indiscriminately.

iD equivalent at https://github.com/openstreetmap/iD/issues/5991

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2019-02-23 17:46:51 +0100 (Sat, 23 Feb 2019)
Build-Date:2019-02-24 02:30:49
Revision:14802
Relative:URL: ^/trunk

Identification: JOSM/1.5 (14802 en) Linux Ubuntu 16.04.5 LTS
Memory Usage: 418 MB / 869 MB (182 MB allocated, but free)
Java version: 1.8.0_201-b09, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: :0.0 1920x1080
Maximum Screen Size: 1920x1080
Dataset consistency test: No problems found

Plugins:
+ OpeningHoursEditor (34867)
+ buildings_tools (34867)
+ continuosDownload (82)
+ imagery_offset_db (34867)
+ measurement (34867)
+ reverter (34867)
+ todo (30306)

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.

Attachments (0)

Change History (13)

comment:1 Changed 8 weeks ago by mkoniecz

Description: modified (diff)

comment:2 Changed 8 weeks ago by mkoniecz

Description: modified (diff)

comment:4 Changed 8 weeks ago by Klumbumbus

Milestone: 19.03

I think 2m is a reasonable threshold. The question is should it warn for <2 or <=2?
We have 1656 highway=pedestrian ways with width=2 spreed all over the world (only one of them in venice) (wizard query: type:way and highway=pedestrian and width=2 global). I would say <2 as 2m could already be acessible even for two-track vehicles.

comment:5 Changed 8 weeks ago by mkoniecz

Also, 2m may be case of "well, it looks about 2m wide" and in reality be for example 3m wide.

Something estimated to be 1m wide or measured precisely is much more likely to not be significantly wider than tagged.

After all, it is better to catch some blatant mistagging rather than all mistaggings and many false positives (especially with an autofix!).

Last edited 8 weeks ago by mkoniecz (previous) (diff)

comment:6 Changed 7 weeks ago by Klumbumbus

Resolution: fixed
Status: newclosed

In 14831/josm:

  • fix #17305 - warn about boundary=administrative together with landuse=residential
  • fix #17391 - warn about highway=pedestrian together with width<2

comment:7 Changed 7 weeks ago by Klumbumbus

In 14840/josm:

fix #17423, see #17391 - fix warning about highway=pedestrian together with width<2

comment:8 Changed 6 weeks ago by dieterdreist

I would make the threshold at least 3m. A 2m wide way (and likely even 3m) is still a footway, not a road that would be a normal road if there wasn't a legal restriction.

A road which is 2 meters wide will not offer room for a normal to small car to pass a single pedestrian walking on it, without putting both into an exceptional state (because of the close passing by). Cars may be up to 2,50 wide according to many jurisdictions, typical cars will be something like ~1.65 (Fiat Panda / smart) to ~1.85 (limousine) to 2 m (SUV). A 2 m car will not be able to use a 2 m road (particularly not in urban setting between buildings and walls, typical for pedestrian streets), and even with a Fiat Panda, there are only 0.35 m remaining for the pedestrians (think about a wheelchair, 1m wide, or a baby stroller or obese people).
A typical pedestrian road is more something like 8 meters wide.

For reference on car dimensions: https://de.automobiledimension.com/abmessungen-autos-land-rover.html

comment:9 Changed 6 weeks ago by Klumbumbus

Resolution: fixed
Status: closedreopened

comment:10 Changed 6 weeks ago by mkoniecz

I initially proposed 2 m to never, ever have false positives. In general, avoiding false positives is for me the highest priority in a well working validator.

I can imagine at least fragments of valid highway=pedestrian of quite narrow width.

Though probably 3 m as edge value will not be problematic.

comment:11 Changed 6 weeks ago by dieterdreist

Yes, I understand a reasonable warning threshold should be on the safe side. I agree <=3m will be safe.
Do not underestimate that people will be also using this to check what is "reasonable". 1.8m gives a warning, but 2 does not? So the limit must be 2 ;-)

comment:12 Changed 6 weeks ago by Klumbumbus

I would say it is not wrong to tag this as highway pedestrian. My quick and dirty geometric calculations in paint ;) resulted a width of 3,33m (assuming the girl is 1,55m tall). So it is potentially even <3m at some sections.

So I prefer the warning at <3, not <=3.

comment:13 Changed 5 weeks ago by Klumbumbus

Resolution: fixed
Status: reopenedclosed

In 14910/josm:

fix #17391 - raise warning threshold about narrow highway=pedestrian to 3

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.