Modify

Opened 2 months ago

Closed 8 weeks ago

Last modified 8 weeks ago

#17371 closed enhancement (fixed)

[PATCH] add combination checks based off KeepRight and Osmose

Reported by: abalosc1 Owned by: team
Priority: normal Milestone: 19.02
Component: Core validator Version:
Keywords: Cc:

Description


Attachments (2)

combinationmapcss.patch (3.0 KB) - added by abalosc1 2 months ago.
updated to include some combinations from osmose checks
combinationmapcss.2.patch (1.9 KB) - added by abalosc1 8 weeks ago.
updated some to be info level warnings. removed place without name

Download all attachments as: .zip

Change History (14)

Changed 2 months ago by abalosc1

Attachment: combinationmapcss.patch added

updated to include some combinations from osmose checks

comment:1 Changed 2 months ago by abalosc1

Summary: [PATCH] add combination checks based off KeepRight[PATCH] add combination checks based off KeepRight and Osmose

comment:2 Changed 2 months ago by Don-vip

Milestone: 19.02

comment:3 Changed 2 months ago by Don-vip

Resolution: fixed
Status: newclosed

In 14798/josm:

fix #17371 - add combination checks based off KeepRight and Osmose (patch by abalosc1, modified)

comment:4 Changed 2 months ago by Don-vip

Thanks for the patch! :)

comment:5 Changed 8 weeks ago by aceman

Wait, will e.g. cafes without 'operator' be reported now? Why is 'name' not enough?

comment:6 Changed 8 weeks ago by Klumbumbus

Resolution: fixed
Status: closedreopened

Yes, this change needs some rework.

  • these missing operator rules don't fit in warning level. I personally wouldn't even put them in info level. (e.g. currently only 3% of amenity=cafe have an operator tag)
  • missing ele and denomination should be info level
  • place without name is a bit risky as it may encourages fake names (https://wiki.openstreetmap.org/wiki/Names#Name_is_the_name_only) atleast for place=islet (currently 19% of islets have a name tagged). On the other hand https://wiki.openstreetmap.org/wiki/Key:place says "Used to indicate that a particular location is known by a particular name", So I guess islets without name should be mapped without the place=islet tag and only by multipolygon or coastline? We have 178000 place=islet objects without name in our database and much likely on most cases not the name tag is missing but the place tag should be removed (as there doesn't exist a name). Then we need a better warning text.

comment:7 Changed 8 weeks ago by Don-vip

Resolution: fixed
Status: reopenedclosed

In 14799/josm:

fix #17371 - rework combination checks

comment:8 Changed 8 weeks ago by Don-vip

In 14800/josm:

see #17371 - fix file

comment:9 Changed 8 weeks ago by Klumbumbus

Ticket #17374 has been marked as a duplicate of this ticket.

Changed 8 weeks ago by abalosc1

Attachment: combinationmapcss.2.patch added

updated some to be info level warnings. removed place without name

comment:10 Changed 8 weeks ago by Klumbumbus

It should already all be done.

comment:11 Changed 8 weeks ago by abalosc1

Oh thanks, just looked at the fixes. The only thing that didn't get addressed is "denomination" is still under warning instead of info.

comment:12 Changed 8 weeks ago by Klumbumbus

In 14818/josm:

see #17371 - downgrade place_of_worship without denomination warning to info level

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.