Modify

Opened 9 days ago

Closed 9 days ago

#17313 closed defect (fixed)

Validator not working (NPE in test higways)

Reported by: anonymous Owned by: GerdP
Priority: major Milestone: 19.02
Component: Core validator Version: latest
Keywords: Cc:

Description

In r14776 the validator stops after 14th check. A few days ago it worked fine.

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.
- E: Thread main-worker-0 raised java.lang.NullPointerException

Attachments (1)

JOSM r14776 validator bug.osm (8.8 MB) - added by anonymous 9 days ago.
Run the validator on this dataset

Change History (6)

comment:1 Changed 9 days ago by GerdP

Might be a regression from r14772. How can I reproduce this error?

comment:2 in reply to:  1 Changed 9 days ago by anonymous

I don't know yet what triggers the error, because there is no popup exception, the progress bar just disappears without any warning.

Maybe try to load a bigger city where are many different OSM objects. I'll attach .osm file where I found the bug.

Changed 9 days ago by anonymous

Run the validator on this dataset

comment:3 Changed 9 days ago by GerdP

Owner: changed from team to GerdP

OK, I can reproduce it now.

comment:4 Changed 9 days ago by GerdP

Milestone: 19.02
Summary: Validator not workingValidator not working (NPE in test higways)

comment:5 Changed 9 days ago by GerdP

Resolution: fixed
Status: newclosed

In 14777/josm:

fix #17313 NPE when *_link road is connected to way without a highway tag (regression from r14772)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain GerdP.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.