Modify

Opened 10 days ago

Closed 6 days ago

#17299 closed defect (worksforme)

Trying to open renamed JOSM file or Level0 editor "uanble to launch application" error

Reported by: lmason@… Owned by: lmason@…
Priority: normal Milestone:
Component: Core Version: latest
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Saving work-in-progress JOSM file
  2. re-opening later. last months version of JOSM and the newest tested version have this issue

What is the expected result?

Would like saved files to open at later date.

What happens instead?

Error message, obviously JNLP file, just not sure how to fix it.

Please provide any additional information below. Attach a screenshot if possible.

Screen shot attached.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2019-02-02 21:01:18 +0100 (Sat, 02 Feb 2019)
Build-Date:2019-02-04 21:50:11
Revision:14760
Relative:URL: ^/trunk

Identification: JOSM/1.5 (14760 en) Windows 10 64-Bit
OS Build number: Windows 10 Pro 1803 (17134)
Memory Usage: 928 MB / 1820 MB (615 MB allocated, but free)
Java version: 1.8.0_201-b09, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1080, \Display1 1920x1080, \Display2 1920x1080
Maximum Screen Size: 1920x1080
Dataset consistency test: No problems found

Plugins:
+ CADTools (1008)
+ FastDraw (34867)
+ QuickLabel (18)
+ apache-commons (34506)
+ auto_tools (67)
+ buildings_tools (34867)
+ colorscheme (34678)
+ ejml (34389)
+ geotools (34513)
+ imagery_offset_db (34867)
+ importvec (34867)
+ indoor_sweepline (34867)
+ indoorhelper (34867)
+ jaxb (34678)
+ jts (34524)
+ measurement (34867)
+ merge-overlap (34664)
+ namemanager (34867)
+ opendata (34867)
+ pdfimport (34867)
+ photoadjust (34867)
+ print (34867)
+ tageditor (34867)
+ tagging-preset-tester (34678)
+ utilsplugin2 (34867)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/OSMRookie&zip=1
+ http://zibi.openstreetmap.org.pl/kendzi/k/Simple3dPreset/s3db-preset.zip

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Noname&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_buildings&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/AddressValidator&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Admin_Boundaries&zip=1
- https://pasharm.github.io/New_basic_style_for_JOSM/New_basic_style.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/ColourTag&zip=1
- https://github.com/igitov/forest-josm-style/archive/master.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/Landcover&zip=1
- https://github.com/gmgeo/osmic-josm-style/archive/master.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/Fixme&zip=1
- https://pasharm.github.io/New_basic_style_for_JOSM/New_basic_style.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/ColourTag&zip=1
- https://raw.githubusercontent.com/OpenSeaMap/josm/master/CEVNI_MapCSS.mapcss
+ <josm.pref>\styles\sit.mapcss
+ <josm.pref>\styles\sit.mapcss
+ <josm.pref>\styles\sit.mapcss
+ <josm.pref>\styles\sit.mapcss

Validator rules:
+ <josm.pref>\validator\indoorhelper.validator.mapcss

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.
- W: Cannot start IPv4 remotecontrol https server on port 8112: Keystore was tampered with, or password was incorrect
- W: Cannot start IPv6 remotecontrol https server on port 8112: Keystore was tampered with, or password was incorrect
- W: java.net.SocketTimeoutException: connect timed out
- W: java.net.SocketTimeoutException: connect timed out

Attachments (4)

JNLP Error message.png (15.4 KB) - added by lmason@… 10 days ago.
Screenshot of JNLP error pop-up(s)
Exception Tab ScreenShot.png (20.2 KB) - added by anonymous 6 days ago.
Launch File number 1.png (174.5 KB) - added by anonymous 6 days ago.
Launch File 1
Launch File number 2.png (172.3 KB) - added by anonymous 6 days ago.
LAunch File 2

Download all attachments as: .zip

Change History (13)

Changed 10 days ago by lmason@…

Attachment: JNLP Error message.png added

Screenshot of JNLP error pop-up(s)

comment:1 Changed 10 days ago by GerdP

The file content shown in the screen shot is that of an empty osm xml file. A JNLP file should be completely different.
Can you explain exactly what what you do to open the saved file?

comment:2 Changed 7 days ago by Don-vip

Owner: changed from team to lmason@…
Status: newneedinfo

Changed 6 days ago by anonymous

Changed 6 days ago by anonymous

Attachment: Launch File number 1.png added

Launch File 1

Changed 6 days ago by anonymous

Attachment: Launch File number 2.png added

LAunch File 2

comment:3 Changed 6 days ago by anonymous

I apologize in advance for the formatting of this reply, I was unaware it would send the screen shots instead of my reply. When I double click to open previously saved JOSM files from either the folder where I save them—or the desktop, and/or using the context menu, I get the same pop-up. I have sent all the information from the pop-up. The 'Exception' Tab info, and 2 sceen shots of the 'Launch File' because it had to be scrolled. This happened with last months version, and the current 14760 version. I suspect it may be an issue with my computer, just not sure what to look for.

As always, thank you for your help and patience in these matters.

comment:4 Changed 6 days ago by GerdP

OK, I've never tried to open the files with a double click. Not sure what you have to do on a Mac to make that work.
Are you still able to open the file(s) from an already running JOSM via File->Open?

comment:5 Changed 6 days ago by GerdP

Oops, sorry, forget the sentence about the Mac. You use Windows, so you have probably connected the chosen extension with josm.jnlp and this file no longer exists or was changed?

comment:6 Changed 6 days ago by GerdP

I see an error similar to yours when I rename a file sample.osm file to sample.jnlp and double click it. So, you probably did that as well and you just have to rename the file to *.osm.

comment:7 Changed 6 days ago by lmason@…

Thank you GerdP,
The JOSM start-up icon works perfectly fine. I can open it and works perfectly, as always, it is only when I save a file. Once renamed it will not reopen. Im am sure the file was purged at some point. I just don't know when. I know I have seen multiple copies of JOSM/Java in my directories, and have purged anything that seemed like an older version. Your response(s) make perfect sense to me. As I suspected, this is a me' issue. Thank you for your help, this gives me information to use moving forward.

comment:8 Changed 6 days ago by GerdP

JOSM uses the extension to decide what the file contains and if a plugin is needed to open it or if JOSM has builtin code to open it. So, don't change extensions!

comment:9 Changed 6 days ago by GerdP

Resolution: worksforme
Status: needinfoclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain lmason@….
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.