Modify

Opened 3 weeks ago

Closed 3 weeks ago

#17263 closed defect (fixed)

GpxLayer sometimes shows "ghost lines"

Reported by: GerdP Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

See #17257.
Sometimes "ghostly" gpx lines appear on the screen and disappear again either the plugin loads more data
or when you move the cursor or force a repaint by deactivating and activating again the GpxLayer.

What is the expected result?

No ghost lines

Please provide any additional information below. Attach a screenshot if possible.

The problem is in class GpxDrawHelper. This class modifies the fields of WayPoint instances, e.g.
drawline and dir. Therefore the result of the first call of of GpxDrawHelper.listVisibleSegments(Bounds box) differs from that of following calls.

Build-Date:2019-01-27 15:50:44
Revision:14735
Is-Local-Build:true

Identification: JOSM/1.5 (14735 SVN en) Windows 10 64-Bit
OS Build number: Windows 10 Home 1803 (17134)
Memory Usage: 667 MB / 1753 MB (246 MB allocated, but free)
Java version: 1.8.0_191-b12, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1080
Maximum Screen Size: 1920x1080
VM arguments: [-agentlib:jdwp=transport=dt_socket,suspend=y,address=localhost:65479, -ea, -Dfile.encoding=UTF-8]
Program arguments: [--debug]
Dataset consistency test: No problems found

Plugins:
+ OpeningHoursEditor (34535)
+ apache-commons (34506)
+ buildings_tools (34850)
+ continuosDownload (82)
+ download_along (34838)
+ ejml (34389)
+ geotools (34513)
+ jaxb (34506)
+ jts (34524)
+ o5m (34846)
+ opendata (34805)
+ pbf (34858)
+ poly (34860)
+ reltoolbox (34788)
+ reverter (34552)
+ utilsplugin2 (34862)

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.

Attachments (2)

ghost-gpx.PNG (271.1 KB) - added by GerdP 3 weeks ago.
17263.patch (1.8 KB) - added by GerdP 3 weeks ago.
Workaround

Download all attachments as: .zip

Change History (4)

Changed 3 weeks ago by GerdP

Attachment: ghost-gpx.PNG added

Changed 3 weeks ago by GerdP

Attachment: 17263.patch added

Workaround

comment:1 Changed 3 weeks ago by GerdP

The patch is a workaround. It changes the data flow so that listVisibleSegments() is called again after calculateColors() which does the modifiations, so it might have a negative effect on performance for areas with lots of GPX data.

I don't know if the code is intended to change the original WayPoint fields downloaded from OSM?


comment:2 Changed 3 weeks ago by GerdP

Resolution: fixed
Status: newclosed

In 14748/josm:

fix #17263: GpxLayer sometimes shows "ghost lines"

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.