Modify

Opened 20 months ago

Closed 8 months ago

#17220 closed enhancement (fixed)

Some improvements related to imagery offsets in LayerListDialog

Reported by: naoliv Owned by: team
Priority: normal Milestone: 20.01
Component: Core imagery Version:
Keywords: offset Cc: zlavergne

Description

https://i.imgur.com/z4H3242.png

1) When we leave the mouse at the offset icon, instead displaying layer has a user-definedd offset (click to remove offset) could we have something like layer has an offset of 'X, Y' (click to remove offset)? (ie, display the current offset value)

https://i.imgur.com/nwtbiIK.png

2) Sometimes we unintentionally click at the offset icon and we lose the offset (and we are not able to remember or set the offset to that same value as before).

At the context menu, could we have an option to load the last offset value?
JOSM would then always store the last value; if we inadvertently reset the value, then we could simply click on Load last offset value

3) Still at the context menu, could we have a Quick save offset value option?

JOSM:

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2019-01-17 18:31:25 +0100 (Thu, 17 Jan 2019)
Revision:14703
Build-Date:2019-01-18 02:32:18
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (14703 pt_BR) Linux Debian GNU/Linux buster/sid
Memory Usage: 408 MB / 2048 MB (38 MB allocated, but free)
Java version: 11.0.2+7-Debian-1, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1920x1080
Maximum Screen Size: 1920x1080
Java package: openjdk-11-jre:amd64-11.0.2+7-1
Java ATK Wrapper package: libatk-wrapper-java:all-0.33.3-21
VM arguments: [-Dawt.useSystemAAFontSettings=gasp]
Dataset consistency test: No problems found

Attachments (0)

Change History (8)

comment:1 Changed 8 months ago by simon04

Summary: Some improvements related with imagerySome improvements related to imagery offsets in LayerListDialog

comment:2 Changed 8 months ago by simon04

In 15733/josm:

see #17220 - LayerListDialog: show imagery offset in tooltip

comment:3 Changed 8 months ago by simon04

In 15734/josm:

see #17220 - LayerListDialog: re-enable previous offset on click

comment:4 Changed 8 months ago by simon04

Cc: offset added
Milestone: 20.01

Ad 1: Implemented in r15733
Ad 2: Implemented in r15734
Ad 3: How would Quick save offset value be different from New offset (which has the current values pre-filled and can be used to store it under a specified name)?

Last edited 8 months ago by simon04 (previous) (diff)

comment:5 Changed 8 months ago by simon04

Ticket #17079 has been marked as a duplicate of this ticket.

comment:6 Changed 8 months ago by simon04

Cc: zlavergne added; offset removed
Keywords: offset added

comment:7 in reply to:  4 Changed 8 months ago by Klumbumbus

Replying to simon04:

Ad 1: Implemented in r15733
Ad 2: Implemented in r15734
Ad 3: How would Quick save offset value be different from New offset (which has the current values pre-filled and can be used to store it under a specified name)?

I too think New offset is enough, so the ticket can be closed I guess.

comment:8 Changed 8 months ago by Don-vip

Resolution: fixed
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.