Modify

Opened 3 months ago

Closed 3 months ago

#17171 closed enhancement (duplicate)

[PATCH] update preset wiki languages

Reported by: naoliv Owned by: team
Priority: normal Milestone: 19.01
Component: Internal preset Version:
Keywords: Cc:

Description

You will need this because presets_lang.pl doesn't handle the last misleading pt_BR entries:

I've tested and presets_lang.pl won't reintroduce any pt_BR back.

Attachments (0)

Change History (7)

comment:1 Changed 3 months ago by naoliv

trac doesn't let me paste the patch nor attach it, because it thinks it's spam...
Content contained these blacklisted patterns: 'href='

Anyway, patch here https://gist.github.com/naoliv/fa5a27c33a3f5baa5078c9151da5726a

comment:2 Changed 3 months ago by Don-vip

Milestone: 19.01

comment:3 Changed 3 months ago by Don-vip

Resolution: fixed
Status: newclosed

In 14633/josm:

fix #17171 - update preset wiki languages (patch by naoliv)

comment:4 Changed 3 months ago by stoecker

You will need this because presets_lang.pl doesn't handle the last misleading pt_BR entries

Can you tell why? That sounds like the script should be fixed.

comment:5 Changed 3 months ago by naoliv

I did not investigate it too much, but usually the problem is with redirects.
For example, the script doesn't remove pt_BR.href="https://wiki.openstreetmap.org/wiki/Pt-br:Link_(highway)"

https://wiki.openstreetmap.org/wiki/Pt-br:Link_(highway) is actually a redirect to https://wiki.openstreetmap.org/wiki/Pt:Tag:highway%3Dmotorway_link

Likewise for https://wiki.openstreetmap.org/wiki/Pt-br:Key:traffic_calminghttps://wiki.openstreetmap.org/wiki/Pt:Key:traffic_calming, etc

If you take a look at https://wiki.openstreetmap.org/w/index.php?title=Pt-br:Key:traffic_calming&action=history you can see that this redirect is old.

Maybe some other non pt_BR pages could be affected too by redirects like this?

comment:6 Changed 3 months ago by stoecker

Resolution: fixed
Status: closedreopened

Hmm, the script does only look at the English page, never at the translated pages.

It seems there is a generic bug in the parsing when the original page is a redirect. Link_(highway) has e.g. different translations in the presets file at different positions.

comment:7 Changed 3 months ago by stoecker

Resolution: duplicate
Status: reopenedclosed

Closed as duplicate of #17173.
Handling this in the other ticket about autodetection.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.