Modify

Opened 13 days ago

Closed 13 days ago

Last modified 13 days ago

#17167 closed defect (fixed)

Gap in filling closed areas near first/last node

Reported by: Zverikk Owned by: GerdP
Priority: normal Milestone: 19.01
Component: Core mappaint Version: latest
Keywords: regression Cc:

Description (last modified by Zverikk)

  1. Download this way: https://www.openstreetmap.org/way/660110703
  2. Optionally (for extra effect) download all referring relations and their members.
  3. Zoom in closer to the top-left part.

One segment of inner (and outer, if you have it) filling disappears.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2019-01-01 14:07:43 +0100 (Tue, 01 Jan 2019)
Build-Date:2019-01-02 02:32:31
Revision:14626
Relative:URL: ^/trunk

Identification: JOSM/1.5 (14626 en) Mac OS X 10.14.2
OS Build number: Mac OS X 10.14.2 (18C54)
Memory Usage: 904 MB / 1820 MB (470 MB allocated, but free)
Java version: 1.8.0_191-b12, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: Display 724840401 2560x1440
Maximum Screen Size: 2560x1440
VM arguments: [-Djava.library.path=/Applications/JOSM.app/Contents/MacOS, -DLibraryDirectory=${HOME}/Library, -DDocumentsDirectory=${HOME}/Documents, -DApplicationSupportDirectory=${HOME}/Library/Application Support, -DCachesDirectory=${HOME}/Library/Caches, -DSandboxEnabled=false, -Dapple.laf.useScreenMenuBar=true, -Dcom.apple.macos.use-file-dialog-packages=true, -Dcom.apple.macos.useScreenMenuBar=true, -Dcom.apple.mrj.application.apple.menu.about.name=JOSM, -Dcom.apple.smallTabs=true]
Dataset consistency test: No problems found

Attachments (1)

Screenshot 2019-01-03 at 14.08.47.png (44.6 KB) - added by Zverikk 13 days ago.

Download all attachments as: .zip

Change History (6)

Changed 13 days ago by Zverikk

comment:1 Changed 13 days ago by Zverikk

Description: modified (diff)

comment:2 Changed 13 days ago by GerdP

Owner: changed from team to GerdP

Looks like a regression from #17095. I'll have a look at it.

comment:3 Changed 13 days ago by GerdP

Resolution: fixed
Status: newclosed

In 14627/josm:

fix #17167 : Regression from #17119 clipped closed path was not closed

comment:4 Changed 13 days ago by Zverikk

Thank you for the prompt fixing!

comment:5 Changed 13 days ago by Don-vip

Keywords: regression added
Milestone: 19.01

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain GerdP.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.