Modify

Opened 3 months ago

Closed 3 months ago

#17166 closed defect (duplicate)

Unexpected exception

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Tried to join 3 areas

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-12-31 15:09:58 +0100 (Mon, 31 Dec 2018)
Build-Date:2018-12-31 14:24:10
Revision:14620
Relative:URL: ^/trunk

Identification: JOSM/1.5 (14620 en) Windows 10 64-Bit
OS Build number: Windows 10 Home 1803 (17134)
Memory Usage: 896 MB / 910 MB (410 MB allocated, but free)
Java version: 1.8.0_191-b12, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1080
Maximum Screen Size: 1920x1080
VM arguments: [-Djosm.home=C:/users/micha/JOSM/FixIt, -Djosm.cache=<josm.cache>]

Dataset consistency test:
[DELETED REFERENCED] {Relation id=6696440 version=3 MVT [way 575645282, way 639073962, node 2508696539, way 28631408, way 134120344, way 121947335, node 3251106362, node 1475011747, node 3251106363, way 167195759]} refers to deleted primitive {Way id=639073962 version=1 MVD nodes=[]}
[DELETED REFERENCED] {Relation id=6696440 version=3 MVT [way 575645282, way 639073962, node 2508696539, way 28631408, way 134120344, way 121947335, node 3251106362, node 1475011747, node 3251106363, way 167195759]} refers to deleted primitive {Way id=134120344 version=6 MVD nodes=[]}


Plugins:
+ OpeningHoursEditor (34535)
+ buildings_tools (34724)
+ conflation (0.6.2)
+ jts (34524)
+ reltoolbox (34788)
+ terracer (34584)
+ turnrestrictions (34643)
+ utilsplugin2 (34793)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/BuildingPreset&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Communication_Towers&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/hiking_routes_with_trail_marking&zip=1

Map paint styles:
- https://github.com/igitov/forest-josm-style/archive/master.zip

Last errors/warnings:
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Deleted member referenced: {Relation id=6696440 version=3 MVT [way 575645282, way 639073962, node 2508696539, way 28631408, way 134120344, way 121947335, node 3251106362, node 1475011747, node 3251106363, way 167195759]}


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (17) of main
org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Deleted member referenced: {Relation id=6696440 version=3 MVT [way 575645282, way 639073962, node 2508696539, way 28631408, way 134120344, way 121947335, node 3251106362, node 1475011747, node 3251106363, way 167195759]}
	at org.openstreetmap.josm.data.osm.Relation.checkMembers(Relation.java:476)
	at org.openstreetmap.josm.data.osm.Relation.fireMembersChanged(Relation.java:488)
	at org.openstreetmap.josm.data.osm.Relation.setMembers(Relation.java:59)
	at org.openstreetmap.josm.data.osm.Relation.cloneFrom(Relation.java:243)
	at org.openstreetmap.josm.command.ChangeCommand.executeCommand(ChangeCommand.java:65)
	at org.openstreetmap.josm.command.SequenceCommand.executeCommand(SequenceCommand.java:79)
	at org.openstreetmap.josm.data.UndoRedoHandler.addNoRedraw(UndoRedoHandler.java:289)
	at org.openstreetmap.josm.data.UndoRedoHandler.add(UndoRedoHandler.java:331)
	at org.openstreetmap.josm.actions.JoinAreasAction.commitCommand(JoinAreasAction.java:835)
	at org.openstreetmap.josm.actions.JoinAreasAction.commitCommands(JoinAreasAction.java:825)
	at org.openstreetmap.josm.actions.JoinAreasAction.resolveTagConflicts(JoinAreasAction.java:742)
	at org.openstreetmap.josm.actions.JoinAreasAction.join(JoinAreasAction.java:534)
	at org.openstreetmap.josm.actions.JoinAreasAction.actionPerformed(JoinAreasAction.java:475)
	at javax.swing.SwingUtilities.notifyAction(Unknown Source)
	at javax.swing.JComponent.processKeyBinding(Unknown Source)
	at javax.swing.KeyboardManager.fireBinding(Unknown Source)
	at javax.swing.KeyboardManager.fireKeyboardAction(Unknown Source)
	at javax.swing.JComponent.processKeyBindingsForAllComponents(Unknown Source)
	at javax.swing.JComponent.processKeyBindings(Unknown Source)
	at javax.swing.JComponent.processKeyEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.KeyboardFocusManager.redispatchEvent(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.dispatchEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (1)

comment:1 Changed 3 months ago by stoecker

Resolution: duplicate
Status: newclosed

Closed as duplicate of #17158.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.