Modify

Opened 11 months ago

Closed 3 months ago

#17015 closed enhancement (duplicate)

Allow to choose multiple tags while solving a conflict

Reported by: naoliv Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: conflict Cc:

Description

When solving a conflict, at the Tags tab we have a single big button, where we can only choose a tag each time:
https://i.imgur.com/mHA6XdO.png

While at the Members tab we have multiple buttons, where we can choose a single conflicting line or all the elements of a side:
https://i.imgur.com/SR4vIoN.png

Couldn't we have the same buttons/options at the Tags tab?

JOSM:

Revision:14438
Is-Local-Build:true
Build-Date:2018-11-20 22:35:14

Identification: JOSM/1.5 (14438 SVN pt_BR) Linux Debian GNU/Linux unstable (sid)
Memory Usage: 796 MB / 2048 MB (187 MB allocated, but free)
Java version: 11.0.1+13-Debian-2, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1920x1080
Maximum Screen Size: 1920x1080
Java package: openjdk-11-jre:amd64-11.0.1+13-2
Java ATK Wrapper package: libatk-wrapper-java:all-0.33.3-21
VM arguments: [-Dawt.useSystemAAFontSettings=gasp]
Dataset consistency test: No problems found

Attachments (0)

Change History (5)

comment:1 Changed 11 months ago by stoecker

Hmm, I'm sure that is possible. Either by clicking the entries or using <SHIFT>. Didn't do that for a long time, but I'm sure there was a chance.

comment:2 Changed 11 months ago by Don-vip

Keywords: conflict added

comment:3 Changed 4 months ago by skyper

Similar to #4615

comment:4 in reply to:  1 Changed 4 months ago by skyper

Replying to stoecker:

Hmm, I'm sure that is possible. Either by clicking the entries or using <SHIFT>. Didn't do that for a long time, but I'm sure there was a chance.

It is possible. Select with meta key <SHIFT> and/or <CTRL> and press button.

comment:5 Changed 3 months ago by skyper

Resolution: duplicate
Status: newclosed

Closed as duplicate of #4615.
Selecting multiple tags is possible and the ticket for the buttons was already created.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.