Modify

Opened 5 weeks ago

Closed 5 weeks ago

Last modified 5 weeks ago

#16980 closed defect (duplicate)

JOSM not saving the position of right side pannels (Windows7)

Reported by: smaprs Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: Cc:

Description

Hi, please,

JOSM is not saving the heights (and widths) of right side pannels.
I'm now with JOSM v.14178
Actually it never worked for me, for any JOSM versions, even if fully re-installed.
I suspect it happens with Windows, becasue I know fellows that use Linux and usually have their pannels saved (but I can't dismiss Windows-v7).
Could it be implemented for Windows?

For GUI it saves OK last values:

    gui.geometry	x=-8,y=-8,width=1296,height=1010
    gui.maximized	true

But not for the right side pannel:

    validator.geometry         x=481,y=403,width=661,height=235

Moreover, not availlable (just empty) for:

    propertiesdialog.geometry
    selectionlist.geometry 
    relationlist.geometry 


For any value I set for those, yes it saves, but does not work when opening new session:
they always open with the same default heights, that is, with too much height for "validator" (used only in the end of session) and too short for "properties" (used constantly).
Even though the values still are there as they were personally set by me.

So I have to manually drag down the pannels again every new session... since 5 years...

So, How to save personal adjusts of heights (and widths) for right side pannels?(in Windows)
Thank you in advance.
Sérgio - openstreetmap.org/user/smaprs

Attachments (0)

Change History (3)

comment:1 Changed 5 weeks ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #7561.

comment:2 Changed 5 weeks ago by smaprs

Just don't know if this is exactly a duplicate, since the other ticket reports panels of plugins. What I report here is about panels of built in tools, like for layers, tags, selection, relations, validator.

comment:3 Changed 5 weeks ago by Klumbumbus

#7561 is about the panels on the right side in general (so for both, core and plugins).

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.