Modify

Opened 20 months ago

Closed 20 months ago

Last modified 18 months ago

#16945 closed defect (fixed)

Download Dialog hides Overpass query

Reported by: GerdP Owned by: team
Priority: normal Milestone: 18.11
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Use an overpass query, eg. use wizard with type:way and natural=coastline
  2. download the data , work with it, quit JOSM
  3. Start JOSM again
  4. Press Ctrl+Shift+Down to open download dialog again

What is the expected result?

Dialog should look like the last time when it was used

What happens instead?

The overpass query is sometimes hidden. Sometimes even the button for the wizard is not visible.

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-10-28 22:27:31 +0100 (Sun, 28 Oct 2018)
Build-Date:2018-10-28 21:33:32
Revision:14382
Relative:URL: ^/trunk

Identification: JOSM/1.5 (14382 en) Windows 10 64-Bit
OS Build number: Windows 10 Home 1803 (17134)
Memory Usage: 1593 MB / 5461 MB (1402 MB allocated, but free)
Java version: 1.8.0_191-b12, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1080
Maximum Screen Size: 1920x1080

Plugins:
+ OpeningHoursEditor (34535)
+ apache-commons (34506)
+ buildings_tools (34572)
+ download_along (34503)
+ ejml (34389)
+ geotools (34513)
+ jaxb (34506)
+ jts (34524)
+ measurement (34529)
+ merge-overlap (34664)
+ o5m (34405)
+ opendata (34698)
+ pbf (34576)
+ poly (34546)
+ reverter (34552)
+ undelete (34568)
+ utilsplugin2 (34506)

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.

Attachments (5)

expected.png (38.7 KB) - added by GerdP 20 months ago.
after_start.png (33.0 KB) - added by GerdP 20 months ago.
worst.png (28.3 KB) - added by GerdP 20 months ago.
fit.PNG (47.7 KB) - added by GerdP 20 months ago.
fit_after.PNG (47.1 KB) - added by GerdP 20 months ago.

Download all attachments as: .zip

Change History (12)

Changed 20 months ago by GerdP

Attachment: expected.png added

Changed 20 months ago by GerdP

Attachment: after_start.png added

Changed 20 months ago by GerdP

Attachment: worst.png added

comment:1 Changed 20 months ago by GerdP

This problem is not new, I think it is as old as the overpass dialog itself, I just never found the time to make the screen shots and report it. When the worst case happened it took me a while to find out that I have to drag down part of the dialog.
I have no idea where to fix this. I think the layout has to be stored in the preferences.

comment:2 Changed 20 months ago by Don-vip

I think we already have a bug report for this.

comment:4 Changed 20 months ago by michael2402

This seems to be caused by the download dialog being resized and then the stored height of the panel gets updated with the smaller height.

comment:5 Changed 20 months ago by michael2402

Resolution: fixed
Status: newclosed

In 14418/josm:

Fix #16945: Only store changed overpass height if user changes it. Add minimum size to overpass query / map view

Changed 20 months ago by GerdP

Attachment: fit.PNG added

Changed 20 months ago by GerdP

Attachment: fit_after.PNG added

comment:6 Changed 20 months ago by GerdP

Thanks for working on this. I still see changes in the layout of the download window when I resize the window for the query wizard so that the query just fits it will look different after restart. Not a big problem, just a bit confusing. See new attachments.
In case that the quere is too complex I'd prefer to see the start of it, not the end. Like in an editor when you open a long text.

comment:7 Changed 18 months ago by Don-vip

Milestone: 18.11

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.