Modify

Opened 6 months ago

Closed 6 months ago

Last modified 6 months ago

#16928 closed defect (fixed)

Include full validator message in a tooltip

Reported by: mkoniecz Owned by: team
Priority: normal Milestone: 18.11
Component: Core validator Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Use payment:credit_cards=yes tag
  2. Run validator
  3. Attempt to use tooltip to get full message

What is the expected result?

Tooltip shows full message

What happens instead?

Tooltip is also showing truncated message

Please provide any additional information below. Attach a screenshot if possible.

It would be preferable to not truncate message at all

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-10-28 22:27:31 +0100 (Sun, 28 Oct 2018)
Build-Date:2018-10-28 21:33:32
Revision:14382
Relative:URL: ^/trunk

Identification: JOSM/1.5 (14382 en) Linux Ubuntu 16.04.5 LTS
Memory Usage: 749 MB / 869 MB (357 MB allocated, but free)
Java version: 1.8.0_191-b12, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: :0.0 1920x1080
Maximum Screen Size: 1920x1080
Dataset consistency test: No problems found

Plugins:
+ OpeningHoursEditor (34535)
+ buildings_tools (34572)
+ continuosDownload (82)
+ imagery_offset_db (34641)
+ measurement (34529)
+ reverter (34552)
+ todo (30306)

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.

Attachments (0)

Change History (4)

comment:1 Changed 6 months ago by Klumbumbus

It is not truncated. The message includes "...", see https://josm.openstreetmap.de/browser/josm/trunk/data/validator/deprecated.mapcss#L689
Thats because there are more possible values than mastercard and visa.
Any better ideas than "..."?

comment:2 Changed 6 months ago by mkoniecz

" or other applicable", "or similar", "or other similar", "etc."?

comment:3 Changed 6 months ago by Klumbumbus

Resolution: fixed
Status: newclosed

In 14392/josm:

fix #16928 - improve payment methods validator message

comment:4 Changed 6 months ago by Klumbumbus

Milestone: 18.11

The problem is that suggestAlternative: should contain osm tags/keys only not other text like "or similar" (keeping #11153 in mind). "..." was not good neither.
The reason for suggestAlternative: is to save and shorten translations strings. I changed it now without adding an additional translation string.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.