Modify

Opened 6 months ago

Closed 6 months ago

#16926 closed defect (fixed)

plugin cadastre-fr failure and all plugins infos unavailable

Reported by: marc_marc Owned by: Don-vip
Priority: normal Milestone:
Component: Plugin cadastre-fr Version:
Keywords: template_report Cc: Patchanka

Description

What steps will reproduce the problem?

  1. load note 1576103 and zoom in this area
  2. download the area from osm
  3. download the cadastral data

What is the expected result?

get cadastral data :)

What happens instead?

popup crash and not cadastra data downloaded

Please provide any additional information below. Attach a screenshot if possible.

an 2nd popup https://framapic.org/2bpmAiFfstNq/K4HrFnJN9XSB.png
no idea if it is the origin of this one.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-10-28 22:27:31 +0100 (Sun, 28 Oct 2018)
Build-Date:2018-10-28 21:33:32
Revision:14382
Relative:URL: ^/trunk

Identification: JOSM/1.5 (14382 fr) Linux CentOS Linux 7 (Core)
Memory Usage: 1168 MB / 1820 MB (338 MB allocated, but free)
Java version: 1.8.0_191-b12, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1600x900
Maximum Screen Size: 1600x900
Java package: java-1.8.0-openjdk:x86_64-1.8.0.191.b12
WebStart package: icedtea-web:x86_64-1.7.1
VM arguments: [-Dicedtea-web.bin.name=javaws.itweb, -Dicedtea-web.bin.location=/usr/bin/javaws.itweb]

Plugins:
+ HouseNumberTaggingTool (34517)
+ Mapillary (v1.5.17)
+ OpeningHoursEditor (34535)
+ RoadSigns (34553)
+ apache-commons (34506)
+ apache-http (34632)
+ cadastre-fr (34630)
+ conflation (0.6.2)
+ continuosDownload (82)
+ ejml (34389)
+ geotools (34513)
+ imagery_offset_db (34641)
+ jaxb (34506)
+ jna (34633)
+ jogl (1.2.2)
+ jts (34524)
+ kendzi3d-resources (0.0.2)
+ log4j (34527)
+ opendata (34698)
+ photo_geotagging (34576)
+ photoadjust (34684)
+ reverter (34552)
+ scripting (30791)
+ tag2link (34690)
+ todo (30306)
+ turnrestrictions (34643)
+ utilsplugin2 (34506)
+ wikipedia (v1.1.1)

Tagging presets:
+ https://raw.github<user.name>content.com/yopaseopor/traffic_signs_preset_JOSM/master/CH.zip
+ https://josm.openstreetmap.de/josmfile?page=Presets/Light_sources&zip=1
+ http://zibi.openstreetmap.org.pl/kendzi/k/Simple3dPreset/s3db-preset.zip
+ https://josm.openstreetmap.de/josmfile?page=Presets/Addr2&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/BuildingPreset&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/ParkingLanes&zip=1
+ https://raw.github<user.name>content.com/species/josm-preset-wheelchair/master/sidewalks_kerbs.xml
+ http://osmtools.de/josm/steps.xml
+ https://raw.github<user.name>content.com/yopaseopor/traffic_signs_preset_JOSM/master/BE.zip
+ https://raw.github<user.name>content.com/yopaseopor/traffic_signs_preset_JOSM/master/FR.zip

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/ParkingLanes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/BesideTheRoad_Speed&zip=1
- https://raw.github<user.name>content.com/species/josm-preset-traffic_sign_direction/master/direction.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/Enhanced_Lane_and_Road_Attributes&zip=1
- https://www.dropbox.com/s/qo3ai47fpv241jf/Styles_Fixme_and_Notes.zip?raw=1
- https://josm.openstreetmap.de/josmfile?page=Styles/SimpleBuildingTags&zip=1
+ https://raw.github<user.name>content.com/yopaseopor/traffic_signs_style_JOSM/master/Styles_Traffic_signs_EUR.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/light_source&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Sidewalks&zip=1
- https://raw.github<user.name>content.com/species/josm-preset-wheelchair/master/sidewalks_kerbs.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/Noname&zip=1

Validator rules:
+ https://www.openrailwaymap.org/validator/openrailwaymap.validator.mapcss
+ https://github.com/Jungle-Bus/transport_mapcss/raw/gh-pages/transport.validator.zip
+ https://raw.github<user.name>content.com/OpenNauticalChart/josm/master/Seamark.validator.mapcss

Last errors/warnings:
- W:  FR:M9j1: Could not get presets icon traffic_signs/FR/FR_M9j1.png
- E: Impossible de trouver l'image "traffic_signs/FR/FR_M9j2.png"
- W:  FR:M9j2: Could not get presets icon traffic_signs/FR/FR_M9j2.png
- E: Impossible de trouver l'image "traffic_signs/FR/FR_M9v1.png"
- W:  FR:M9v1: Could not get presets icon traffic_signs/FR/FR_M9v1.png
- E: Impossible de trouver l'image "traffic_signs/FR/FR_M9v2.png"
- W:  FR:M9v2: Could not get presets icon traffic_signs/FR/FR_M9v2.png
- W: No configuration settings found.  Using hardcoded default values for all pools.
- E: Handled by bug report queue: javax.json.stream.JsonParsingException: JsonParser#getArray() or JsonParser#getArrayStream() is valid only for START_ARRAY parser state. But current parser state is START_OBJECT. Cause : java.lang.IllegalStateException: JsonParser#getArray() or JsonParser#getArrayStream() is valid only for START_ARRAY parser state. But current parser state is START_OBJECT
- W: Avertissement - <html>JOSM ne parvient pas à trouver d’information sur les greffons suivants :<ul><li>apache-commons</li><li>HouseNumberTaggingTool</li><li>conflation</li><li>geotools</li><li>opendata</li><li>RoadSigns</li><li>cadastre-fr</li><li>continuosDownload</li><li>jaxb</li><li>scripting</li><li>utilsplugin2</li><li>jogl</li><li>turnrestrictions</li><li>wikipedia</li><li>jna</li><li>log4j</li><li>imagery_offset_db</li><li>photoadjust</li><li>jts</li><li>kendzi3d-resources</li><li>Mapillary</li><li>tag2link</li><li>ejml</li><li>reverter</li><li>todo</li><li>photo_geotagging</li><li>OpeningHoursEditor</li><li>apache-http</li></ul>Les greffons ne seront pas chargés.</html>


=== STACK TRACE ===
Thread: AWT-EventQueue-1 (33) of JOSM
javax.json.stream.JsonParsingException: JsonParser#getArray() or JsonParser#getArrayStream() is valid only for START_ARRAY parser state. But current parser state is START_OBJECT
	at org.glassfish.json.JsonReaderImpl.readArray(JsonReaderImpl.java:131)
	at org.openstreetmap.josm.plugins.fr.cadastre.api.CadastreAPI.getSheets(CadastreAPI.java:53)
	at org.openstreetmap.josm.plugins.fr.cadastre.api.CadastreAPI.getSheets(CadastreAPI.java:35)
	at org.openstreetmap.josm.plugins.fr.cadastre.download.CadastreDownloadTask.download(CadastreDownloadTask.java:55)
	at org.openstreetmap.josm.plugins.fr.cadastre.download.CadastreDownloadSource.doDownload(CadastreDownloadSource.java:26)
	at org.openstreetmap.josm.plugins.fr.cadastre.download.CadastreDownloadSource.doDownload(CadastreDownloadSource.java:16)
	at org.openstreetmap.josm.gui.download.AbstractDownloadSourcePanel.triggerDownload(AbstractDownloadSourcePanel.java:105)
	at org.openstreetmap.josm.gui.download.DownloadDialog$DownloadAction.lambda$run$0(DownloadDialog.java:563)
	at java.util.Optional.ifPresent(Optional.java:159)
	at org.openstreetmap.josm.gui.download.DownloadDialog$DownloadAction.run(DownloadDialog.java:558)
	at org.openstreetmap.josm.gui.download.DownloadDialog$DownloadAction.actionPerformed(DownloadDialog.java:570)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2022)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2348)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:402)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:252)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:289)
	at java.awt.Component.processMouseEvent(Component.java:6539)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3324)
	at java.awt.Component.processEvent(Component.java:6304)
	at java.awt.Container.processEvent(Container.java:2239)
	at java.awt.Component.dispatchEventImpl(Component.java:4889)
	at java.awt.Container.dispatchEventImpl(Container.java:2297)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4904)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4535)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4476)
	at java.awt.Container.dispatchEventImpl(Container.java:2283)
	at java.awt.Window.dispatchEventImpl(Window.java:2746)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:760)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:74)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:84)
	at java.awt.EventQueue$4.run(EventQueue.java:733)
	at java.awt.EventQueue$4.run(EventQueue.java:731)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:74)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:730)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:205)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:109)
	at java.awt.WaitDispatchSupport$2.run(WaitDispatchSupport.java:190)
	at java.awt.WaitDispatchSupport$4.run(WaitDispatchSupport.java:235)
	at java.awt.WaitDispatchSupport$4.run(WaitDispatchSupport.java:233)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.WaitDispatchSupport.enter(WaitDispatchSupport.java:233)
	at java.awt.Dialog.show(Dialog.java:1084)
	at java.awt.Component.show(Component.java:1671)
	at java.awt.Component.setVisible(Component.java:1623)
	at java.awt.Window.setVisible(Window.java:1014)
	at java.awt.Dialog.setVisible(Dialog.java:1005)
	at org.openstreetmap.josm.gui.download.DownloadDialog.setVisible(DownloadDialog.java:460)
	at org.openstreetmap.josm.actions.DownloadAction.actionPerformed(DownloadAction.java:37)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2022)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2348)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:402)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:252)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:289)
	at java.awt.Component.processMouseEvent(Component.java:6539)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3324)
	at java.awt.Component.processEvent(Component.java:6304)
	at java.awt.Container.processEvent(Container.java:2239)
	at java.awt.Component.dispatchEventImpl(Component.java:4889)
	at java.awt.Container.dispatchEventImpl(Container.java:2297)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4904)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4535)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4476)
	at java.awt.Container.dispatchEventImpl(Container.java:2283)
	at java.awt.Window.dispatchEventImpl(Window.java:2746)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:760)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:74)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:84)
	at java.awt.EventQueue$4.run(EventQueue.java:733)
	at java.awt.EventQueue$4.run(EventQueue.java:731)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:74)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:730)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:205)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)
Caused by: java.lang.IllegalStateException: JsonParser#getArray() or JsonParser#getArrayStream() is valid only for START_ARRAY parser state. But current parser state is START_OBJECT
	at org.glassfish.json.JsonParserImpl.getArray(JsonParserImpl.java:162)
	at org.glassfish.json.JsonReaderImpl.readArray(JsonReaderImpl.java:129)
	... 93 more

Attachments (0)

Change History (5)

comment:1 Changed 6 months ago by simon04

Ticket #16929 has been marked as a duplicate of this ticket.

comment:2 Changed 6 months ago by simon04

Cc: Patchanka added
Component: CorePlugin cadastre-fr
Owner: changed from team to pieren

comment:3 Changed 6 months ago by Don-vip

Owner: changed from pieren to Don-vip
Status: newassigned

comment:4 Changed 6 months ago by Don-vip

It was a temporary failure of the French cadastre API. They're releasing the new version of the Cadastre tonight, it might fail again during the operation. I'm releasing a new version of the plugin that is robust to this error.

comment:5 Changed 6 months ago by Don-vip

Resolution: fixed
Status: assignedclosed

Fixed in [o34711:34712].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.