Modify

Opened 5 years ago

Closed 14 months ago

Last modified 14 months ago

#16900 closed enhancement (fixed)

Add undocumented popular tags

Reported by: Don-vip Owned by: team
Priority: normal Milestone: 22.10
Component: Internal preset Version:
Keywords: unknown_tags ex-longterm Cc: Klumbumbus

Description (last modified by Klumbumbus)

From ticket:16793#comment:6 we found out JOSM does not know about many popular tags (but undocumented on OSM wiki).

Below the list we should focus on (removed: tags containing uppercase, numeric, blank and non-latin characters)

  • age=mature - 30373
  • age=semi-mature - 14014
  • age=young - 10692
  • amenity=mobile_money_agent - 10274
  • authoritative=yes - 11423
  • backup_generator=no - 22718
  • border_type=city - 17329
  • border_type=county - 13297
  • border_type=freguesia - 11111
  • building=kitchen - 12040
  • building=trullo - 13504
  • building:part=room - 10878
  • condition=deficient - 27972
  • condition=fair - 74805
  • condition=good - 65061
  • cosmha=yes - 45344
  • crossing=zebra - 524978 (duplicate of crossing_ref=zebra, introduced by iD)
  • dataset=buildings - 75846
  • designation=public_bridleway - 29334
  • designation=public_footpath - 142993
  • detail=track - 23249
  • driveway=garage - 14032
  • editor=opengislab 2018 - 11245
  • entrance=unisex - 10242
  • exit=yes - 10722
  • flood_prone=no - 11202
  • flood_prone=yes - 12800
  • healthcare=doctor - 14530
  • healthcare=hospital - 12721
  • healthcare=pharmacy - 13477
  • highspeed=no - 11515
  • highspeed=yes - 53445
  • house=detached - 15682 (deprecated)
  • house=semi-detached - 40530 (deprecated)
  • house=terraced - 18804 (deprecated)
  • importance=national - 31234
  • importance=regional - 21733
  • intermittent=no - 27277 (same as not set, introduced by iD)
  • lamp_type=electric - 47536
  • lamp_type=electrical - 10162
  • lamp_type=gaslight - 16374
  • lcn=yes - 131945
  • length_unit=km - 64167
  • light_source=lantern - 33711
  • maintenance=salting - 15920
  • meadow=agricultural - 302836
  • meadow=agriculture - 13112
  • mechanical=yes - 13934
  • median=no - 12002
  • operational_status=open - 20853
  • operational_status=operational - 17735
  • operational_status_quality=confirmed - 15527
  • osm_type=way - 11874
  • ownership=municipal - 15910
  • protected=perpetuity - 22191
  • rcn=yes - 15760
  • review=no - 81256
  • service=irrigation - 10373 (ignored)
  • shoulder=no - 10443
  • shoulder=yes - 10914
  • side=right - 16196
  • sidewalk=none - 283898 (synonym for sidewalk=no)
  • site=geodesic - 72715
  • site=stop_area - 46740
  • snowplowing=yes - 37117
  • source_type_imagery=yes - 34497
  • standing=low - 47698
  • standing=very_low - 58857
  • stop=minor - 11804
  • stream=ephemeral - 60285
  • stream=fixme - 33001
  • stream=perennial - 19451
  • structure_gauge=GC - 20451
  • todo=continue - 24120 (better use fixme=*)
  • trailblazed=yes - 26452
  • tree_form=natural - 45535
  • tunnel=no - 22481 (same as unset)
  • type=turnlanes:turns - 23348
  • wall=yes - 50279
  • waterway=artificial - 16694
  • working=yes - 29620

Attachments (0)

Change History (38)

comment:1 Changed 5 years ago by mkoniecz

building=collapsed - HOT induced mistagging, it is not a building purpose (and it is disputable whatever collapsed remains of a building are a building)

building=damaged - HOT induced mistagging, it is not a building purpose

condition=deficient/fair/good - highly suspicious subjective tagging

flood_prone=yes/no - is it really verifiable?

tunnel=no - sounds like iD induced pointless tagging

healthcare=doctor/hospital/pharmacy - looks potentially reasonable, but it duplicates existing tags (sounds like someone disliking existing tagging scheme and creating duplicate with hope that original will soon disappear)

Last edited 5 years ago by mkoniecz (previous) (diff)

comment:2 Changed 4 years ago by Klumbumbus

Description: modified (diff)

comment:3 Changed 4 years ago by Klumbumbus

Description: modified (diff)

comment:4 in reply to:  1 Changed 4 years ago by Klumbumbus

Replying to mkoniecz:

building=collapsed - HOT induced mistagging, it is not a building purpose (and it is disputable whatever collapsed remains of a building are a building)

building=damaged - HOT induced mistagging, it is not a building purpose

warning added in #17786

comment:5 Changed 4 years ago by Klumbumbus

Description: modified (diff)

comment:6 Changed 4 years ago by Klumbumbus

Milestone: Longterm
Type: defectenhancement

comment:7 Changed 4 years ago by mkoniecz

todo=continue - based on quick look looks like an organic use ( https://taginfo.openstreetmap.org/tags/todo=continue#map )

Maybe turn all todo into fixme as long as there is no fixme tag?


leaf_type=broadl-leaved - now dropped to below 1000 level - see https://overpass-turbo.eu/s/MiC


dataset=buildings - badly done import in Washington, see for example https://www.openstreetmap.org/changeset/5155755 (now documented at OSM wiki as a horrible idea)


waterway=artificial - badly done import, see https://lists.openstreetmap.org/pipermail/tagging/2019-August/047809.html thread (now documented at OSM wiki as a horrible idea)

(if considered as useful I may similarly review more tags)

Last edited 4 years ago by mkoniecz (previous) (diff)

comment:8 Changed 4 years ago by mdk

The keys healthcare=* and healthcare:speciality=* are now in state "approved" and widely used (>200k times):
https://wiki.openstreetmap.org/wiki/Key:healthcare
The keys amenity=doctors, amenity=dentist, amenity=clinic and amenity=hospital are only in state "de facto".
Would it be time, that the Validator at least stops complaining about "Presets do not contain property key" for healthcare and healthcare:speciality?
I think there are external presets which could be used to integrate into the internal presets of JOSM.

comment:9 Changed 4 years ago by mdk

More general: there are several keys which are approved, but the validator complains about like Key:cash_withdrawal which is approved (since 2019-09-19), but JOSM didn't know about.
Is there a possibility to scan the wiki or taginfo for approved keys and compare it with known keys in JOSM?

comment:10 Changed 4 years ago by Klumbumbus

Description: modified (diff)

Removed leaf_type=broadl-leaved as per comment:7 and the remaining ones are catched by the "x looks like y" warning.

comment:11 Changed 4 years ago by anonymous

Them maybe removal from list ones caught by valid "X looks like Y" also would be a good idea?

comment:12 Changed 4 years ago by Klumbumbus

Description: modified (diff)

comment:13 Changed 4 years ago by Klumbumbus

Description: modified (diff)

comment:14 Changed 4 years ago by Klumbumbus

Description: modified (diff)

comment:15 Changed 4 years ago by skyper

Description: modified (diff)
Keywords: unknown tags added

comment:16 Changed 4 years ago by skyper

Description: modified (diff)

comment:17 Changed 4 years ago by mkoniecz

stream=intermittent - 88537

import-induced mistagging - strictly limited area ( https://taginfo.openstreetmap.org/tags/stream=intermittent#map ), appeared in one step - see https://taghistory.raifer.tech/#***/stream/intermittent

Should be intermittent=yes and mostly is https://taginfo.openstreetmap.org/tags/stream=intermittent#combinations

I will try to deimport this.

comment:18 Changed 4 years ago by mkoniecz

amenity=private_toilet should disappear soon, nearly all of them were added in an undiscussed import that I just reverted

See https://www.openstreetmap.org/changeset/58762350 https://www.openstreetmap.org/changeset/58760097

comment:19 Changed 3 years ago by Klumbumbus

Description: modified (diff)

comment:20 in reply to:  17 Changed 3 years ago by Klumbumbus

Replying to mkoniecz:

stream=intermittent - 88537

import-induced mistagging - strictly limited area ( https://taginfo.openstreetmap.org/tags/stream=intermittent#map ), appeared in one step - see https://taghistory.raifer.tech/#***/stream/intermittent

Should be intermittent=yes and mostly is https://taginfo.openstreetmap.org/tags/stream=intermittent#combinations

I will try to deimport this.

I added a warning for now, see #19396.

comment:21 in reply to:  18 Changed 3 years ago by Klumbumbus

Replying to mkoniecz:

amenity=private_toilet should disappear soon, nearly all of them were added in an undiscussed import that I just reverted

See https://www.openstreetmap.org/changeset/58762350 https://www.openstreetmap.org/changeset/58760097

There is a new spot, but "only" 282 objects so far: https://overpass-turbo.eu/?w=%22amenity%22%3D%22private_toilet%22+global&R

comment:22 Changed 3 years ago by Klumbumbus

Description: modified (diff)

comment:23 Changed 3 years ago by skyper

Description: modified (diff)

Updated the access tags included in r16742.

comment:24 Changed 3 years ago by Klumbumbus

Description: modified (diff)

comment:25 Changed 3 years ago by mdk

Actually
healthcare=doctor is approved and has now more than 50000 uses.
healthcare=hospital is approved and has now more than 50000 uses.
healthcare=pharmacy has now more than 100000 uses. The wiki suggest to add healthcare=pharmacy to existing amenity=pharmacy objects.

comment:26 Changed 3 years ago by mkoniecz

"The wiki suggest to add healthcare=pharmacy to existing amenity=pharmacy objects."

On which page?

https://wiki.openstreetmap.org/wiki/Tag:healthcare%3Dpharmacy and https://wiki.openstreetmap.org/wiki/Tag:amenity%3Dpharmacy does not

comment:27 Changed 3 years ago by mdk

https://wiki.openstreetmap.org/wiki/Tag:healthcare%3Dpharmacy:

Tag history

Multiple healthcare=* tags were introduced by healthcare proposal. This tag duplicating amenity=pharmacy was not introduced by this proposal. Author of the healthcare proposal wanted to deprecate amenity=pharmacy and replace it with shop=pharmacy, but due to strong opposition to deprecating amenity=pharmacy this was abandoned.

This tag started to be used later anyway, with intention to

  1. Add healthcare=pharmacy to existing amenity=pharmacy objects
  2. Add support in at least prominent data consumers for also healthcare=pharmacy in addition to supporting amenity=pharmacy
  3. Remove support for amenity=pharmacy in data consumers and remove this tag from pharmacies

There is opposition to this potential deprecation of widely used tag amenity=pharmacy. There is some support but it is often motivated by "this is part of the accepted proposal".

comment:28 Changed 14 months ago by mdk

How to deal with this ticket?
We have a test for such tags: org.openstreetmap.josm.data.osm.TaginfoTestIT.testCheckPopularTags()
And we have separate tickets solving the cases reported by this test like #14347, #20447, #21396

This is an endless job, but does it make sense to keep this ticket open? I think all mentioned tags in this ticket are handled or not longer a problem.

comment:29 Changed 14 months ago by mkoniecz

I think that in general idea is to create listing of what is not handled by JOSM and either start supporting tags/retag tags/mark them as ignored and then close ticket and open a new one with fresh listing.

comment:30 Changed 14 months ago by mkoniecz

So I guess that I would run this test, confirm that nothing is from this ticket (or is from this ticket but there is no useful discussion) and close this one and open new.

comment:31 Changed 14 months ago by taylor.smock

https://josm.openstreetmap.de/jenkins/job/JOSM-Integration/lastCompletedBuild/jdk=JDK8/testReport/org.openstreetmap.josm.data.osm/TaginfoTestIT/testCheckPopularTags__/

It looks like the current missing tags are:

  • building=sports_centre - 10049
  • dual_carriageway=yes - 11057
  • location=surface - 122947
  • man_made=lamp - 11708

comment:32 Changed 14 months ago by mdk

As I said, this is an endless job. But this ticket deals with a specific list of tags (see description). Are these tags solved?
There are already new tickets for new results of the test: #20447, #21396
And there are actually new missing tags as taylor smock said.

But we have lots of endless taks, where we don't create longterm tickets like changing TopLevelDomains, new Ubuntu versions, ....

My question was: does it make sense to keep THIS ticket open? It is about an old list of problems.
Wouldn't it make more sense to open a new ticket, when there are new missing tags instead of using this old ticket, which was not done for several years now!

comment:33 Changed 14 months ago by mkoniecz

Resolution: fixed
Status: newclosed

Yeah, this one is fixed as far as I can see.

comment:34 Changed 14 months ago by mkoniecz

(if this one is intended to be kept open forever, then description ideally would be changed with specific tag list shunted of to a separate issue)

(I have not opened a new one for https://josm.openstreetmap.de/ticket/16900#comment:31 list)

Last edited 14 months ago by mkoniecz (previous) (diff)

comment:35 Changed 14 months ago by mdk

Keywords: ex-longterm added
Milestone: Longterm

comment:36 Changed 14 months ago by mkoniecz

Keywords: unknown_tags added; unknown tags removed

comment:37 Changed 14 months ago by taylor.smock

I'm kind of planning on trying to keep on top of that for the foreseeable future (I get an RSS feed notification every 8 hours or so while that test is failing). I just don't want to add stuff right before I do a release (which is what I'm doing today). So hopefully we never have a big long list of tags to add in the future.

I just won't be adding new presets (most new top-level objects are going to be ignored until someone comes up with a good icon for it).

comment:38 Changed 14 months ago by taylor.smock

Milestone: 22.10

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.