Modify

Opened 7 months ago

Closed 7 months ago

Last modified 7 months ago

#16888 closed defect (fixed)

"suspicious tag combination - oneway=yes together with lanes:backward" on roads with oneway:psv

Reported by: mkoniecz Owned by: team
Priority: normal Milestone: 18.10
Component: Core validator Version:
Keywords: template_report Cc:

Description (last modified by mkoniecz)

What steps will reproduce the problem?

  1. Encounter road that in one direction is only for busses, bicycles and some similar exceptions
  2. Create way with oneway=yes, lanes:backward, oneway:psv=no, oneway:bicycle=no etc ( https://www.openstreetmap.org/way/475556393 )
  3. run validator

What is the expected result?

No complaints.

What happens instead?

"suspicious tag combination - oneway=yes together with lanes:backward" on road with oneway:psv

Please provide any additional information below. Attach a screenshot if possible.

https://wiki.openstreetmap.org/wiki/Key:oneway:psv (I just created it)

https://github.com/osm-fr/osmose-backend/issues/363 (equivalent osmose issue)

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-10-23 01:34:26 +0200 (Tue, 23 Oct 2018)
Build-Date:2018-10-23 01:33:02
Revision:14358
Relative:URL: ^/trunk

Identification: JOSM/1.5 (14358 en) Linux Ubuntu 16.04.5 LTS
Memory Usage: 373 MB / 869 MB (88 MB allocated, but free)
Java version: 1.8.0_191-b12, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: :0.0 1920x1080
Maximum Screen Size: 1920x1080
Dataset consistency test: No problems found

Plugins:
+ OpeningHoursEditor (34535)
+ buildings_tools (34572)
+ continuosDownload (82)
+ imagery_offset_db (34641)
+ measurement (34529)
+ reverter (34552)
+ todo (30306)

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.

Attachments (0)

Change History (7)

comment:1 Changed 7 months ago by mkoniecz

Description: modified (diff)

comment:2 Changed 7 months ago by naoliv

comment:3 Changed 7 months ago by Klumbumbus

Resolution: fixed
Status: newclosed

In 14364/josm:

fix #16888 - don't warn about oneway *:forward *:backward combinations if an exception to the oneway is set by oneway:bicycle=no or oneway:psv=no

comment:4 Changed 7 months ago by Klumbumbus

Milestone: 18.10

comment:5 Changed 7 months ago by mkoniecz

"oneway:bicycle=no" - are you sure? AFAIK bicycle lanes are not counted in lanes* tags.

comment:6 Changed 7 months ago by mkoniecz

" Is it similar to this example? ​https://wiki.openstreetmap.org/wiki/Key:lanes:psv " - yes, but without road markings. There is also weird mix of vehicles allowed in two directions. It is a temporary, long-term change, due to rebuilding of tram tracks busses now replaced tram line with heavy traffic and to avoid complete commuting collapse some roads were closed for cars and trucks in one direction.

comment:7 in reply to:  5 Changed 7 months ago by Klumbumbus

Replying to mkoniecz:

"oneway:bicycle=no" - are you sure? AFAIK bicycle lanes are not counted in lanes* tags.

The rule I changed is not restricted to lanes related tags but to all possible tags ending with :forward or :backward.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.