Modify

Opened 7 weeks ago

Closed 6 weeks ago

Last modified 6 weeks ago

#16792 closed defect (fixed)

power=switchgear preset not displayed

Reported by: anonymous Owned by: Klumbumbus
Priority: normal Milestone: 18.10
Component: Internal preset Version: latest
Keywords: power switchgear Cc:

Description (last modified by Don-vip)

If you tag something with eg. osmwiki:Tag:power=terminal no description is shown about the object, like <icon> Man Made/Power/*.


Attachments (6)

terminal.png (116.1 KB) - added by Klumbumbus 7 weeks ago.
tagspanel_terminal.png (6.1 KB) - added by anonymous 7 weeks ago.
tagspanel_switchgear.png (5.6 KB) - added by anonymous 7 weeks ago.
tagspanel_generator.png (5.6 KB) - added by anonymous 6 weeks ago.
tagspanel_catenary_mast.png (5.7 KB) - added by anonymous 6 weeks ago.
generator.png (5.6 KB) - added by anonymous 6 weeks ago.

Download all attachments as: .zip

Change History (22)

comment:1 Changed 7 weeks ago by Don-vip

Component: CoreInternal preset
Keywords: power terminal added
Milestone: 18.10
Priority: minornormal
Summary: Tags panel issue with some power=* tagsAdd power=terminal
Type: defectenhancement

comment:2 Changed 7 weeks ago by Don-vip

Description: modified (diff)

comment:3 Changed 7 weeks ago by anonymous

Please revise other power tags as well. Another example, switchgear. It already has an icon, I see it in tag adding window's history and in the editor.
I assumed if something has an icon (significant enough to have), it'll have a preset. Am I wrong?

BTW somehow the power=terminal preset appeared with translation.

comment:4 Changed 7 weeks ago by Klumbumbus

Both terminal and switchgear are part of the internal presets.
attachment:terminal.png
I don't understand what is missing.
(The only minor mistake I just noticed is the switchgear is rendered on nodes instead of on areas. That should be fixed.)

Last edited 7 weeks ago by Klumbumbus (previous) (diff)

Changed 7 weeks ago by Klumbumbus

Attachment: terminal.png added

comment:5 Changed 7 weeks ago by Don-vip

Owner: changed from team to anonymous
Status: newneedinfo

Please describe what you want.

Changed 7 weeks ago by anonymous

Attachment: tagspanel_terminal.png added

Changed 7 weeks ago by anonymous

Attachment: tagspanel_switchgear.png added

comment:6 Changed 7 weeks ago by anonymous

Klumbumbus, you have right. It has some kind of preset, but not what I meant to. I don't exactly know the terms you use for the different parts of the application but I try my best to explain.

I attached two pictures, hope it helps to understand the point.

As far as I know, this panel called "Tags" which was the original title of the issue, because it's an issue, not an enhancement.

Note that the red bordered clickable "preset" was not there at the moment of the report. It just appeared as I mentioned in comment:3.

comment:7 Changed 7 weeks ago by anonymous

Keywords: terminal removed

comment:8 Changed 6 weeks ago by Don-vip

Description: modified (diff)
Keywords: switchgear added
Summary: Add power=terminalpower=switchgear preset not displayed
Type: enhancementdefect

Changed 6 weeks ago by anonymous

Attachment: tagspanel_generator.png added

Changed 6 weeks ago by anonymous

Attachment: tagspanel_catenary_mast.png added

comment:9 Changed 6 weeks ago by anonymous

generator not displaying at all. The catenary_mast preset only appears if the tag is on a node (it should be on a node according to the OSM wiki). I'm not sure it's a bug with catenary_mast, but with generator definitely, it is.

Replying to Klumbumbus:

(The only minor mistake I just noticed is the switchgear is rendered on nodes instead of on areas. That should be fixed.)

This confused me because it gave me the impression it's the right type (node) otherwise the icons disappear on areas.

Also if I add the tag from the Presets>Man Made>Power>Terminal to a way, JOSM will warn me The preset Terminal cannot be applied since the selection is unsuitable. But on Tags panel I can add the terminal tag for any type of object, JOSM not checking anything. This is maybe another issue, but I'm trying to sum up everything which led me to this report.

In short:

  1. JOSM not always checking known tags applicability before tagging
  2. The rendering not always right

And after these, no further info provided on the UI, see

comment:10 Changed 6 weeks ago by Don-vip

Owner: changed from anonymous to team
Status: needinfonew

comment:11 Changed 6 weeks ago by Klumbumbus

Owner: changed from team to Klumbumbus
Status: newassigned

comment:12 Changed 6 weeks ago by Klumbumbus

Resolution: fixed
Status: assignedclosed

In 14299/josm:

fix #16792 - fix rendering of power=switchgear from node to area, add a warning; allow mulitipolygon for power=switchgear, generator:source=hydro and generator:source=tidal in presets

comment:13 in reply to:  9 ; Changed 6 weeks ago by Klumbumbus

Replying to anonym:

generator not displaying at all.

As there are seperate presets for each generator:source you need to set this tag to get the links in the Tags/Membership dialog.

The catenary_mast preset only appears if the tag is on a node (it should be on a node according to the OSM wiki).

This sentence doesn't make sense.

Also if I add the tag from the Presets>Man Made>Power>Terminal to a way, JOSM will warn me The preset Terminal cannot be applied since the selection is unsuitable. But on Tags panel I can add the terminal tag for any type of object, JOSM not checking anything.

The presets help to use the right tags on the right objects but they don't offer every single rare tag. So in manual editing you can tachnically add all tags you want on all objects. This is the wanted behavior. (Running the validator helps to find the most common tagging mistakes.)

comment:14 in reply to:  13 ; Changed 6 weeks ago by anonymous

Replying to Klumbumbus:

As there are seperate presets for each generator:source you need to set this tag to get the links in the Tags/Membership dialog.

This behaviour is a bit confusing (for me, at least) but okay.

This sentence doesn't make sense.

Yep, I couldn't edit after submitting the comment (maybe I should register). Sorry about that.

The presets help to use the right tags on the right objects but they don't offer every single rare tag. So in manual editing you can tachnically add all tags you want on all objects. This is the wanted behavior. (Running the validator helps to find the most common tagging mistakes.)

The idea behind it - why repair something after the action when you could do it before? You could say, OSM evolves this way. Users introduce new tags or use the old ones on new (until then not recommended) types of objects.
But then there are the presets, where you can only add tags for specified objects. Or this is like the presets is for the beginners and the built-in checks help them to make fewer mistakes, then the Tags/Membership dialogue is for more advanced users?

comment:15 in reply to:  14 ; Changed 6 weeks ago by Klumbumbus

Replying to anonym:

Replying to Klumbumbus:

As there are seperate presets for each generator:source you need to set this tag to get the links in the Tags/Membership dialog.

This behaviour is a bit confusing (for me, at least) but okay.

Every power=generator should have the generator:source=* tag too. If you use one of the 17 generator presets, both tags are set automatically and everything is fine. If you manually set power=generator only, none of the 17 presets can be linked as it is unclear which one should be linked.

comment:16 in reply to:  15 Changed 6 weeks ago by anonymous

Replying to Klumbumbus:

Every power=generator should have the generator:source=* tag too. If you use one of the 17 generator presets, both tags are set automatically and everything is fine. If you manually set power=generator only, none of the 17 presets can be linked as it is unclear which one should be linked.

That's right. Why is there rendered icon when generator:source is not added to the object (actually node)? When I mentioned the behaviour, I thought about this.

Changed 6 weeks ago by anonymous

Attachment: generator.png added

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Klumbumbus.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.