Modify

Opened 9 months ago

Closed 9 months ago

Last modified 5 months ago

#16686 closed defect (fixed)

AIOOBE at java.awt.TexturePaintContext$Int.setRaster

Reported by: remontees@… Owned by: team
Priority: normal Milestone: 18.09
Component: Core mappaint Version: latest
Keywords: template_report ibm openj9 javabug Cc:

Description

What steps will reproduce the problem?

  1. Downloading OSM data around Sarcenas (Isère, France)
  2. Imagerie > Bing

What is the expected result? Bing images should appear at the background of the map.

What happens instead? An error appeared

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-08-22 19:44:25 +0200 (Wed, 22 Aug 2018)
Build-Date:2018-08-22 17:46:33
Revision:14178
Relative:URL: ^/trunk

Identification: JOSM/1.5 (14178 fr) Linux Mint 18.3 Sylvia
Memory Usage: 184 MB / 512 MB (36 MB allocated, but free)
Java version: 8.0.5.16 - pxa6480sr5fp16-20180524_01(SR5 FP16), IBM Corporation, IBM J9 VM
Screen: :0.0 1920x1080
Maximum Screen Size: 1920x1080
VM arguments: [-Xoptionsfile=<java.home>/lib/amd64/compressedrefs/options.default, -Xlockword:mode=default,noLockword=java/lang/String,noLockword=java/util/MapEntry,noLockword=java/util/HashMap$Entry,noLockword=org/apache/harmony/luni/util/ModifiedMap$Entry,noLockword=java/util/Hashtable$Entry,noLockword=java/lang/invoke/MethodType,noLockword=java/lang/invoke/MethodHandle,noLockword=java/lang/invoke/CollectHandle,noLockword=java/lang/invoke/ConstructorHandle,noLockword=java/lang/invoke/ConvertHandle,noLockword=java/lang/invoke/ArgumentConversionHandle,noLockword=java/lang/invoke/AsTypeHandle,noLockword=java/lang/invoke/ExplicitCastHandle,noLockword=java/lang/invoke/FilterReturnHandle,noLockword=java/lang/invoke/DirectHandle,noLockword=java/lang/invoke/ReceiverBoundHandle,noLockword=java/lang/invoke/DynamicInvokerHandle,noLockword=java/lang/invoke/FieldHandle,noLockword=java/lang/invoke/FieldGetterHandle,noLockword=java/lang/invoke/FieldSetterHandle,noLockword=java/lang/invoke/StaticFieldGetterHandle,noLockword=java/lang/invoke/StaticFieldSetterHandle,noLockword=java/lang/invoke/IndirectHandle,noLockword=java/lang/invoke/InterfaceHandle,noLockword=java/lang/invoke/VirtualHandle,noLockword=java/lang/invoke/PrimitiveHandle,noLockword=java/lang/invoke/InvokeExactHandle,noLockword=java/lang/invoke/InvokeGenericHandle,noLockword=java/lang/invoke/VarargsCollectorHandle,noLockword=java/lang/invoke/ThunkTuple, -Dcom.ibm.oti.vm.bootstrap.library.path=<java.home>/lib/amd64/compressedrefs:<java.home>/lib/amd64, -Dsun.boot.library.path=<java.home>/lib/amd64/compressedrefs:<java.home>/lib/amd64, -Djava.library.path=<java.home>/lib/amd64/compressedrefs:<java.home>/lib/amd64:/usr/lib64:/usr/lib, -Djava.home=<java.home>, -Djava.ext.dirs=<java.home>/lib/ext, -Duser.dir=${HOME}/Bureau, -Djava.runtime.version=pxa6480sr5fp16-20180524_01 (SR5 FP16), -Djava.class.path=., -Djava.class.path=josm-tested.jar, -Dsun.java.command=josm-tested.jar, -Dsun.java.launcher=SUN_STANDARD, -Dsun.java.launcher.pid=5254]
Dataset consistency test: No problems found

Last errors/warnings:
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- E: Handled by bug report queue: java.lang.ArrayIndexOutOfBoundsException
- E: Handled by bug report queue: java.lang.ArrayIndexOutOfBoundsException


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (35) of main
java.lang.ArrayIndexOutOfBoundsException
	at java.awt.TexturePaintContext$Int.setRaster(TexturePaintContext.java:456)
	at java.awt.TexturePaintContext.getRaster(TexturePaintContext.java:236)
	at sun.java2d.pipe.AlphaPaintPipe.renderPathTile(AlphaPaintPipe.java:136)
	at sun.java2d.pipe.SpanShapeRenderer$Composite.renderBox(SpanShapeRenderer.java:72)
	at sun.java2d.pipe.SpanShapeRenderer.spanClipLoop(SpanShapeRenderer.java:225)
	at sun.java2d.pipe.SpanShapeRenderer.renderSpans(SpanShapeRenderer.java:208)
	at sun.java2d.pipe.SpanShapeRenderer.fill(SpanShapeRenderer.java:128)
	at sun.java2d.pipe.ValidatePipe.fill(ValidatePipe.java:172)
	at sun.java2d.SunGraphics2D.fill(SunGraphics2D.java:2539)
	at org.openstreetmap.josm.gui.layer.OsmDataLayer.paint(OsmDataLayer.java:501)
	at org.openstreetmap.josm.gui.layer.AbstractMapViewPaintable$CompatibilityModeLayerPainter.paint(AbstractMapViewPaintable.java:27)
	at org.openstreetmap.josm.gui.MapView.paintLayer(MapView.java:468)
	at org.openstreetmap.josm.gui.MapView.drawMapContent(MapView.java:583)
	at org.openstreetmap.josm.gui.MapView.paint(MapView.java:490)
	at javax.swing.JComponent.paintChildren(JComponent.java:900)
	at javax.swing.JComponent.paint(JComponent.java:1076)
	at javax.swing.JComponent.paintToOffscreen(JComponent.java:5221)
	at javax.swing.BufferStrategyPaintManager.paint(BufferStrategyPaintManager.java:301)
	at javax.swing.RepaintManager.paint(RepaintManager.java:1283)
	at javax.swing.JComponent._paintImmediately(JComponent.java:5169)
	at javax.swing.JComponent.paintImmediately(JComponent.java:4980)
	at javax.swing.RepaintManager$4.run(RepaintManager.java:842)
	at javax.swing.RepaintManager$4.run(RepaintManager.java:825)
	at java.security.AccessController.doPrivileged(AccessController.java:666)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:91)
	at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:825)
	at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:800)
	at javax.swing.RepaintManager.prePaintDirtyRegions(RepaintManager.java:749)
	at javax.swing.RepaintManager.access$1200(RepaintManager.java:75)
	at javax.swing.RepaintManager$ProcessingRunnable.run(RepaintManager.java:1743)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:322)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:769)
	at java.awt.EventQueue.access$500(EventQueue.java:108)
	at java.awt.EventQueue$3.run(EventQueue.java:720)
	at java.awt.EventQueue$3.run(EventQueue.java:714)
	at java.security.AccessController.doPrivileged(AccessController.java:666)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:91)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:739)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:216)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:127)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:112)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:104)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:93)

Attachments (0)

Change History (11)

comment:1 Changed 9 months ago by Don-vip

Component: CoreCore imagery
Keywords: ibm openj9 javabug added
Priority: criticalnormal

comment:2 Changed 9 months ago by Don-vip

Owner: changed from team to remontees@…
Status: newneedinfo

How did you install Java? Can you please tell me what package is installed and its exact version?

comment:3 Changed 9 months ago by remontees

I installed java-common version 0.56ubuntu2 by the repository of Ubuntu Xenial

comment:4 Changed 9 months ago by Don-vip

Then how do you get to run JOSM with IBM J9 runtime? You're the first one to report a JOSM bug with this JVM. java-common traditionally install openJDK. I can't find any openj9 package in Ubuntu repositories.

comment:5 Changed 9 months ago by anonymous

I don't really now, I just started JOSM with this command java -jar josm-tested.jar
No more… !

comment:6 Changed 9 months ago by Don-vip

Owner: changed from remontees@… to team
Status: needinfonew

comment:7 Changed 9 months ago by Don-vip

Component: Core imageryCore mappaint

comment:8 Changed 9 months ago by Don-vip

Milestone: 18.09

comment:9 Changed 9 months ago by Don-vip

Resolution: fixed
Status: newclosed

In 14182/josm:

fix #16686 - add robustness when drawing hatched area for non-downloaded region

comment:10 Changed 9 months ago by Don-vip

Summary: Trying to add Bing images at the backgroundAIOOBE at java.awt.TexturePaintContext$Int.setRaster

comment:11 Changed 5 months ago by kiwiwings@…

I had the same problem while getting our project working again with the IBM JDK and searched for the stacktrace which lead me here. In my case the AIOOBE could not always be reproduced while debugging. In the end it seems to be a JIT issue which could be fixed by adding the following to the VM parameters.

 -Xjit:exclude={sun/java2d/pipe/AlphaPaintPipe.renderPathTile(Ljava/lang/Object;[BIIIIII)V}

For more information about determining/disabling the JIT-compiled classes have a look at the
IBM docs

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.