Modify

Opened 2 years ago

Closed 20 months ago

Last modified 16 months ago

#16525 closed enhancement (fixed)

[PATCH] Internal preset does not cover most tags/values of sport=climbing

Reported by: schoschi Owned by: Don-vip
Priority: normal Milestone: 18.12
Component: Internal preset Version:
Keywords: sport climbing Cc:

Description (last modified by schoschi)

JOSM's internal preset does not cover most tags/values of https://wiki.openstreetmap.org/wiki/Tag:sport%3Dclimbing which increases required effort to map them and probably is one reason why they are not used widely even after years.

Attached is a patch. It provided EN and DE texts. As usual tags as well as usual values differ between climbs on natural and artificial structures, I added two distinct items.

Attachments (3)

defaultpresets.xml.patch (9.4 KB) - added by schoschi 2 years ago.
patched default presets
JOSM preset climbing.xml (8.6 KB) - added by schoschi 2 years ago.
"JOSM preset climbing.xml" can be manually added into JOSM for easy trying of submitted patch, or as a workaround until the patch is included into JOSM releases.
defaultpresets 2018-08-06.xml.patch (8.0 KB) - added by schoschi 2 years ago.

Download all attachments as: .zip

Change History (28)

Changed 2 years ago by schoschi

Attachment: defaultpresets.xml.patch added

patched default presets

comment:1 Changed 2 years ago by schoschi

Description: modified (diff)

Changed 2 years ago by schoschi

Attachment: JOSM preset climbing.xml added

"JOSM preset climbing.xml" can be manually added into JOSM for easy trying of submitted patch, or as a workaround until the patch is included into JOSM releases.

comment:2 Changed 2 years ago by Klumbumbus

Component: CoreInternal preset

comment:3 Changed 2 years ago by Don-vip

Thanks! Two remarks to take into account:

  • We don't maintain translations in the presets file. Only English is included, then all languages are translated on Launchpad. So the German translations must be removed
  • There is an indentation problem (tabs instead of spaces, or too many spaces)

comment:4 Changed 2 years ago by schoschi

Thank you for the feedback. In case you have to give it more often, you may want to add both as coding convetion to https://josm.openstreetmap.de/wiki/DevelopersGuide/DefaultPresets
@1: I removed the German translations except for link element (so similar to other item elements in the XML). I will add translations via Launchpad when I figured out how that works...
@2: I investigated the other parts of the XML and replaced tabs by 4 spaces. Hope that is fine.

Changed 2 years ago by schoschi

comment:5 Changed 2 years ago by schoschi

I want to support OSM & JOSM comunity but sorry, for just once submitting some translated strings I am not motivated to invest 1-2 hours to read Ubuntu One terms of service, Ubuntu data privacy policy and Ubuntu Canonical's SSO privacy notice and then create an Ubuntu account and then create a Launchpad account and then start to learn how to translate using Launchpad. Someone from the community who is more into Ubuntu and translations can extract (even automatically) the translated strings from the original .patch or preset .xml files I submitted.

comment:6 Changed 2 years ago by Don-vip

Keywords: sport climbing added
Milestone: 18.09

comment:7 Changed 23 months ago by Don-vip

Milestone: 18.0918.10

comment:8 Changed 22 months ago by Don-vip

Milestone: 18.1018.11

comment:9 Changed 22 months ago by RicoZ

We have recently revamped the climbing page and documented the grading values without the min/max/mean that can be used to tag single routes, eg "climbing:grade:uiaa" https://taginfo.openstreetmap.org/keys/climbing%3Agrade%3Auiaa

Could you please add those to the preset?

Also, would it be possible to provide a selection of common values for grading so mappers are less likely to mistype them?

comment:10 Changed 21 months ago by Klumbumbus

Milestone: 18.1118.12

comment:11 Changed 20 months ago by Don-vip

Owner: changed from team to Don-vip
Status: newassigned

comment:12 Changed 20 months ago by Don-vip

Resolution: fixed
Status: assignedclosed

In 14591/josm:

fix #16525 - improve sport=climbing presets (patch by schoschi, modified)

comment:13 Changed 20 months ago by Don-vip

In 14597/josm:

see #16525 - fix issues

comment:14 Changed 20 months ago by Don-vip

Issue created for the opening_hours warning

comment:15 Changed 19 months ago by Don-vip

In 14644/josm:

see #16525 - fix i18n issue

comment:16 Changed 19 months ago by ypid23

Hi,

About the opening_hours warning. The example opening_hours value that is used in this preset is not ideal and I do not consider the warning that is given a false positive. It is missing important information:

  • Is it open on public holidays?
  • What time is it open/allowed?

Maybe an example like:

Mar-Jun closed; Jul-Feb Th-Su,PH 06:00-18:00

can be used. Or maybe you have an even better/more realistic value for this preset. Please also consider to rework the other example opening_hours. Ideally they would all be realistic and fully valid. To do this, I would propose:

'sunset-sunrise open; sunrise-sunset closed;' -> 'Mo-Su,PH sunset-sunrise'

Please try all values in https://openingh.ypid.de/evaluation_tool/, I tried really hard to give tips/warnings:

  • "This rule does not contain anything useful. Please remove this empty rule. Might it be possible that you are a programmer and adding a semicolon after each statement is hardwired in your muscle memory ;) ? The thing is that the semicolon in the opening_hours syntax is defined as rule separator. So for compatibility reasons you should omit this last semicolon."

comment:17 Changed 19 months ago by Don-vip

OK, thanks! :)

comment:18 Changed 19 months ago by Don-vip

In 14663/josm:

see #16525 - use more explicit opening_hours value

comment:19 Changed 19 months ago by simon04

In 14730/josm:

see #16525 - Exclude numeric climbing values from i18n

comment:20 Changed 17 months ago by simon@…

General question which seems to be completely skipped in the wiki discussions etc: does this tagging promote the sport tag to a top level "object" tag?

In particular https://wiki.openstreetmap.org/wiki/Climbing#Climbing_Routes would seem to be suggest the routes to be mappedas stand alone entities.

comment:21 Changed 17 months ago by anonymous

In this case climbing=route is for me the primary tag.

comment:22 Changed 17 months ago by anonymous

Which is naturally even worse.

comment:23 Changed 16 months ago by RicoZ

The history is that someone who created/maintained the sport=climbing page/tag was at some point long ago strongly against mapping of single climbing routes and other details. Hence it seems there was little coordination with the climbing proposal. Some time ago User:Tigerfell and me merged it as good as we could figure out.

As I understand it there is supposed to be a sport=climbing on some object. This could be even a climbing=route but in practice this will be rare and the sport=climbing will mostly be applied to a natural=cliff, a building with indoor climbing, a crag or just a node showing the general location.

comment:24 Changed 16 months ago by simon@…

@RicoZ the problem is that up to now, the sport key/tag was considered to be an attribute of an otherwise mapped object, for example leisure=pitch. In the case of climbing routes, these are individual "objects" on their own. So while you could add sport=climbing to a cliff, it still wouldn't change that for routes up the cliff you still have this issue.

A quick check in taginfo and overpass would seem to indicate that climbing=route and climbing=route_bottom (which is more popular, but interesting enough is missing from the preset) are not consistently used in one way or the other. Which in my experience implies that things will gravitate towards climbing being used on its own.

comment:25 Changed 16 months ago by RicoZ

@simon: I think you are right predicting that climbing routes will be probably frequently used without sport=climbing. We could change the wiki but I don't know how to make it better. Attaching sport=climbing to each climbing route would not feel right for me unless those were on separate cliffs? In some way I consider the situation similar to sport=cycling - afaik pretty much nobody uses it for outdoor mtb tracks.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.