Modify

Opened 7 months ago

Closed 7 months ago

#16491 closed defect (fixed)

NPE at Territories.isIso3166Code

Reported by: naoliv Owned by: team
Priority: normal Milestone: 18.07
Component: Core mappaint Version:
Keywords: regression Cc:

Description (last modified by naoliv)

Before uploading some data I saw some messages in the console:

2018-07-16 10:55:25.720 GRAVE: java.lang.reflect.InvocationTargetException. Causa: java.lang.NullPointerException
java.lang.reflect.InvocationTargetException
	at jdk.internal.reflect.GeneratedMethodAccessor84.invoke(Unknown Source)
	at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.base/java.lang.reflect.Method.invoke(Method.java:564)
	at org.openstreetmap.josm.gui.mappaint.mapcss.ExpressionFactory$ParameterFunction.evaluate(ExpressionFactory.java:1320)
	at org.openstreetmap.josm.gui.mappaint.mapcss.ConditionFactory$ExpressionCondition.applies(ConditionFactory.java:876)
	at org.openstreetmap.josm.gui.mappaint.mapcss.Selector$AbstractSelector.matches(Selector.java:485)
	at org.openstreetmap.josm.gui.mappaint.mapcss.Selector$GeneralSelector.matches(Selector.java:563)
	at org.openstreetmap.josm.data.validation.tests.MapCSSTagChecker$TagCheck.whichSelectorMatchesEnvironment(MapCSSTagChecker.java:415)
	at org.openstreetmap.josm.data.validation.tests.MapCSSTagChecker.getErrorsForPrimitive(MapCSSTagChecker.java:693)
	at org.openstreetmap.josm.data.validation.tests.MapCSSTagChecker.getErrorsForPrimitive(MapCSSTagChecker.java:679)
	at org.openstreetmap.josm.data.validation.tests.MapCSSTagChecker.check(MapCSSTagChecker.java:715)
	at org.openstreetmap.josm.data.validation.Test$TagTest.visit(Test.java:136)
	at org.openstreetmap.josm.data.osm.Relation.accept(Relation.java:174)
	at org.openstreetmap.josm.data.validation.Test.visit(Test.java:210)
	at org.openstreetmap.josm.actions.upload.ValidateUploadHook.checkUpload(ValidateUploadHook.java:64)
	at org.openstreetmap.josm.actions.UploadAction.checkPreUploadConditions(UploadAction.java:217)
	at org.openstreetmap.josm.actions.UploadAction.uploadData(UploadAction.java:241)
	at org.openstreetmap.josm.actions.UploadAction.actionPerformed(UploadAction.java:301)
	at java.desktop/javax.swing.SwingUtilities.notifyAction(SwingUtilities.java:1810)
	at java.desktop/javax.swing.JComponent.processKeyBinding(JComponent.java:2900)
	at java.desktop/javax.swing.KeyboardManager.fireBinding(KeyboardManager.java:311)
	at java.desktop/javax.swing.KeyboardManager.fireKeyboardAction(KeyboardManager.java:266)
	at java.desktop/javax.swing.JComponent.processKeyBindingsForAllComponents(JComponent.java:2993)
	at java.desktop/javax.swing.JComponent.processKeyBindings(JComponent.java:2985)
	at java.desktop/javax.swing.JComponent.processKeyEvent(JComponent.java:2862)
	at java.desktop/java.awt.Component.processEvent(Component.java:6366)
	at java.desktop/java.awt.Container.processEvent(Container.java:2261)
	at java.desktop/java.awt.Component.dispatchEventImpl(Component.java:4966)
	at java.desktop/java.awt.Container.dispatchEventImpl(Container.java:2319)
	at java.desktop/java.awt.Component.dispatchEvent(Component.java:4798)
	at java.desktop/java.awt.KeyboardFocusManager.redispatchEvent(KeyboardFocusManager.java:1950)
	at java.desktop/java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent(DefaultKeyboardFocusManager.java:871)
	at java.desktop/java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent(DefaultKeyboardFocusManager.java:1140)
	at java.desktop/java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(DefaultKeyboardFocusManager.java:1010)
	at java.desktop/java.awt.DefaultKeyboardFocusManager.dispatchEvent(DefaultKeyboardFocusManager.java:836)
	at java.desktop/java.awt.Component.dispatchEventImpl(Component.java:4847)
	at java.desktop/java.awt.Container.dispatchEventImpl(Container.java:2319)
	at java.desktop/java.awt.Window.dispatchEventImpl(Window.java:2772)
	at java.desktop/java.awt.Component.dispatchEvent(Component.java:4798)
	at java.desktop/java.awt.EventQueue.dispatchEventImpl(EventQueue.java:772)
	at java.desktop/java.awt.EventQueue.access$600(EventQueue.java:97)
	at java.desktop/java.awt.EventQueue$4.run(EventQueue.java:721)
	at java.desktop/java.awt.EventQueue$4.run(EventQueue.java:715)
	at java.base/java.security.AccessController.doPrivileged(Native Method)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:87)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:97)
	at java.desktop/java.awt.EventQueue$5.run(EventQueue.java:745)
	at java.desktop/java.awt.EventQueue$5.run(EventQueue.java:743)
	at java.base/java.security.AccessController.doPrivileged(Native Method)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:87)
	at java.desktop/java.awt.EventQueue.dispatchEvent(EventQueue.java:742)
	at java.desktop/java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:203)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:124)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:113)
	at java.desktop/java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:109)
	at java.desktop/java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.desktop/java.awt.EventDispatchThread.run(EventDispatchThread.java:90)
Caused by: java.lang.NullPointerException
	at org.openstreetmap.josm.tools.Territories.isIso3166Code(Territories.java:66)
	at org.openstreetmap.josm.gui.mappaint.mapcss.ExpressionFactory$Functions.inside(ExpressionFactory.java:1031)
	... 57 more

I was working here https://www.openstreetmap.org/relation/3986083 (if it helps with the org.openstreetmap.josm.tools.Territories.isIso3166Code(Territories.java:66) part)

JOSM:

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-07-16 01:20:27 +0200 (Mon, 16 Jul 2018)
Revision:14034
Build-Date:2018-07-16 01:32:44
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (14034 pt_BR) Linux Debian GNU/Linux testing (buster)
Memory Usage: 748 MB / 7168 MB (578 MB allocated, but free)
Java version: 10.0.1+10-Debian-4, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1600x900, :0.1 1280x1024
Maximum Screen Size: 1600x1024
Java package: openjdk-10-jre:amd64-10.0.1+10-4
Java ATK Wrapper package: libatk-wrapper-java:all-0.33.3-21
VM arguments: [--add-modules=java.activation,java.se.ee, -Dawt.useSystemAAFontSettings=gasp]

Attachments (0)

Change History (5)

comment:1 Changed 7 months ago by naoliv

Description: modified (diff)

comment:2 Changed 7 months ago by Don-vip

Keywords: regression added
Milestone: 18.07

comment:3 Changed 7 months ago by Don-vip

Component: CoreCore mappaint

comment:4 Changed 7 months ago by Don-vip

Summary: GRAVE: java.lang.reflect.InvocationTargetException caused by java.lang.NullPointerExceptionNPE at Territories.isIso3166Code

comment:5 Changed 7 months ago by Don-vip

Resolution: fixed
Status: newclosed

In 14035/josm:

fix #16491 - NPE

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.