Modify

Opened 6 years ago

Closed 6 years ago

#16476 closed enhancement (duplicate)

In the relation list, show easier-to-distinguish relation names

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: japan boundary relation Cc:

Description (last modified by Don-vip)

I'm currently mapping Fujimino (Saitama, Japan). In there, there are (like in most Japanese cities) a lot of neighborhoods called “1-banchi”, that are distinguished by the “X-chome”-type relation they have for parent, which are themselves distinguished by the (named) quarter relation they have for parent (and the parent of the quarter is the city).

As a consequence, in the relation list, I have currently about 10 relations named “1-banchi”, which makes for a pretty hard-to-use list.

Would it be possible to show the relation name the displayed relation is memberOf? (and preferentially recursively up to the root, here Japan I guess, and potentially limiting to subarea-type membership-ness)

Alternatively, would it be possible to show a “full_name” tag, when one exists, in which I could put the whole “Fujimino Kiyomi 1-chome 1-banchi” address?


Anyway, thank you for the work you do on JOSM!

Attachments (2)

screenshot.png (483.5 KB ) - added by anonymous 6 years ago.
fujimino.osm (4.6 MB ) - added by anonymous 6 years ago.

Change History (11)

comment:1 by Klumbumbus, 6 years ago

That seems to me a bit too specific and a change would maybe worsen the situation in other contexts. Could you please add a sample data set (.osm file) and a screenshot showing the problem?

comment:2 by Don-vip, 6 years ago

Owner: changed from team to anonymous
Status: newneedinfo

by anonymous, 6 years ago

Attachment: screenshot.png added

by anonymous, 6 years ago

Attachment: fujimino.osm added

comment:3 by anonymous, 6 years ago

I guess it's a bit specific indeed, but as Japanese addresses will get mapped it will likely become the norm here. (Currently there are almost no address mapped as far as I can tell.)

Here are the two requested files. The main difficulty is when wanting to look for relation eg. Fujimino Kiyomi 1-chome 1-banchi, then I have to either go to the Fujimino relation and get down three times, every time opening a new window, or test all 1-banchi relations until I figure out thanks to highlighting which one is the right one.

Unfortunately, that's not very helpful.

(For the context, one Banchi is approximately a block, and addresses are attributed as house numbers inside the block in Japan, hence the need for it in order to map addresses.)

Anyway, thank you for reading me!
Ekleog

comment:4 by Klumbumbus, 6 years ago

Owner: changed from anonymous to team
Status: needinfonew

comment:5 by Klumbumbus, 6 years ago

Not sure if we could do something with name templates

comment:6 by Don-vip, 6 years ago

Description: modified (diff)

comment:7 by Don-vip, 6 years ago

Keywords: japan boundary relation added

We could also change the relations dialog to display a tree, where child relations appear under the parent relation node. I think there's already a ticket about that.

comment:8 by Don-vip, 6 years ago

Yep, #4399

comment:9 by anonymous, 6 years ago

Resolution: duplicate
Status: newclosed

Closed as duplicate of #4399.
Klumbumbus: Oh wow, that's great! Thanks, I was able to fix my issue with this name template :)

boundary[{admin_level}]: !{parent() type=boundary '!{parent() type=boundary '{name}'} {name}'}-{name}

(even though for some weird reason this appears to output one additional space after the second {name} element, that's not a big deal, and I'll let you open a bug if you think that deserves fixing)

Closing as dup of #4399, as that's the only thing that may still be missing to help mapping.

Thank you for your help!
Ekleog

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.