Modify

Opened 8 months ago

Closed 8 months ago

Last modified 8 months ago

#16458 closed defect (fixed)

False positives with roles guidepost and information in hiking routes

Reported by: Davidleci Owned by: team
Priority: normal Milestone: 18.07
Component: Internal preset Version: latest
Keywords: role guidepost information route hiking Cc: Klumbumbus

Description

Dear JOSM team:

I do not understand why JOSM warn me about errors relating to guidepost in route relations. I included a guidepost into two hiking routes and JOSM told me that it did not know the role guidepost for type route relations.
Can you download this node (https://www.openstreetmap.org/node/5680431998) with JOSM and tell me where is the error that I cannot find?

Excuse me for not writing from my computer. I like editing with JOSM, but this summer I have not much time for it.

Thank you for your work.

Attachments (1)

bugroles.png (20.8 KB) - added by Don-vip 8 months ago.

Download all attachments as: .zip

Change History (12)

comment:1 in reply to:  description Changed 8 months ago by Don-vip

Keywords: role route hiking added; roles: removed
Milestone: 18.07

Replying to davidjulianez@…:

I do not understand why JOSM warn me about errors relating to guidepost in route relations.

Because guidepost is not a defined role in the JOSM route presets.

But I see this is documented and the OSM database contains 48519 members with guidepost role.

Last edited 8 months ago by Don-vip (previous) (diff)

comment:2 Changed 8 months ago by Don-vip

Component: CoreInternal preset

Changed 8 months ago by Don-vip

Attachment: bugroles.png added

comment:3 Changed 8 months ago by Don-vip

Cc: Klumbumbus added

Bug fixed with a chunk:

  <chunk id="walking_routes_roles">
     <roles>
         <role key="" text="route segment" requisite="required" type="way,closedway" member_expression="highway|route=ferry"/>
         <role key="" text="infrastructure" requisite="optional" type="node,closedway" member_expression="tourism OR amenity"/>
         <role key="" text="natural" requisite="optional" type="node,closedway" member_expression="natural=peak OR natural=volcano OR mountain_pass=yes OR natural=water OR tourism=viewpoint OR amenity=drinking_water OR natural=spring OR place=locality"/>
         <role key="guidepost" text="guidepost" requisite="optional" type="node" member_expression="information=guidepost"/>
     </roles>
  </chunk>

But this causes this bug, the chunk is duplicated:


Did you see this problem already? Maybe there's an other ticket.

comment:4 Changed 8 months ago by Klumbumbus

No I didn't see this before as we don't have roles defined in chunks in the internal preset until now.
However by a quick check I can't reproduce your bug. roles in chunks work fine for me, i.e. displayed only once. Did you double check that you didn't accidently double reference the chunk or chunk + "normal" roles?

comment:5 Changed 8 months ago by Don-vip

This is what I did:

  • data/defaultpresets.xml

     
    438438  <chunk id="motorcycle_brands">
    439439    <multiselect key="brand" text="Motorcycle brand" values="Aprillia;BMW;Ducati;Gilera;Harley-Davidson;Honda;Kawasaki;KTM;Kymco;Piaggio;Peugeot;Piaggio;Suzuki;Triumph;Vespa;Yamaha" values_no_i18n="true" />
    440440  </chunk>
     441  <chunk id="walking_routes_roles">
     442     <roles>
     443         <role key="" text="route segment" requisite="required" type="way,closedway" member_expression="highway|route=ferry"/>
     444         <role key="" text="infrastructure" requisite="optional" type="node,closedway" member_expression="tourism OR amenity"/>
     445         <role key="" text="natural" requisite="optional" type="node,closedway" member_expression="natural=peak OR natural=volcano OR mountain_pass=yes OR natural=water OR tourism=viewpoint OR amenity=drinking_water OR natural=spring OR place=locality"/>
     446         <role key="guidepost" text="guidepost" requisite="optional" type="node" member_expression="information=guidepost"/>
     447     </roles>
     448  </chunk>
    441449  <!-- Link chunks -->
    442450  <chunk id="link_contact_address">
    443451    <preset_link preset_name="Contact (Common Schema)" />
     
    1169311701                <optional>
    1169411702                    <reference ref="route_hikebike_optionals" />
    1169511703                </optional>
    11696                 <roles>
    11697                     <role key="" text="route segment" requisite="required" type="way,closedway" member_expression="highway|route=ferry"/>
    11698                     <role key="" text="infrastructure" requisite="optional" type="node,closedway" member_expression="tourism OR amenity"/>
    11699                     <role key="" text="natural" requisite="optional" type="node,closedway" member_expression="natural=peak OR natural=volcano OR mountain_pass=yes OR natural=water OR tourism=viewpoint OR amenity=drinking_water OR natural=spring OR place=locality"/>
    11700                 </roles>
     11704                <reference ref="walking_routes_roles" />
    1170111705            </item> <!-- Hiking Route -->
    1170211706            <item name="Walking Route" icon="presets/misc/route.svg" type="relation" preset_name_label="true">
    1170311707                <link href="https://wiki.openstreetmap.org/wiki/Tag:route=foot"
     
    1171111715                <optional>
    1171211716                    <reference ref="route_hikebike_optionals" />
    1171311717                </optional>
    11714                 <roles>
    11715                     <role key="" text="route segment" requisite="required" type="way,closedway" member_expression="highway|route=ferry"/>
    11716                     <role key="" text="infrastructure" requisite="optional" type="node,closedway" member_expression="tourism OR amenity"/>
    11717                     <role key="" text="natural" requisite="optional" type="node,closedway" member_expression="natural=peak OR natural=volcano OR mountain_pass=yes OR natural=water OR tourism=viewpoint OR amenity=drinking_water OR natural=spring OR place=locality"/>
    11718                 </roles>
     11718                <reference ref="walking_routes_roles" />
    1171911719            </item> <!-- Walking Route -->
    1172011720            <item name="Riding Route" icon="presets/misc/route.svg" type="relation" preset_name_label="true">
    1172111721                <link href="https://wiki.openstreetmap.org/wiki/Tag:route=horse"

comment:6 Changed 8 months ago by Klumbumbus

OK, I couldn't reproduce because I used the reference only once. It seems it is displayed so often like the reference is used. (3 times reference used => 3 times the roles in the preset dialog for these 3 presets)

The plugin tagging presets tester is not happy about this code too.

comment:7 Changed 8 months ago by Don-vip

Resolution: fixed
Status: newclosed

In 13998/josm:

fix #16458 - add guidepost role to walking routes presets (route=hiking/foot)

comment:8 Changed 8 months ago by Klumbumbus

Could you please fix the tagging-presets-tester plugin too?

comment:9 Changed 8 months ago by Don-vip

In 13999/josm:

see #16458 - fix tagging presets XSD

comment:10 in reply to:  8 Changed 8 months ago by Don-vip

Replying to Klumbumbus:

Could you please fix the tagging-presets-tester plugin too?

What's wrong with it? I was able with r14001 to open it without problem. Didn't test prior r13999 though.

comment:11 Changed 8 months ago by Klumbumbus

There was an error message but it works fine for me now too. I'm not sure which version I tested. Much likely it was fixed with r13999.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.