Modify

Opened 9 months ago

Closed 9 months ago

#16427 closed defect (fixed)

If imagery layer name is too long, the offset warning cannot be dismissed

Reported by: ff5722 Owned by: team
Priority: minor Milestone:
Component: Core imagery Version:
Keywords: template_report offset Cc:

Description (last modified by Klumbumbus)

What steps will reproduce the problem?

If you open an image layer with a very long name (which is usually erronous too), the 'x' symbol to close the 'Aerial imagery might be misaligned' disappears. The dialog cannot be removed by any other way than restarting JOSM.

What is the expected result?

'x' should still appear

What happens instead?

'x' is not visible on screen

Another bug is that the sidebar width cannot be adjusted anymore.

Please provide any additional information below. Attach a screenshot if possible.


URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-05-31 00:51:20 +0200 (Thu, 31 May 2018)
Build-Date:2018-05-30 22:58:01
Revision:13878
Relative:URL: ^/trunk

Identification: JOSM/1.5 (13878 en) Windows 10 64-Bit
OS Build number: Windows 10 Home 1803 (17134)
Memory Usage: 1569 MB / 1820 MB (549 MB allocated, but free)
Java version: 1.8.0_171-b11, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1080
Maximum Screen Size: 1920x1080
Dataset consistency test: No problems found

Plugins:
+ FastDraw (34109)
+ Mapillary (v1.5.14+post13733)
+ apache-commons (34109)
+ apache-http (34109)
+ buildings_tools (34212)
+ ejml (34126)
+ geotools (34125)
+ importvec (34109)
+ jts (34038)
+ opendata (34196)
+ reverter (34109)
+ utilsplugin2 (34221)

Last errors/warnings:
- W: java.net.UnknownHostException: api.openstreetmap.org
- W: Already here java.net.UnknownHostException: api.openstreetmap.org
- E: java.net.UnknownHostException: api.openstreetmap.org
- W: org.openstreetmap.josm.io.OsmTransferException: Could not connect to the OSM server. Please check your internet connection.. Cause: java.net.UnknownHostException: api.openstreetmap.org
- W: java.net.UnknownHostException: api.openstreetmap.org
- W: Already here java.net.UnknownHostException: api.openstreetmap.org
- E: java.net.UnknownHostException: api.openstreetmap.org
- W: org.openstreetmap.josm.io.OsmTransferException: Could not connect to the OSM server. Please check your internet connection.. Cause: java.net.UnknownHostException: api.openstreetmap.org
- W: Unable to find supported projection for layer https://geoservice.code-de.org/Sentinel2/wms?SERVICE=WMS&VERSION=1.1.0&REQUEST=GetMap&FORMAT=image%2Fpng&TRANSPARENT=true&LAYERS=S2_MSI_L1C&time=2018-06-09T07%3A56%3A11.024Z%2F2018-06-09T07%3A56%3A11.024Z&STYLES=&SRS=%7Bproj%7D&WIDTH=%7Bwidth%7D&HEIGHT=%7Bheight%7D&BBOX=%7Bbbox%7D&SERVICE=WMS&REQUEST=GetCapabilities&:. Using EPSG:3857.
- W: Unable to find supported projection for layer https://geoservice.code-de.org/Sentinel2/wms?SERVICE=WMS&VERSION=1.1.0&REQUEST=GetMap&FORMAT=image%2Fpng&TRANSPARENT=true&LAYERS=S2_MSI_L1C&time=2018-06-09T07%3A56%3A11.024Z%2F2018-06-09T07%3A56%3A11.024Z&STYLES=&SRS=%7Bproj%7D&WIDTH=%7Bwidth%7D&HEIGHT=%7Bheight%7D&BBOX=%7Bbbox%7D&SERVICE=WMS&REQUEST=GetCapabilities&:. Using EPSG:3857.

Attachments (2)

Screenshot (6).png (355.2 KB) - added by ff5722 9 months ago.
16427_space.png (38.8 KB) - added by Don-vip 9 months ago.

Download all attachments as: .zip

Change History (7)

Changed 9 months ago by ff5722

Attachment: Screenshot (6).png added

comment:1 Changed 9 months ago by Don-vip

Component: CoreCore imagery
Keywords: offset added

comment:2 Changed 9 months ago by Klumbumbus

Description: modified (diff)

comment:3 Changed 9 months ago by Don-vip

This is because the name does not contain any space, it works fine with the description:


Last edited 9 months ago by Don-vip (previous) (diff)

Changed 9 months ago by Don-vip

Attachment: 16427_space.png added

comment:4 Changed 9 months ago by ff5722

Ah then it's probably not a problem that will occur often, barely worth fixing. In my case it was just that the layer didn't have a title auto-filled.

comment:5 Changed 9 months ago by Don-vip

Resolution: fixed
Status: newclosed

In 13978/josm:

fix #16427 - Inserts zero width space character (U+8203) after each slash/amperand to wrap long URLs in imagery offset panel

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.