Modify

Opened 5 months ago

Closed 5 months ago

#16425 closed defect (fixed)

allow source:maxspeed=PL:zone40

Reported by: mkoniecz Owned by: team
Priority: normal Milestone: 18.06
Component: Core validator Version:
Keywords: template_report maxspeed poland Cc:

Description

What steps will reproduce the problem?

  1. tag zone 40 maxspeed in Poland with maxspeed=40 and source:maxspeed=PL:zone40 what AFAIK is correct
  2. run validator

What is the expected result?

No complaints about source:maxspeed=PL:zone40

What happens instead?

Unknown source:maxspeed context: zone40 (1)

Please provide any additional information below. Attach a screenshot if possible.

https://www.openstreetmap.org/way/22690910#map=19/50.08515/19.97966

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-06-24 19:57:43 +0200 (Sun, 24 Jun 2018)
Build-Date:2018-06-24 18:08:53
Revision:13974
Relative:URL: ^/trunk

Identification: JOSM/1.5 (13974 en) Linux Ubuntu 16.04.4 LTS
Memory Usage: 812 MB / 869 MB (339 MB allocated, but free)
Java version: 1.8.0_171-b11, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: :0.0 1920x1080
Maximum Screen Size: 1920x1080
Dataset consistency test: No problems found

Plugins:
+ OpeningHoursEditor (34095)
+ buildings_tools (34212)
+ continuosDownload (1529090613)
+ imagery_offset_db (34337)
+ reverter (34271)
+ todo (30304)

Last errors/warnings:
- W: Invalid jar file ''<josm.userdata>/plugins/imagery_offset_db.jar.new'' (exists: false, canRead: false)
- W: No configuration settings found.  Using hardcoded default values for all pools.
- E: Skipping to the next rule, because of an error:
- E: org.openstreetmap.josm.gui.mappaint.mapcss.parsergen.ParseException: Encountered " <IDENT> "way "" at line 222, column 1.

Attachments (0)

Change History (3)

comment:1 Changed 5 months ago by mkoniecz

Component: CoreCore validator

comment:2 Changed 5 months ago by Don-vip

Keywords: maxspeed poland added
Milestone: 18.06

comment:3 Changed 5 months ago by Don-vip

Resolution: fixed
Status: newclosed

In 13976/josm:

fix #16425 - support "zone40" maxspeed context

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.