Modify

Opened 3 months ago

Closed 3 months ago

#16424 closed defect (fixed)

handle illegal railway crossings in validator

Reported by: mkoniecz Owned by: team
Priority: normal Milestone: 18.06
Component: Core validator Version:
Keywords: template_report railway crossing Cc:

Description (last modified by mkoniecz)

What steps will reproduce the problem?

  1. mark path with an illegal railway crossing
  2. run validator

What is the expected result?

Validator is not encouraging to add incorrect railway=crossing

What happens instead?

Validator is encouraging to add incorrect railway=crossing

Please provide any additional information below. Attach a screenshot if possible.

Example: https://www.openstreetmap.org/node/2921238446

Possible solutions:

  • change message from "missing tag - pedestrian railway crossing without railway=crossing" to "missing tag - pedestrian railway crossing without railway=crossing, mark illegal but anyway used crossings with crossing=no"
  • do not report it on access=no ways (without foot and biccyle tags)
  • do not report it on crossing=no nodes
URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-06-24 19:57:43 +0200 (Sun, 24 Jun 2018)
Build-Date:2018-06-24 18:08:53
Revision:13974
Relative:URL: ^/trunk

Identification: JOSM/1.5 (13974 en) Linux Ubuntu 16.04.4 LTS
Memory Usage: 672 MB / 869 MB (288 MB allocated, but free)
Java version: 1.8.0_171-b11, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: :0.0 1920x1080
Maximum Screen Size: 1920x1080
Dataset consistency test: No problems found

Plugins:
+ OpeningHoursEditor (34095)
+ buildings_tools (34212)
+ continuosDownload (1529090613)
+ imagery_offset_db (34337)
+ reverter (34271)
+ todo (30304)

Last errors/warnings:
- W: Invalid jar file ''<josm.userdata>/plugins/imagery_offset_db.jar.new'' (exists: false, canRead: false)
- W: No configuration settings found.  Using hardcoded default values for all pools.
- E: Skipping to the next rule, because of an error:
- E: org.openstreetmap.josm.gui.mappaint.mapcss.parsergen.ParseException: Encountered " <IDENT> "way "" at line 222, column 1.

Attachments (0)

Change History (3)

comment:1 Changed 3 months ago by mkoniecz

Description: modified (diff)

comment:2 Changed 3 months ago by Don-vip

Keywords: railway crossing added
Milestone: 18.06

comment:3 Changed 3 months ago by Don-vip

Resolution: fixed
Status: newclosed

In 13977/josm:

fix #16424 - ignore crossing=no from "pedestrian railway crossing without railway=crossing" check

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.