Modify

Opened 3 months ago

Closed 3 months ago

#16410 closed defect (fixed)

Josm crashe on startup

Reported by: kendzi Owned by: team
Priority: normal Milestone: 18.06
Component: Core Version:
Keywords: template_report linux Cc:

Description

What steps will reproduce the problem?

  1. Simply run josm

What is the expected result?

Josm should start, splash screen appear.

What happens instead?

I get error message

Please provide any additional information below. Attach a screenshot if possible.

I have 3 screens

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-05-31 00:51:20 +0200 (Thu, 31 May 2018)
Revision:13878
Build-Date:2018-05-30 22:58:01
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (13878 en) Linux Ubuntu 18.04 LTS
Memory Usage: 250 MB / 3986 MB (212 MB allocated, but free)
Java version: 9.0.4+11, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: :0.0 1366x768, :0.1 1920x1080, :0.2 1920x1080
Maximum Screen Size: 1920x1080

Plugins:
+ buildings_tools
+ jogl
+ <user.name>3d
+ <user.name>3d-resources
+ log4j

Tagging presets:
+ http://zibi.openstreetmap.org.pl/<user.name>/k/Simple3dPreset/s3db-preset.zip

Last errors/warnings:
- E: java.util.concurrent.ExecutionException: java.lang.IllegalArgumentException: Window must not be zero. Cause: java.lang.IllegalArgumentException: Window must not be zero
- E: Handled by bug report queue: java.lang.NullPointerException


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: main (1)
java.lang.NullPointerException
	at org.openstreetmap.josm.gui.MainApplication.mainJOSM(MainApplication.java:1025)
	at org.openstreetmap.josm.gui.MainApplication$2.processArguments(MainApplication.java:280)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:860)

Attachments (2)

MainApplication.java.patch (833 bytes) - added by kendzi 3 months ago.
fix for null
WindowGeometry.java.patch (1.5 KB) - added by kendzi 3 months ago.
Fix for throwing IllegalArgumentException when window size is checked

Download all attachments as: .zip

Change History (14)

comment:1 Changed 3 months ago by Don-vip

Resolution: fixed
Status: newclosed

In 13960/josm:

fix #16410 - NPE

comment:2 Changed 3 months ago by Don-vip

Milestone: 18.06

comment:3 Changed 3 months ago by kendzi

Resolution: fixed
Status: closedreopened

Sorry still not working. Now I gets:

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-06-21 01:27:13 +0200 (Thu, 21 Jun 2018)
Revision:13962
Build-Date:2018-06-21 01:32:00
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (13962 en) Linux Ubuntu 18.04 LTS
Memory Usage: 250 MB / 3986 MB (211 MB allocated, but free)
Java version: 9.0.4+11, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: :0.0 1366x768, :0.1 1920x1080, :0.2 1920x1080
Maximum Screen Size: 1920x1080

Plugins:
+ buildings_tools
+ jogl
+ <user.name>3d
+ <user.name>3d-resources
+ log4j

Tagging presets:
+ http://zibi.openstreetmap.org.pl/<user.name>/k/Simple3dPreset/s3db-preset.zip

Last errors/warnings:
- E: java.util.concurrent.ExecutionException: java.lang.IllegalArgumentException: Window must not be zero. Cause: java.lang.IllegalArgumentException: Window must not be zero
- E: Handled by bug report queue: java.lang.NullPointerException


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: main (1)
java.lang.NullPointerException
	at org.openstreetmap.josm.gui.MainApplication.lambda$mainJOSM$15(MainApplication.java:1032)
	at org.openstreetmap.josm.gui.SplashScreen$SplashProgressMonitor.beginTask(SplashScreen.java:239)
	at org.openstreetmap.josm.gui.MainApplication.mainJOSM(MainApplication.java:1034)
	at org.openstreetmap.josm.gui.MainApplication$2.processArguments(MainApplication.java:283)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:865)

comment:4 Changed 3 months ago by kendzi

the same with java 10.0.1

Changed 3 months ago by kendzi

Attachment: MainApplication.java.patch added

fix for null

comment:5 Changed 3 months ago by kendzi

patch fix that bug but now i get that error when starting main app :(

=== STACK TRACE ===
Thread: main (1)
java.lang.IllegalArgumentException: Window must not be zero
	at java.desktop/sun.awt.X11.XAtom.checkWindow(XAtom.java:774)
	at java.desktop/sun.awt.X11.XAtom.getAtomData(XAtom.java:465)
	at java.desktop/sun.awt.X11.XToolkit.getWorkArea(XToolkit.java:805)
	at java.desktop/sun.awt.X11.XToolkit.getInsets(XToolkit.java:881)
	at java.desktop/sun.awt.X11.XToolkit.getScreenInsets(XToolkit.java:869)
	at java.desktop/sun.java2d.SunGraphicsEnvironment.getUsableBounds(SunGraphicsEnvironment.java:274)
	at java.desktop/sun.awt.X11GraphicsEnvironment.getXineramaWindowBounds(X11GraphicsEnvironment.java:390)
	at java.desktop/sun.awt.X11GraphicsEnvironment.getMaximumWindowBounds(X11GraphicsEnvironment.java:314)
	at org.openstreetmap.josm.gui.util.WindowGeometry.applySafe(WindowGeometry.java:346)
	at org.openstreetmap.josm.gui.MainFrame.initialize(MainFrame.java:83)
	at org.openstreetmap.josm.gui.MainApplication.initializeMainWindow(MainApplication.java:477)
	at org.openstreetmap.josm.Main$InitializationTask.call(Main.java:260)
	at org.openstreetmap.josm.Main.runInitializationTasks(Main.java:186)
	at org.openstreetmap.josm.Main.initialize(Main.java:158)
	at org.openstreetmap.josm.gui.MainApplication.mainJOSM(MainApplication.java:1072)
	at org.openstreetmap.josm.gui.MainApplication$2.processArguments(MainApplication.java:283)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:865)

Changed 3 months ago by kendzi

Attachment: WindowGeometry.java.patch added

Fix for throwing IllegalArgumentException when window size is checked

comment:6 Changed 3 months ago by kendzi

With that to workaround josm is working on my setup, but it is reporting on console "IllegalArgumentException" each time new window is opened. It looks like some Java bug.

code:
System.out.println(GraphicsEnvironment.getLocalGraphicsEnvironment().getMaximumWindowBounds());

java 8 result:
java.awt.Rectangle[x=1366,y=0,width=1920,height=1080]

java 10.0.1 result:
Exception in thread "main" java.lang.IllegalArgumentException: Window must not be zero
	at java.desktop/sun.awt.X11.XAtom.checkWindow(XAtom.java:774)
	at java.desktop/sun.awt.X11.XAtom.getAtomData(XAtom.java:465)
	at java.desktop/sun.awt.X11.XToolkit.getWorkArea(XToolkit.java:805)
	at java.desktop/sun.awt.X11.XToolkit.getInsets(XToolkit.java:881)
	at java.desktop/sun.awt.X11.XToolkit.getScreenInsets(XToolkit.java:869)
	at java.desktop/sun.java2d.SunGraphicsEnvironment.getUsableBounds(SunGraphicsEnvironment.java:274)
	at java.desktop/sun.awt.X11GraphicsEnvironment.getXineramaWindowBounds(X11GraphicsEnvironment.java:390)
	at java.desktop/sun.awt.X11GraphicsEnvironment.getMaximumWindowBounds(X11GraphicsEnvironment.java:314)
	at main.main(main.java:6)

I report that to oracle, will see if they open issue.

Last edited 3 months ago by kendzi (previous) (diff)

comment:7 Changed 3 months ago by Don-vip

Thanks! Can you please share the Oracle incident number?

comment:8 Changed 3 months ago by Don-vip

Seems related to #11997

comment:9 Changed 3 months ago by Don-vip

Keywords: linux added

comment:10 Changed 3 months ago by kendzi

For now i get only internal review ID : 9055725 , look even I cannot open it. I will post you if they publish it.

comment:11 Changed 3 months ago by Don-vip

Yes, the bug is not visible until they decide to make it public. The link is https://bugs.openjdk.java.net/browse/JI-9055725. Once they convert it into a public bug report, the link will automatically redirect.

comment:12 Changed 3 months ago by Don-vip

Resolution: fixed
Status: reopenedclosed

In 13963/josm:

fix #16410 - workaround for "IllegalArgumentException: Window must not be zero" on Linux (patch by kendzi)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.