Modify

Opened 6 months ago

Closed 6 months ago

#16367 closed defect (fixed)

IAE: Keyframe fractions must be increasing

Reported by: naoliv Owned by: team
Priority: normal Milestone: 18.06
Component: Core Version:
Keywords: svg regression Cc: Klumbumbus

Description

While loading JOSM I am seeing this at the console:

2018-06-08 10:08:21.230 GRAVE: Unable to load svg:: com.kitfox.svg.SVGException: java.lang.IllegalArgumentException: Keyframe fractions must be increasing: 1.0. Cause: java.lang.IllegalArgumentException: Keyframe fractions must be increasing: 1.0

JOSM:

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-06-07 22:18:01 +0200 (Thu, 07 Jun 2018)
Revision:13899
Build-Date:2018-06-08 01:33:16
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (13899 pt_BR) Linux Debian GNU/Linux testing (buster)
Memory Usage: 370 MB / 7168 MB (140 MB allocated, but free)
Java version: 10.0.1+10-Debian-4, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1600x900, :0.1 1280x1024
Maximum Screen Size: 1600x1024
Java package: openjdk-10-jre:amd64-10.0.1+10-4
Java ATK Wrapper package: libatk-wrapper-java:all-0.33.3-21
VM arguments: [--add-modules=java.activation,java.se.ee, -Dawt.useSystemAAFontSettings=on]

Plugins:
+ ImportImagePlugin (34219)
+ OpeningHoursEditor (34095)
+ PicLayer (34170)
+ SimplifyArea (34109)
+ apache-commons (34109)
+ buildings_tools (34212)
+ download_along (34081)
+ editgpx (34109)
+ ejml (34126)
+ geojson (80)
+ geotools (34125)
+ jts (34038)
+ log4j (34038)
+ measurement (34109)
+ opendata (34196)
+ pbf (34109)
+ poly (34098)
+ reverter (34109)
+ scripting (30785)
+ tageditor (34109)
+ todo (30304)
+ turnlanes-tagging (263)
+ turnrestrictions (34129)
+ undelete (34109)
+ utilsplugin2 (34221)

Attachments (0)

Change History (9)

comment:1 Changed 6 months ago by Don-vip

Keywords: svg added

comment:2 Changed 6 months ago by Don-vip

if you run JOSM with --trace option, do you see what SVG file causes this error?

comment:3 Changed 6 months ago by naoliv

It seems to be images/dialogs/delete.svg

2018-06-08 10:40:52.614 FINEST: createImageFromSvg: jar:file:/home/naoliv/josm/josm-latest.jar!/images/new.svg java.awt.Dimension[width=-1,height=16]
2018-06-08 10:40:52.620 FINEST: createImageFromSvg: jar:file:/home/naoliv/josm/josm-latest.jar!/images/new.svg java.awt.Dimension[width=-1,height=24]
2018-06-08 10:40:52.732 FINEST: get ImageProvider [name=openrecent] from Thread[main,5,main]
2018-06-08 10:40:52.844 FINEST: createImageFromSvg: jar:file:/home/naoliv/josm/josm-latest.jar!/images/dialogs/delete.svg java.awt.Dimension[width=-1,height=16]
2018-06-08 10:40:52.851 SEVERE: Unable to load svg:: com.kitfox.svg.SVGException: java.lang.IllegalArgumentException: Keyframe fractions must be increasing: 1.0. Cause: java.lang.IllegalArgumentException: Keyframe fractions must be increasing: 1.0
2018-06-08 10:40:52.853 FINEST: createImageFromSvg: jar:file:/home/naoliv/josm/josm-latest.jar!/images/dialogs/delete.svg java.awt.Dimension[width=-1,height=24]
2018-06-08 10:40:52.860 SEVERE: Unable to load svg:: com.kitfox.svg.SVGException: java.lang.IllegalArgumentException: Keyframe fractions must be increasing: 1.0. Cause: java.lang.IllegalArgumentException: Keyframe fractions must be increasing: 1.0
2018-06-08 10:40:52.931 FINEST: createImageFromSvg: jar:file:/home/naoliv/josm/josm-latest.jar!/images/exit.svg java.awt.Dimension[width=-1,height=16]
2018-06-08 10:40:52.935 FINEST: createImageFromSvg: jar:file:/home/naoliv/josm/josm-latest.jar!/images/exit.svg java.awt.Dimension[width=-1,height=24]
2018-06-08 10:40:52.950 FINEST: createImageFromSvg: jar:file:/home/naoliv/josm/josm-latest.jar!/images/undo.svg java.awt.Dimension[width=-1,height=16]
2018-06-08 10:40:52.953 FINEST: createImageFromSvg: jar:file:/home/naoliv/josm/josm-latest.jar!/images/undo.svg java.awt.Dimension[width=-1,height=24]
2018-06-08 10:40:52.961 FINEST: createImageFromSvg: jar:file:/home/naoliv/josm/josm-latest.jar!/images/redo.svg java.awt.Dimension[width=-1,height=16]
2018-06-08 10:40:52.964 FINEST: createImageFromSvg: jar:file:/home/naoliv/josm/josm-latest.jar!/images/redo.svg java.awt.Dimension[width=-1,height=24]
2018-06-08 10:40:52.967 FINEST: createImageFromSvg: jar:file:/home/naoliv/josm/josm-latest.jar!/images/copy.svg java.awt.Dimension[width=-1,height=16]
2018-06-08 10:40:52.971 FINEST: createImageFromSvg: jar:file:/home/naoliv/josm/josm-latest.jar!/images/copy.svg java.awt.Dimension[width=-1,height=24]
2018-06-08 10:40:52.976 FINEST: createImageFromSvg: jar:file:/home/naoliv/josm/josm-latest.jar!/images/paste.svg java.awt.Dimension[width=-1,height=16]
2018-06-08 10:40:52.980 FINEST: createImageFromSvg: jar:file:/home/naoliv/josm/josm-latest.jar!/images/paste.svg java.awt.Dimension[width=-1,height=24]
2018-06-08 10:40:53.005 FINEST: createImageFromSvg: jar:file:/home/naoliv/josm/josm-latest.jar!/images/dialogs/delete.svg java.awt.Dimension[width=-1,height=16]
2018-06-08 10:40:53.007 SEVERE: Unable to load svg:: com.kitfox.svg.SVGException: java.lang.IllegalArgumentException: Keyframe fractions must be increasing: 1.0. Cause: java.lang.IllegalArgumentException: Keyframe fractions must be increasing: 1.0
2018-06-08 10:40:53.007 FINEST: createImageFromSvg: jar:file:/home/naoliv/josm/josm-latest.jar!/images/dialogs/delete.svg java.awt.Dimension[width=-1,height=24]
2018-06-08 10:40:53.008 SEVERE: Unable to load svg:: com.kitfox.svg.SVGException: java.lang.IllegalArgumentException: Keyframe fractions must be increasing: 1.0. Cause: java.lang.IllegalArgumentException: Keyframe fractions must be increasing: 1.0

comment:4 Changed 6 months ago by naoliv

Cc: Klumbumbus added

Regression from #16320?

comment:5 Changed 6 months ago by Don-vip

Keywords: regression added
Milestone: 18.06

comment:6 Changed 6 months ago by Don-vip

Confirmed:

com.kitfox.svg.SVGException: java.lang.IllegalArgumentException: Keyframe fractions must be increasing: 1.0
	at com.kitfox.svg.ShapeElement.renderShape(ShapeElement.java:169)
	at com.kitfox.svg.Path.render(Path.java:94)
	at com.kitfox.svg.Group.render(Group.java:205)
	at com.kitfox.svg.SVGRoot.renderToViewport(SVGRoot.java:329)
	at com.kitfox.svg.SVGDiagram.render(SVGDiagram.java:105)
	at org.openstreetmap.josm.tools.ImageProvider.createImageFromSvg(ImageProvider.java:1597)
	...
	at org.openstreetmap.josm.actions.DeleteLayerAction.<init>(DeleteLayerAction.java:26)
	...
Caused by: java.lang.IllegalArgumentException: Keyframe fractions must be increasing: 1.0
	at java.awt.MultipleGradientPaint.<init>(MultipleGradientPaint.java:184)
	at java.awt.LinearGradientPaint.<init>(LinearGradientPaint.java:286)
	at com.kitfox.svg.LinearGradient.getPaint(LinearGradient.java:128)
	at com.kitfox.svg.ShapeElement.renderShape(ShapeElement.java:167)
	... 22 more

comment:7 Changed 6 months ago by Don-vip

The error is caused by:

    <linearGradient
       id="linearGradient3218"
       y2="16.280224"
       gradientUnits="userSpaceOnUse"
       x2="-4.3679562"
       y1="18.571865"
       x1="36.648621">
      <stop
         id="stop3214"
         stop-color="#555753"
         offset="0" />
      <stop
         id="stop3233"
         stop-color="#d5d9d2"
         offset="1" />
      <stop
         id="stop3216"
         stop-color="#888a85"
         offset="1" />
    </linearGradient>

The stop offsets must be increasing, but we have: 0, 1, 1

comment:8 Changed 6 months ago by Klumbumbus

I'll fix that.

comment:9 Changed 6 months ago by Klumbumbus

Resolution: fixed
Status: newclosed

In 13900/josm:

fix #16367, see #16320 - fix svg code

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.