Modify

#16216 closed defect (duplicate)

some error

Reported by: klioda0@… Owned by: team
Priority: normal Milestone:
Component: Core Version: tested
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-03-26 22:16:39 +0200 (Mon, 26 Mar 2018)
Build-Date:2018-03-26 20:45:23
Revision:13576
Redirecting:to URL 'https://josm.openstreetmap.de/svn/trunk':
Relative:URL: ^/trunk

Identification: JOSM/1.5 (13576 en) Windows 10 64-Bit
OS Build number: Windows 10 Pro 1709 (16299)
Memory Usage: 799 MB / 1783 MB (347 MB allocated, but free)
Java version: 1.8.0_161-b12, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1080
Maximum Screen Size: 1920x1080
Dataset consistency test: No problems found

Plugins:
+ turnrestrictions (34129)

Last errors/warnings:
- E: Handled by bug report queue: java.awt.IllegalComponentStateException: component must be showing on the screen to determine its location
- W: Too many errors. Dropping ReportedException [thread=Thread[AWT-EventQueue-0,6,main], exception=java.awt.IllegalComponentStateException: component must be showing on the screen to determine its location, methodWarningFrom=BugReportExceptionHandler#handleException]
- E: Handled by bug report queue: java.awt.IllegalComponentStateException: component must be showing on the screen to determine its location
- W: Too many errors. Dropping ReportedException [thread=Thread[AWT-EventQueue-0,6,main], exception=java.awt.IllegalComponentStateException: component must be showing on the screen to determine its location, methodWarningFrom=BugReportExceptionHandler#handleException]
- E: Handled by bug report queue: java.awt.IllegalComponentStateException: component must be showing on the screen to determine its location
- W: Too many errors. Dropping ReportedException [thread=Thread[AWT-EventQueue-0,6,main], exception=java.awt.IllegalComponentStateException: component must be showing on the screen to determine its location, methodWarningFrom=BugReportExceptionHandler#handleException]
- E: Handled by bug report queue: java.awt.IllegalComponentStateException: component must be showing on the screen to determine its location
- W: Too many errors. Dropping ReportedException [thread=Thread[AWT-EventQueue-0,6,main], exception=java.awt.IllegalComponentStateException: component must be showing on the screen to determine its location, methodWarningFrom=BugReportExceptionHandler#handleException]
- E: Handled by bug report queue: java.awt.IllegalComponentStateException: component must be showing on the screen to determine its location
- W: Too many errors. Dropping ReportedException [thread=Thread[AWT-EventQueue-0,6,main], exception=java.awt.IllegalComponentStateException: component must be showing on the screen to determine its location, methodWarningFrom=BugReportExceptionHandler#handleException]


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (20) of main
java.awt.IllegalComponentStateException: component must be showing on the screen to determine its location
	at java.awt.Component.getLocationOnScreen_NoTreeLock(Unknown Source)
	at java.awt.Component.getLocationOnScreen(Unknown Source)
	at sun.awt.windows.WInputMethod$1.run(Unknown Source)
	at java.awt.event.InvocationEvent.dispatch(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (1)

comment:1 Changed 19 months ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #15801.
Please update your version of Java. This is fixed in version 8u171.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.