Modify

Opened 2 months ago

Closed 4 weeks ago

Last modified 11 days ago

#16215 closed enhancement (fixed)

Korean translation

Reported by: stoecker Owned by: LuxuryCoop
Priority: major Milestone: 18.05
Component: Core Version:
Keywords: korean i18n Cc:

Description

Hello,

thanks for adding the Korean translation for StartupPage.

I only want to inform you that this will not have any effect until Korean is added to JOSM. For this approx at least 1000 more core strings must be translated. I see that you already started that task. I'd be happy to see another translation going live again after a long time.

Attachments (8)

koreanjosm.png (53.2 KB) - added by Don-vip 4 weeks ago.
koreanjosm2.png (85.1 KB) - added by Don-vip 4 weeks ago.
JOSMStartup.png (164.2 KB) - added by LuxuryCoop 4 weeks ago.
wikiStartup.png (48.3 KB) - added by LuxuryCoop 4 weeks ago.
Screenshot_20180521_180515.png (273.0 KB) - added by stoecker 4 weeks ago.
Screenshot openSUSE Tumblewwed
JOSM translations.png (1.4 MB) - added by Don-vip 2 weeks ago.
mapchartSAVE.json (3.2 KB) - added by Don-vip 2 weeks ago.
top20.png (26.5 KB) - added by Don-vip 12 days ago.

Change History (49)

comment:1 Changed 2 months ago by Don-vip

Keywords: korean i18n added

comment:2 Changed 2 months ago by Don-vip

Maybe you can also help to provide more information for #16199. I don't understand what is the problem there.

comment:3 in reply to:  description Changed 8 weeks ago by LuxuryCoop

Replying to stoecker:

Hello,

thanks for adding the Korean translation for StartupPage.

I only want to inform you that this will not have any effect until Korean is added to JOSM. For this approx at least 1000 more core strings must be translated. I see that you already started that task. I'd be happy to see another translation going live again after a long time.

Thank you for informing me that.
By the way, I haven't understood what core strings are. I think that it is either translation in Launchpad or in this wiki.
So, I hope I will know core strings' accurate meaning.

comment:4 Changed 8 weeks ago by stoecker

The first strings in Launchpad. You can see the source files referenced in Launchpad for each text. The most important parts in core are program texts and the presets. Later come plugins and other strings e.g. server texts. They are much work as well, but don't count for the minimum requirements. As far as possible Launchpad is sorted by importance.
See also Translations page.

comment:5 in reply to:  4 ; Changed 8 weeks ago by LuxuryCoop

Replying to stoecker:

The first strings in Launchpad. You can see the source files referenced in Launchpad for each text. The most important parts in core are program texts and the presets. Later come plugins and other strings e.g. server texts. They are much work as well, but don't count for the minimum requirements. As far as possible Launchpad is sorted by importance.
See also Translations page.

I'm sorry to respond slowly.
I just saw that page, knowing that a minimal amount of translation to showing foreign language at JOSM are 2000 strings, but not 1000.
I tried asking why Korean has not been added despite translated 1000 and over Korean strings, there is no need to ask that question now.
Nevertheless, thank you for your kindness!

comment:6 in reply to:  5 ; Changed 8 weeks ago by anonymous

Replying to LuxuryCoop:

I just saw that page, knowing that a minimal amount of translation to showing foreign language at JOSM are 2000 strings, but not 1000.

I said 1000 more (than now) ;-)

comment:7 in reply to:  6 Changed 8 weeks ago by LuxuryCoop

Replying to 익명사용자:

at least 1000 more core strings

ah...sorry... I misinterpreted "more".

comment:8 in reply to:  5 ; Changed 8 weeks ago by Don-vip

Replying to LuxuryCoop:

I'm sorry to respond slowly.

1 day is not slow, don't worry :) And don't be even sorry for that, we all have a personal life :) Thanks a lot for helping to translate JOSM in a new language, this is very appreciated!

Maybe the translation effort can be mentioned (if not already done) on the wiki? osmwiki:WikiProject_Korea

comment:9 in reply to:  8 Changed 8 weeks ago by LuxuryCoop

Replying to Don-vip:

Thanks! Though some Korean contributors of OSM don't tend to refer the Wiki, I will add an introduction and several links of JOSM translation.

Last edited 8 weeks ago by LuxuryCoop (previous) (diff)

comment:10 Changed 7 weeks ago by Don-vip

~1750 core strings translated, we will soon be able to add Korean :)

comment:11 Changed 4 weeks ago by Don-vip

Milestone: 18.05
Type: taskenhancement

1920 core strings, only 80 required to add it.

comment:12 in reply to:  11 Changed 4 weeks ago by LuxuryCoop

Replying to Don-vip:
Strings of Korean translation just have attained 2610 strings. Will the translation be added on JOSM?

comment:13 Changed 4 weeks ago by Don-vip

I'm on it :)

comment:14 Changed 4 weeks ago by Don-vip

In 13790/josm:

see #16215 - Add Korean translation

comment:15 Changed 4 weeks ago by Don-vip

Last edited 4 weeks ago by Don-vip (previous) (diff)

comment:16 Changed 4 weeks ago by Don-vip

Priority: normalmajor

comment:17 Changed 4 weeks ago by Don-vip

Korean characters are not displayed on my western Windows 10. Probably need to change default fonts, like what is done for khmer (see r7894, r7896, r8282 + #10989)

comment:18 Changed 4 weeks ago by Don-vip

comment:19 Changed 4 weeks ago by Don-vip

In 13791/josm:

see #10989, #16215, fix #16199 - load "Malgun Gothic" font on Windows in order to display Korean characters on Windows 10 without Korean language pack installed

Changed 4 weeks ago by Don-vip

Attachment: koreanjosm.png added

comment:20 Changed 4 weeks ago by Don-vip

Resolution: fixed
Status: assignedclosed

It works :)


Changed 4 weeks ago by Don-vip

Attachment: koreanjosm2.png added

comment:21 Changed 4 weeks ago by stoecker

Well, my fonts package josm-fonts for openSUSE still works perfect. Even for Korean ;-)

Changed 4 weeks ago by LuxuryCoop

Attachment: JOSMStartup.png added

Changed 4 weeks ago by LuxuryCoop

Attachment: wikiStartup.png added

comment:22 in reply to:  21 Changed 4 weeks ago by LuxuryCoop

Replying to stoecker:
It seems to be broken, but I don't know why it has been broken.

▼JOSM
▼▼Wiki



Last edited 4 weeks ago by stoecker (previous) (diff)

comment:23 Changed 4 weeks ago by Don-vip

What's wrong? I fail to see any difference?

comment:24 in reply to:  23 Changed 4 weeks ago by LuxuryCoop

Replying to Don-vip:
There is many differences between this screenshot and above screenshot.


Last edited 4 weeks ago by stoecker (previous) (diff)

comment:25 Changed 4 weeks ago by Don-vip

OK. So my screenshot is not OK and yours is fine? Can you please explain what the differences are? Is it still Korean displayed on my screenshot?

comment:26 Changed 4 weeks ago by Don-vip

@Dirk: can you please post a screenshot as well?

comment:27 in reply to:  26 Changed 4 weeks ago by LuxuryCoop

Replying to Don-vip:
Given Characters aren't completely broken, I think that there's lineup problem.
Also, other strings (menus, dialog, etc.) never have been broken except Startup Page. Is there problem at JOSM wiki by any chance?

Changed 4 weeks ago by stoecker

Screenshot openSUSE Tumblewwed

comment:28 Changed 4 weeks ago by stoecker

openSUSE Tumbleweed:

Screenshot openSUSE Tumblewwed

@LuxuryCoop:

If something is wrong, you need to tell us exactly what's wrong. We don't know a single bit how Korean really has to look like.

Usually if it is wrong some font is missing and a replacement is used which sometimes does not create the correct result.

comment:29 Changed 4 weeks ago by Don-vip

I think it's just the Windows font used on systems where Korean Language Pack is not installed. On native Korean Windows, I guess this is OK? (no way to check myself)

comment:30 Changed 4 weeks ago by stoecker

Any chance with Noto fonts on Windows? Or even on Linux? For mapnik all the special fonts have been dropped and Noto is used for everything. For Java I still have to manage a special fonts package. Using Noto would probably result on better result when working in different areas. These are designed to have a common look.

comment:31 in reply to:  30 Changed 4 weeks ago by Don-vip

Replying to stoecker:

Any chance with Noto fonts on Windows? Or even on Linux?

See #12085

comment:32 in reply to:  28 Changed 4 weeks ago by LuxuryCoop

Replying to stoecker:
That screenshot is completely normal.

comment:33 in reply to:  29 Changed 4 weeks ago by LuxuryCoop

Replying to Don-vip:
+ Malgun Gothic font is being used Korean Windows as default font.

comment:34 Changed 4 weeks ago by LuxuryCoop

on Korean Windows

comment:35 Changed 4 weeks ago by Klumbumbus

LuxuryCoop, please mark the characters which are displayed wrong on this screenshot. attachment:JOSMStartup.png We can't find them.

comment:36 in reply to:  35 Changed 4 weeks ago by LuxuryCoop

Replying to Klumbumbus:
Because of strings broken widely, I can't mark them specifically. Instead, I will install English Windows equivalent to your Windows, then inform cause of the error if I find the cause.

Changed 2 weeks ago by Don-vip

Attachment: JOSM translations.png added

Changed 2 weeks ago by Don-vip

Attachment: mapchartSAVE.json added

comment:37 Changed 2 weeks ago by Don-vip

Now that Korean has been added, I tried to get an idea about our translations status, using mapchart.net and attached config file:


Changed 12 days ago by Don-vip

Attachment: top20.png added

comment:38 Changed 12 days ago by Don-vip

Another view, by number of native speakers:

comment:39 Changed 11 days ago by Don-vip

I've blogged about this here, here and here and it seems to pay off: three unusual languages have been modified today: Arabic, Southern Sotho and Persian. I hope we will see new languages soon!

Last edited 11 days ago by Don-vip (previous) (diff)

comment:40 Changed 11 days ago by stoecker

We once had support for Arabian...

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain LuxuryCoop.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.