Modify

Opened 3 years ago

Closed 3 years ago

#16164 closed defect (worksforme)

Error when trying to open shapeFile

Reported by: facevedo@… Owned by: facevedo@…
Priority: normal Milestone:
Component: Core Version: tested
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Open shapefile http://geoservicios.indec.gov.ar/geoserver/sig/ows?service=WFS&version=1.0.0&request=GetFeature&typeName=sig:vias&outputFormat=SHAPE-ZIP&CQL_FILTER=link+like+%2706%25%27 <- shapefile inside zip
  2. exepction say that opendata needs to be updated -> click Update plugin
  3. JSOM can't find updates for plugins

What is the expected result?

I've never opened a shapefile before, but I do not expect an expetion

What happens instead?

exception

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-03-26 22:16:39 +0200 (Mon, 26 Mar 2018)
Build-Date:2018-03-26 20:45:23
Revision:13576
Redirecting:to URL 'https://josm.openstreetmap.de/svn/trunk':
Relative:URL: ^/trunk

Identification: JOSM/1.5 (13576 en) Linux Fedora 26 (Twenty Six)
Memory Usage: 1166 MB / 3900 MB (1026 MB allocated, but free)
Java version: 1.8.0_161-b14, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1920x1080
Maximum Screen Size: 1920x1080
Java package: java-1.8.0-openjdk:x86_64-1.8.0.161

Plugins:
+ apache-commons (34109)
+ ejml (34126)
+ geotools
+ jts
+ opendata (34132)
+ utilsplugin2

Last errors/warnings:
- W: Invalid jar file ''<josm.pref>/plugins/geotools.jar.new'' (exists: false, canRead: false)
- E: org.openstreetmap.josm.plugins.PluginException: An error occurred in plugin jts. Cause: java.lang.ClassNotFoundException: org.openstreetmap.josm.plugins.jts.JTSPlugin
- W: Disable plugin - <html>Could not load plugin jts because the plugin<br>main class 'org.openstreetmap.josm.plugins.jts.JTSPlugin' was not found.<br>Delete from preferences?</html>
- E: org.openstreetmap.josm.plugins.PluginException: An error occurred in plugin geotools. Cause: java.lang.reflect.InvocationTargetException. Cause: java.lang.NoClassDefFoundError: com/vividsolutions/jts/geom/CoordinateSequence. Cause: java.lang.ClassNotFoundException: com.vividsolutions.jts.geom.CoordinateSequence
- W: Disable plugin - Could not load plugin geotools. Delete from preferences?
- E: org.openstreetmap.josm.plugins.PluginException: An error occurred in plugin utilsplugin2. Cause: java.lang.ClassNotFoundException: org.openstreetmap.josm.plugins.utilsplugin2.UtilsPlugin2
- W: Disable plugin - <html>Could not load plugin utilsplugin2 because the plugin<br>main class 'org.openstreetmap.josm.plugins.utilsplugin2.UtilsPlugin2' was not found.<br>Delete from preferences?</html>
- E: Failed to parse module list document from site 'http://svn.openstreetmap.org/applications/editors/josm/plugins/opendata/modules.txt%<?modules=>'. Skipping site. Exception was: org.openstreetmap.josm.plugins.opendata.core.modules.ModuleListParseException: java.io.IOException: Illegal entry in module list.
- E: Handled by bug report queue: java.lang.NoClassDefFoundError: com/vividsolutions/jts/geom/Geometry. Cause: java.lang.ClassNotFoundException: com.vividsolutions.jts.geom.Geometry
- W: Warning - <html>JOSM could not find information about the following plugins:<ul><li>utilsplugin2</li><li>apache-commons</li><li>geotools</li><li>opendata</li><li>jts</li><li>ejml</li></ul>The plugins are not going to be loaded.</html>


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: main-worker-0 (47) of main
java.lang.NoClassDefFoundError: com/vividsolutions/jts/geom/Geometry
	at org.openstreetmap.josm.plugins.opendata.core.io.geographic.ShpImporter.parseDataSet(ShpImporter.java:29)
	at org.openstreetmap.josm.gui.io.importexport.OsmImporter.loadLayer(OsmImporter.java:121)
	at org.openstreetmap.josm.gui.io.importexport.OsmImporter.importData(OsmImporter.java:98)
	at org.openstreetmap.josm.plugins.opendata.core.io.AbstractImporter.importData(AbstractImporter.java:55)
	at org.openstreetmap.josm.gui.io.importexport.FileImporter.importDataHandleExceptions(FileImporter.java:95)
	at org.openstreetmap.josm.actions.OpenFileAction$OpenFileTask.importData(OpenFileAction.java:361)
	at org.openstreetmap.josm.actions.OpenFileAction$OpenFileTask.realRun(OpenFileAction.java:314)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:95)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:143)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
	at java.lang.Thread.run(Thread.java:748)
Caused by: java.lang.ClassNotFoundException: com.vividsolutions.jts.geom.Geometry
	at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
	at org.openstreetmap.josm.plugins.PluginClassLoader.loadClass(PluginClassLoader.java:73)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
	... 14 more

Attachments (2)

screenshot-05-04-2018_14-37.png (8.4 KB) - added by anonymous 3 years ago.
screenshot-05-04-2018_14-36.png (11.8 KB) - added by anonymous 3 years ago.

Download all attachments as: .zip

Change History (4)

Changed 3 years ago by anonymous

Changed 3 years ago by anonymous

comment:1 Changed 3 years ago by Don-vip

Owner: changed from team to facevedo@…
Status: newneedinfo

Your plugins seem to be corrupted, please try to delete the <josm.pref>/plugins/*.jar.new and update plugins again.

comment:2 Changed 3 years ago by Don-vip

Resolution: worksforme
Status: needinfoclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain facevedo@….
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.