Modify

Opened 15 months ago

Closed 15 months ago

Last modified 14 months ago

#16097 closed defect (fixed)

NPE in History window

Reported by: osmTOGA Owned by: team
Priority: normal Milestone: 18.03
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Select a modified (not new) object
  2. Go into the History window (Ctrl+H)
  3. Click on drop down arrow (next to the changeset button) of the modified version

What is the expected result?

Don't really know. The button probably shouldn't be clickable in the first place.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-03-14 20:20:13 +0100 (Wed, 14 Mar 2018)
Build-Date:2018-03-15 02:36:05
Revision:13531
Redirecting:to URL 'https://josm.openstreetmap.de/svn/trunk':
Relative:URL: ^/trunk

Identification: JOSM/1.5 (13531 de) Windows 10 64-Bit
OS Build number: Windows 10 Home 1709 (16299)
Memory Usage: 841 MB / 2222 MB (315 MB allocated, but free)
Java version: 1.8.0_161-b12, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1080
Maximum Screen Size: 1920x1080
Dataset consistency test: No problems found

Plugins:
+ Mapillary (v1.5.10)
+ PicLayer (34021)
+ RoadSigns (33798)
+ apache-commons (33668)
+ apache-http (32699)
+ buildings_tools (34040)
+ continuosDownload (68)
+ ejml (32680)
+ geochat (33982)
+ geotools (33958)
+ imagery_offset_db (33774)
+ jts (32699)
+ measurement (33760)
+ opendata (34072)
+ reverter (34036)
+ todo (30303)
+ turnrestrictions (33780)
+ undelete (33980)
+ utilsplugin2 (33991)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/LaneAttributes&preset&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Communication_Towers&zip=1

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/AddressValidator&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Sidewalks&style&zip=1
- https://dl.dropbox.com/u/8010189/Forum%20attachments/Hide_nodes.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/LessObtrusiveNodes&style&zip=1
- https://github.com/hotosm/HDM-JOSM-style/archive/master.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1
+ %UserProfile%\Downloads\Diverses\OSM\JOSM-Paintstyles\Power_lines.mapcss
+ https://josm.openstreetmap.de/josmfile?page=Styles/TigerReviewedNo&zip=1

Last errors/warnings:
- W: java.io.IOException: Die angeforderte URL https://dl.dropbox.com/u/8010189/Forum%20attachments/Hide_nodes.mapcss wurde nicht gefunden
- W: Kartenstile konnten nicht von 'https://dl.dropbox.com/u/8010189/Forum%20attachments/Hide_nodes.mapcss' geladen werden. Fehler war: java.io.IOException: Die angeforderte URL https://dl.dropbox.com/u/8010189/Forum%20attachments/Hide_nodes.mapcss wurde nicht gefunden
- E: java.io.IOException: Die angeforderte URL https://dl.dropbox.com/u/8010189/Forum%20attachments/Hide_nodes.mapcss wurde nicht gefunden
- W: Initializing map style https://dl.dropbox.com/u/8010189/Forum%20attachments/Hide_nodes.mapcss completed in 344 ms (1 errors, 0 warnings)
- W: No configuration settings found.  Using hardcoded default values for all pools.
- E: Handled by bug report queue: java.lang.NullPointerException


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (20) of main
java.lang.NullPointerException
	at org.openstreetmap.josm.gui.history.VersionInfoPanel.lambda$build$0(VersionInfoPanel.java:119)
	at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
	at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (4)

comment:1 Changed 15 months ago by Don-vip

Milestone: 18.03

comment:2 Changed 15 months ago by Don-vip

Resolution: fixed
Status: newclosed

In 13535/josm:

fix #16097 - NPE + disable arrow button in history dialog with changeset button

comment:3 Changed 14 months ago by Klumbumbus

Ticket #16126 has been marked as a duplicate of this ticket.

comment:4 Changed 14 months ago by Don-vip

Ticket #16130 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.