Modify

Opened 3 years ago

Last modified 3 months ago

#16076 reopened defect

Second dialog window underneath the first window on macOS

Reported by: nkamapper Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report macos javabug Cc:

Description

What steps will reproduce the problem?

Whenever a second popup/dialogue window appears, it is displayed underneath the first dialogue window.
Examples:
1) First open Imagery Preferences window, then hit the TMS, WMS etc buttons to display the second dialogue window.
2) First open Download from Overpass API, then hit the Query Wiard button.

When I click on the top window (i.e. the first window) within the boundaries of the second window, the second window is displayed properly.

I run JOSM on MacOS. Same behavior on 4 Macs. This problem appeared approx. a year ago.

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-03-04 16:20:37 +0100 (Sun, 04 Mar 2018)
Build-Date:2018-03-04 15:24:13
Revision:13500
Redirecting:to URL 'https://josm.openstreetmap.de/svn/trunk':
Relative:URL: ^/trunk

Identification: JOSM/1.5 (13500 nb) Mac OS X 10.13.3
OS Build number: Mac OS X 10.13.3 (17D47)
Memory Usage: 654 MB / 1820 MB (178 MB allocated, but free)
Java version: 1.8.0_161-b12, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: Display 69732864 1440x900
Maximum Screen Size: 1440x900
VM arguments: [-Djava.security.policy=file:<java.home>/lib/security/javaws.policy, -DtrustProxy=true, -Djnlpx.home=<java.home>/bin, -Djava.security.manager, -Djnlpx.origFilenameArg=${HOME}/Library/Application Support/Oracle/Java/Deployment/cache/6.0/56/1ee8cfb8-40e36ffa, -Djnlpx.remove=false, -Dsun.awt.warmup=true, -Djava.util.Arrays.useLegacyMergeSort=true, -Dmacosx.jnlpx.dock.name=JOSM, -Dmacosx.jnlpx.dock.icon=${HOME}/Library/Application Support/Oracle/Java/Deployment/cache/6.0/16/47ee53d0-3ef1ec79.icns, -Djnlp.application.href=https://josm.openstreetmap.de/download/josm.jnlp , -Djnlpx.jvm="<java.home>/bin/java"]

Plugins:
+ PicLayer (34021)
+ SeaChart (33995)
+ apache-commons (33668)
+ conflation (0.5.6)
+ ejml (32680)
+ geotools (33958)
+ imagery-xml-bounds (34077)
+ jts (32699)
+ opendata (34072)
+ reverter (34036)
+ todo (30303)
+ utilsplugin2 (33991)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/LaneAttributes&zip=1
+ https://raw.githubusercontent.com/OpenNauticalChart/josm/master/INT-1-preset.xml

Map paint styles:
+ https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://raw.githubusercontent.com/OpenSeaMap/josm/master/INT1_Seamark.mapcss
- http://osm.wzh.be/josm/entur_1.0.mapcss

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.
- W: Warning: Failed to scan file 'site-svn.openstreetmap.org-_applications_editors_josm_plugins_opendata_modules.txt' for module information. Skipping.

Attachments (0)

Change History (14)

comment:1 in reply to:  description Changed 3 years ago by Don-vip

Replying to nkamapper:

This problem appeared approx. a year ago.

Just a general note: it's easier to fix problems when they are reported as soon as they're detected :)

comment:2 Changed 3 years ago by nkamapper

Just a general note: it's easier to fix problems when they are reported as soon as they're detected :)

Naive assumption: If I wait long enough, the problem will go away ... :)

comment:3 Changed 3 years ago by nkamapper

I still have this problem. Cannot see popup windows including error messages because they appear behind the first window.

comment:4 Changed 3 years ago by Don-vip

Keywords: macos added
Summary: Second dialogue window underneath the first windowSecond dialog window underneath the first window on macOS

Never seen that on Windows and don't have any similar report on Linux, so probably macOS specific.

comment:5 Changed 3 years ago by Don-vip

macOS bug reports never go away by themselves for a simple reason: none of us own a mac. If you know Java developers with a mac, tell them to contribute to JOSM :)

comment:6 Changed 3 years ago by nkamapper

I updated to Java 10 now and the problem disappeared :)

comment:7 Changed 3 years ago by nkamapper

Resolution: fixed
Status: newclosed

comment:8 Changed 3 years ago by Don-vip

Keywords: javabug added
Resolution: fixedothersoftware

comment:9 Changed 3 years ago by Don-vip

Great!

comment:10 Changed 3 years ago by nkamapper

Resolution: othersoftware
Status: closedreopened

After one week, this problem is now back on one of the Macs ...
Not sure how that happened,

comment:11 Changed 5 months ago by Stereo

I think this might be a duplicate of #17849

Can you try the most recent pre-release at ​https://github.com/thomersch/josm/releases and see if you can still reproduce this?

comment:12 Changed 5 months ago by nkamapper

I tried v17201 but same problem. This has been standard JOSM behavior on all my Macs for the past 3+ years ...
Java 8/261. MacOS 10.15.7.

After v17084 I have had two occasions where a pop-up window is just stuck/will not close (last with the split way function). JOSM continues to have normal operation underneath. Unfortunately I have been unable to reproduce the problem.

comment:13 Changed 4 months ago by richlv

Reporter of the other ticket here (I've listed a few specific problem scenarios there).
I sometimes observe a bit different problem, where JOSM loses keyboard input capabilities.
Text input fields cannot be selected, "esc" does not work to close dialogs. Dialogs can be operated and closed with mouse.
In some cases, I tracked this down to some popup dialog being obscured by another dialog, in other cases I've been unable to find out the case.
This seems to mostly happen when system is under high load.

I might have reported this as a separate ticket, but cannot find one right now.

Mentioning it here, as the underlying cause might in the end turn out to be the same.

comment:14 Changed 3 months ago by anonymous

This issue is still exists for me.

JOSM v17084, macOS Catalina 10.15.7, Java(TM) SE Runtime Environment (build 1.8.0_151-b12)
Java HotSpot(TM) 64-Bit Server VM (build 25.151-b12, mixed mode)

This happens when calling any modal dialogue when the current input language is not English (in my case, when my input language is Ukrainian). It also creates two layers of data, when you use ⌘+N.

All this happens when you use hotkeys, pressing icons and performing actions through menu items works as expected.

see https://josm.openstreetmap.de/ticket/11111#comment:4

Last edited 3 months ago by andygol (previous) (diff)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as reopened The owner will remain team.
as The resolution will be set.
to The owner will be changed from team to the specified user.
The owner will change to nkamapper
as duplicate The resolution will be set to duplicate.The specified ticket will be cross-referenced with this ticket

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.