Modify

Opened 19 months ago

Closed 19 months ago

Last modified 19 months ago

#15683 closed enhancement (fixed)

[PATCH] Fix registration of JAI operations

Reported by: george-hopkins Owned by: Don-vip
Priority: normal Milestone:
Component: Plugin geotools Version:
Keywords: Cc:

Description

As the JAI JARs are bundled with the plugin, the regular initialization procedure does not work for JAI. We therefore register the operations by hand. However, the manually registered operations are lost as soon as JAI-Ext gets initialized because JAI-Ext replaces the operation registry once it is initialized. With the attached patched, JAI-Ext is initialized before we load the remaining operations.

Timeline how the bug gets triggered in ImageImportPlugin:

  • JAI gets initialized
  • User loads first image successfully (with ImageRead operation)
  • JOSM displays layer which triggers the initialization of JAI-Ext
  • JAI-Ext replaces the operation registry
  • User loads second image which fails as ImageRead operation is no longer available

Fixes: #12097, #13056, #13083, #14046, #14047

Attachments (1)

jaiext.patch (1.4 KB) - added by george-hopkins 19 months ago.

Download all attachments as: .zip

Change History (5)

Changed 19 months ago by george-hopkins

Attachment: jaiext.patch added

comment:1 Changed 19 months ago by Don-vip

Resolution: fixed
Status: newclosed

Fixed in [o33958:33959]. Thanks for the patch! :)

comment:2 Changed 19 months ago by Don-vip

Ticket #14047 has been marked as a duplicate of this ticket.

comment:3 Changed 19 months ago by Don-vip

Ticket #14046 has been marked as a duplicate of this ticket.

comment:4 Changed 19 months ago by Don-vip

Ticket #13083 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.