Modify

Opened 12 months ago

Closed 11 months ago

Last modified 11 months ago

#15682 closed defect (fixed)

Upgrade to JSR 374 (JSON Processing 1.1) to avoid crash of mapillary plugin

Reported by: anonymous Owned by: team
Priority: normal Milestone: 17.12
Component: Core Version:
Keywords: json mapillary jsr javabug Cc:

Description

What steps will reproduce the problem?

1.none, it just appears out of a sudden

What is the expected result?

What happens instead?

First it appeared an error about Mapillary, I wanted to update but then it gave me the error report, after that it appeared the Warning about all the other plugins
it disables all of my plugins

Please provide any additional information below. Attach a screenshot if possible.

Lately it crashes a lot and last time it crashed so bad that it had removed all my presets, all my mapcss, plugins, shortcuts...everything

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-11-26 14:31:59 +0100 (Sun, 26 Nov 2017)
Build-Date:2017-11-26 13:34:54
Revision:13170
Relative:URL: ^/trunk

Identification: JOSM/1.5 (13170 en) Windows 7 64-Bit
OS Build number: Windows 7 Professional (7601)
Memory Usage: 1847 MB / 7282 MB (1111 MB allocated, but free)
Java version: 1.8.0_141-b15, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1080, \Display1 1920x1080, \Display2 2560x1440
Maximum Screen Size: 2560x1440
Dataset consistency test: No problems found

Plugins:
+ ImportImagePlugin (33563)
+ ImproveOsm (126)
+ Mapillary (v1.5.9)
+ OpenStreetCam (114)
+ RoadSigns (33798)
+ apache-commons (33668)
+ apache-http (32699)
+ buildings_tools (33735)
+ download_along (33710)
+ ejml (32680)
+ geojson (73)
+ geotools (33930)
+ graphview (33938)
+ jna (32699)
+ jts (32699)
+ log4j (32699)
+ measurement (33760)
+ opendata (33791)
+ pbf (33568)
+ poly (33570)
+ reltoolbox (33708)
+ reverter (33865)
+ scripting (30775)
+ tageditor (33806)
+ todo (30303)
+ turnlanes (33858)
+ turnlanes-tagging (260)
+ turnrestrictions (33780)
+ utilsplugin2 (33742)
+ waydownloader (33910)

Tagging presets:
+ %UserProfile%\Desktop\Tools\mapcss\signpost.xml
+ %UserProfile%\Desktop\Tools\mapcss\statuspreset4node.xml

Map paint styles:
+ %UserProfile%\Desktop\Tools\mapcss\status.mapcss
- %UserProfile%\Desktop\Tools\mapcss\turn_lanes.mapcss
- %UserProfile%\Desktop\Tools\mapcss\v4_Lane and road attributes.mapcss
- %UserProfile%\Desktop\Tools\mapcss\number of lanes.mapcss

Last errors/warnings:
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.net.UnknownHostException: api.openstreetmap.org
- E: java.net.UnknownHostException: api.openstreetmap.org
- W: org.openstreetmap.josm.io.OsmTransferException: Could not connect to the OSM server. Please check your internet connection.. Cause: java.net.UnknownHostException: api.openstreetmap.org
- W: Could not read from URL https://a.mapillary.com/v3/sequences?client_id=T1Fzd20xZjdtR0s1VDk5OFNIOXpYdzoxNDYyOGRkYzUyYTFiMzgz&bbox=-121.9373632%2C37.6958168%2C-121.922493%2C37.7029645!: java.io.IOException: javax.json.stream.JsonParsingException: Unexpected char -1 at (line no=1, column no=916352, offset=916351). Cause: javax.json.stream.JsonParsingException: Unexpected char -1 at (line no=1, column no=916352, offset=916351)
- W: Could not read from URL https://a.mapillary.com/v3/sequences?client_id=T1Fzd20xZjdtR0s1VDk5OFNIOXpYdzoxNDYyOGRkYzUyYTFiMzgz&bbox=-121.8994474%2C37.7053795%2C-121.8920124%2C37.708953!: java.io.IOException: javax.json.stream.JsonParsingException: Unexpected char -1 at (line no=1, column no=1326003, offset=1326002). Cause: javax.json.stream.JsonParsingException: Unexpected char -1 at (line no=1, column no=1326003, offset=1326002)
- E: Handled by bug report queue: java.lang.NumberFormatException
- W: Warning - <html>JOSM could not find information about the following plugins:<ul><li>apache-commons</li><li>reltoolbox</li><li>geotools</li><li>tageditor</li><li>opendata</li><li>RoadSigns</li><li>measurement</li><li>OpenStreetCam</li><li>scripting</li><li>turnlanes-tagging</li><li>utilsplugin2</li><li>turnrestrictions</li><li>jna</li><li>log4j</li><li>ImproveOsm</li><li>jts</li><li>Mapillary</li><li>graphview</li><li>ejml</li><li>turnlanes</li><li>reverter</li><li>geojson</li><li>todo</li><li>pbf</li><li>ImportImagePlugin</li><li>poly</li><li>buildings_tools</li><li>download_along</li><li>waydownloader</li><li>apache-http</li></ul>The plugins are not going to be loaded.</html>
- E: Handled by bug report queue: java.lang.NumberFormatException


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: pool-7-thread-3 (2928)
java.lang.NumberFormatException
	at java.math.BigDecimal.<init>(Unknown Source)
	at java.math.BigDecimal.<init>(Unknown Source)
	at org.glassfish.json.JsonTokenizer.getBigDecimal(JsonTokenizer.java:493)
	at org.glassfish.json.JsonParserImpl.getBigDecimal(JsonParserImpl.java:132)
	at org.glassfish.json.JsonReaderImpl.readArray(JsonReaderImpl.java:153)
	at org.glassfish.json.JsonReaderImpl.readArray(JsonReaderImpl.java:139)
	at org.glassfish.json.JsonReaderImpl.readObject(JsonReaderImpl.java:180)
	at org.glassfish.json.JsonReaderImpl.readObject(JsonReaderImpl.java:184)
	at org.glassfish.json.JsonReaderImpl.readArray(JsonReaderImpl.java:143)
	at org.glassfish.json.JsonReaderImpl.readObject(JsonReaderImpl.java:180)
	at org.glassfish.json.JsonReaderImpl.readObject(JsonReaderImpl.java:103)
	at org.openstreetmap.josm.plugins.mapillary.io.download.SequenceDownloadRunnable.run(SequenceDownloadRunnable.java:41)
	at org.openstreetmap.josm.plugins.mapillary.io.download.BoundsDownloadRunnable.run(BoundsDownloadRunnable.java:36)
	at org.openstreetmap.josm.plugins.mapillary.io.download.MapillarySquareDownloadRunnable.run(MapillarySquareDownloadRunnable.java:32)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)

Attachments (2)

Mapillary crash.JPG (44.4 KB) - added by anonymous 12 months ago.
Warning plugins.JPG (50.1 KB) - added by anonymous 12 months ago.

Download all attachments as: .zip

Change History (10)

Changed 12 months ago by anonymous

Attachment: Mapillary crash.JPG added

Changed 12 months ago by anonymous

Attachment: Warning plugins.JPG added

comment:1 Changed 12 months ago by Don-vip

Component: PluginPlugin mapillary
Owner: changed from team to floscher

comment:3 Changed 12 months ago by Don-vip

Ticket #15684 has been marked as a duplicate of this ticket.

comment:4 Changed 12 months ago by Don-vip

Ticket #15686 has been marked as a duplicate of this ticket.

comment:5 Changed 12 months ago by Don-vip

In 13231/josm:

see #15682 - upgrade to JSR 374 (JSON Processing) API 1.1.2

comment:6 Changed 12 months ago by Don-vip

In 13232/josm:

see #15682 - update unit test

comment:7 Changed 11 months ago by Don-vip

Component: Plugin mapillaryCore
Keywords: json mapillary jsr javabug added; plugins crash removed
Milestone: 17.12
Owner: changed from floscher to team
Priority: majornormal
Resolution: fixed
Status: newclosed
Summary: JOSM doesn't find information about plugins....the plugins are not going to be loadedUpgrade to JSR 374 (JSON Processing 1.1) to avoid crash of mapillary plugin

comment:8 Changed 11 months ago by Don-vip

In 13318/josm:

see #15682 - fix messages.properties

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.