Modify

Opened 17 months ago

Closed 17 months ago

Last modified 17 months ago

#15465 closed defect (duplicate)

AIOOBE at DrawableSegment.paint

Reported by: Frans S Owned by: team
Priority: normal Milestone:
Component: Plugin shapetools Version:
Keywords: template_report Cc:

Description (last modified by Don-vip)

What steps will reproduce the problem?

  1. Resized building and tried to delete nodes which left over outside the new figure

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-10-03 21:43:00 +0200 (Tue, 03 Oct 2017)
Build-Date:2017-10-03 19:50:21
Revision:12921
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12921 en) Windows 10 64-Bit
OS Build number: Windows 10 Enterprise 1703 (15063)
Memory Usage: 309 MB / 989 MB (168 MB allocated, but free)
Java version: 1.8.0_151-b12, Oracle Corporation, Java HotSpot(TM) Client VM
Screen: \Display0 1680x1050, \Display1 1680x1050
Maximum Screen Size: 1680x1050
Dataset consistency test: No problems found

Plugins:
+ BuildingGeneralization (16)
+ FastDraw (33583)
+ ShapeTools (1220)
+ auto_tools (1494971731)
+ buildings_tools (33004)
+ indoor_sweepline (33007)
+ markseen (6)
+ measurement (33088)
+ photoadjust (33303)
+ terracer (33608)
+ tofix (1505422613)
+ touchscreenhelper (32699)
+ utilsplugin2 (33704)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/HotNepal&zip=1

Map paint styles:
- https://github.com/hotosm/HDM-JOSM-style/archive/master.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/Fixme&zip=1
+ https://github.com/MarkCupitt/HOT-Osm-Validation/blob/master/HOT-Validate.mapcss

Last errors/warnings:
- W: Unable to detect current tested version of JOSM:: java.lang.NumberFormatException: For input string: "<html>12921
- W: Unable to detect current tested version of JOSM:: java.lang.NumberFormatException: For input string: "<html>12921
- E: Handled by bug report queue: java.lang.ArrayIndexOutOfBoundsException: 5
- E: Handled by bug report queue: java.lang.ArrayIndexOutOfBoundsException: 5
- W: Unable to detect current tested version of JOSM:: java.lang.NumberFormatException: For input string: "<html>12921
- W: Unable to detect current tested version of JOSM:: java.lang.NumberFormatException: For input string: "<html>12921
- E: Handled by bug report queue: java.lang.ArrayIndexOutOfBoundsException: 5
- E: Handled by bug report queue: java.lang.ArrayIndexOutOfBoundsException: 5
- W: Unable to detect current tested version of JOSM:: java.lang.NumberFormatException: For input string: "<html>12921
- W: Unable to detect current tested version of JOSM:: java.lang.NumberFormatException: For input string: "<html>12921


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (17) of main
java.lang.ArrayIndexOutOfBoundsException: 5
	at org.openstreetmap.josm.data.osm.Way.getNode(Way.java:129)
	at org.openstreetmap.josm.data.osm.WaySegment.getSecondNode(WaySegment.java:46)
	at org.openstreetmap.josm.plugins.shapetools.DrawableSegment.paint(DrawableSegment.java:55)
	at org.openstreetmap.josm.gui.MapView.drawTemporaryLayers(MapView.java:668)
	at org.openstreetmap.josm.gui.MapView.drawMapContent(MapView.java:605)
	at org.openstreetmap.josm.gui.MapView.paint(MapView.java:507)
	at javax.swing.JComponent.paintChildren(Unknown Source)
	at javax.swing.JComponent.paint(Unknown Source)
	at javax.swing.JComponent.paintToOffscreen(Unknown Source)
	at javax.swing.RepaintManager$PaintManager.paintDoubleBuffered(Unknown Source)
	at javax.swing.RepaintManager$PaintManager.paint(Unknown Source)
	at javax.swing.RepaintManager.paint(Unknown Source)
	at javax.swing.JComponent._paintImmediately(Unknown Source)
	at javax.swing.JComponent.paintImmediately(Unknown Source)
	at javax.swing.RepaintManager$4.run(Unknown Source)
	at javax.swing.RepaintManager$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at javax.swing.RepaintManager.paintDirtyRegions(Unknown Source)
	at javax.swing.RepaintManager.paintDirtyRegions(Unknown Source)
	at javax.swing.RepaintManager.prePaintDirtyRegions(Unknown Source)
	at javax.swing.RepaintManager.access$1200(Unknown Source)
	at javax.swing.RepaintManager$ProcessingRunnable.run(Unknown Source)
	at java.awt.event.InvocationEvent.dispatch(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.WaitDispatchSupport$2.run(Unknown Source)
	at java.awt.WaitDispatchSupport$4.run(Unknown Source)
	at java.awt.WaitDispatchSupport$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.WaitDispatchSupport.enter(Unknown Source)
	at java.awt.Dialog.show(Unknown Source)
	at java.awt.Component.show(Unknown Source)
	at java.awt.Component.setVisible(Unknown Source)
	at java.awt.Window.setVisible(Unknown Source)
	at java.awt.Dialog.setVisible(Unknown Source)
	at org.openstreetmap.josm.gui.bugreport.BugReportDialog.lambda$showFor$3(BugReportDialog.java:295)
	at java.util.concurrent.FutureTask.run(Unknown Source)
	at java.awt.event.InvocationEvent.dispatch(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (4)

comment:1 Changed 17 months ago by Don-vip

Component: CorePlugin shapetools
Description: modified (diff)
Summary: Resized building and tried to delete nodes which left over outside the new figureAIOOBE at DrawableSegment.paint

comment:2 Changed 17 months ago by Don-vip

In 13030/josm:

see #15465 - validate WaySegment constructor arguments

comment:3 Changed 17 months ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #11802.
Will be fixed through https://github.com/JOSM/ShapeTools/issues/2

comment:4 Changed 17 months ago by Don-vip

I can't reproduce. Can you please provide a data set and step-by-step scenario? Either here or at https://github.com/JOSM/ShapeTools/issues/2

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.