Modify

Opened 14 years ago

Closed 13 years ago

#1544 closed defect (fixed)

AgPifoJ: PluginException while going through geo images (de: bei Durchblättern von Geofotos Fehlermeldung)

Reported by: anonymous Owned by: Christian Gallioz <christian.gallioz@…>
Priority: major Milestone:
Component: Plugin Version:
Keywords: PluginException; AgPifoJ Cc:

Description

Path: trunk
URL: http://josm.openstreetmap.de/svn/trunk
Repository Root: http://josm.openstreetmap.de/svn
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Revision: 961
Node Kind: directory
Last Changed Author: ulfl
Last Changed Rev: 961
Last Changed Date: 2008-09-14 01:13:47 +0200 (Sun, 14 Sep 2008)

org.openstreetmap.josm.plugins.PluginException: Ein Fehler ist in dem Plugin AgPifoJ aufgetreten.

at org.openstreetmap.josm.plugins.PluginProxy.mapFrameInitialized(PluginProxy.java:33)
at org.openstreetmap.josm.Main.setMapFrame(Main.java:152)
at org.openstreetmap.josm.Main.removeLayer(Main.java:177)
at org.openstreetmap.josm.gui.dialogs.LayerListDialog$DeleteLayerAction.actionPerformed(LayerListDialog.java:85)
at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1849)
at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2169)
at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:420)
at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:258)
at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:236)
at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:231)
at java.awt.Component.processMouseEvent(Component.java:5517)
at javax.swing.JComponent.processMouseEvent(JComponent.java:3135)
at java.awt.Component.processEvent(Component.java:5282)
at java.awt.Container.processEvent(Container.java:1966)
at java.awt.Component.dispatchEventImpl(Component.java:3984)
at java.awt.Container.dispatchEventImpl(Container.java:2024)
at java.awt.Component.dispatchEvent(Component.java:3819)
at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4212)
at java.awt.LightweightDispatcher.processMouseEvent(Container.java:3892)
at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3822)
at java.awt.Container.dispatchEventImpl(Container.java:2010)
at java.awt.Window.dispatchEventImpl(Window.java:1791)
at java.awt.Component.dispatchEvent(Component.java:3819)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:463)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:242)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:163)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:157)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:149)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)

Caused by: java.lang.reflect.InvocationTargetException

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:585)
at org.openstreetmap.josm.plugins.PluginProxy.mapFrameInitialized(PluginProxy.java:30)
... 28 more

Caused by: java.lang.NullPointerException

at org.openstreetmap.josm.plugins.agpifoj.AgpifojDialog.displayImage(Unknown Source)
at org.openstreetmap.josm.plugins.agpifoj.AgpifojPlugin.mapFrameInitialized(Unknown Source)
... 33 more

Attachments (0)

Change History (5)

comment:1 Changed 14 years ago by stoecker

Component: unspecifiedPlugin openstreetbugs

comment:2 Changed 13 years ago by Hasienda

Keywords: PluginException AgPifoJ added
Summary: Beim durchblättern von Geofotos FehlermeldungPluginException while going through geo images (de: bei Durchblättern von Geofotos Fehlermeldung)

The initial report is quite old compared to the steady progress of JOSM development, and still not updated.

Would you test with more current JOSM revision (1096 to date) and AgPifoJ (10334 to date), please?

This might even be related to #1430, which holds a quit similar PluginException, but thrown by validator plugin. So it's possible, that it has been fixed too.

comment:3 Changed 13 years ago by anonymous

Summary: PluginException while going through geo images (de: bei Durchblättern von Geofotos Fehlermeldung)AgPifoJ: PluginException while going through geo images (de: bei Durchblättern von Geofotos Fehlermeldung)

comment:4 Changed 13 years ago by stoecker

Owner: changed from framm to Christian Gallioz <christian.gallioz@…>

comment:5 Changed 13 years ago by Christian Gallioz <christian.gallioz@…>

Resolution: fixed
Status: newclosed

This has probably be caused be null image entry. Fixed.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christian Gallioz <christian.gallioz@…>.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.