Modify

Opened 14 years ago

Closed 14 years ago

#1430 closed defect (fixed)

org.openstreetmap.josm.plugins.PluginException: An error occoured in plugin validator

Reported by: anonymous Owned by: framm
Priority: major Milestone:
Component: Plugin Version: latest
Keywords: validator Cc:

Description

First strt after loading new version:

Path: trunk
URL: http://josm.openstreetmap.de/svn/trunk
Repository Root: http://josm.openstreetmap.de/svn
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Revision: 805
Node Kind: directory
Last Changed Author: stoecker
Last Changed Rev: 805
Last Changed Date: 2008-08-18 01:27:58 +0200 (Mon, 18 Aug 2008)

org.openstreetmap.josm.plugins.PluginException: An error occoured in plugin validator

at org.openstreetmap.josm.plugins.PluginProxy.mapFrameInitialized(PluginProxy.java:33)
at org.openstreetmap.josm.Main.setMapFrame(Main.java:152)
at org.openstreetmap.josm.Main.addLayer(Main.java:293)
at org.openstreetmap.josm.actions.OpenAction.openFileAsGpx(OpenAction.java:95)
at org.openstreetmap.josm.actions.OpenAction.openFile(OpenAction.java:58)
at org.openstreetmap.josm.actions.OpenAction.actionPerformed(OpenAction.java:49)
at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1882)
at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2202)
at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:420)
at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:258)
at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:236)
at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:231)
at java.awt.Component.processMouseEvent(Component.java:5602)
at javax.swing.JComponent.processMouseEvent(JComponent.java:3135)
at java.awt.Component.processEvent(Component.java:5367)
at java.awt.Container.processEvent(Container.java:2010)
at java.awt.Component.dispatchEventImpl(Component.java:4068)
at java.awt.Container.dispatchEventImpl(Container.java:2068)
at java.awt.Component.dispatchEvent(Component.java:3903)
at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4256)
at java.awt.LightweightDispatcher.processMouseEvent(Container.java:3936)
at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3866)
at java.awt.Container.dispatchEventImpl(Container.java:2054)
at java.awt.Window.dispatchEventImpl(Window.java:1791)
at java.awt.Component.dispatchEvent(Component.java:3903)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:463)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:269)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:184)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:176)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)

Caused by: java.lang.reflect.InvocationTargetException

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:585)
at org.openstreetmap.josm.plugins.PluginProxy.mapFrameInitialized(PluginProxy.java:30)
... 30 more

Caused by: java.lang.NoSuchMethodError: org.openstreetmap.josm.data.osm.visitor.SimplePaintVisitor.getPreferencesColor(Ljava/lang/String;Ljava/awt/Color;)Ljava/awt/Color;

at org.openstreetmap.josm.plugins.validator.Severity.<clinit>(Severity.java:10)
at org.openstreetmap.josm.plugins.validator.ErrorLayer.getToolTipText(ErrorLayer.java:92)
at org.openstreetmap.josm.gui.dialogs.LayerListDialog$1.getListCellRendererComponent(LayerListDialog.java:170)
at javax.swing.plaf.basic.BasicListUI.updateLayoutState(BasicListUI.java:1155)
at javax.swing.plaf.basic.BasicListUI.maybeUpdateLayoutState(BasicListUI.java:1105)
at javax.swing.plaf.basic.BasicListUI$Handler.valueChanged(BasicListUI.java:2226)
at javax.swing.DefaultListSelectionModel.fireValueChanged(DefaultListSelectionModel.java:187)
at javax.swing.DefaultListSelectionModel.fireValueChanged(DefaultListSelectionModel.java:167)
at javax.swing.DefaultListSelectionModel.fireValueChanged(DefaultListSelectionModel.java:214)
at javax.swing.DefaultListSelectionModel.changeSelection(DefaultListSelectionModel.java:408)
at javax.swing.DefaultListSelectionModel.changeSelection(DefaultListSelectionModel.java:417)
at javax.swing.DefaultListSelectionModel.setSelectionInterval(DefaultListSelectionModel.java:441)
at javax.swing.JList.setSelectedIndex(JList.java:1732)
at javax.swing.JList.setSelectedValue(JList.java:1834)
at org.openstreetmap.josm.gui.dialogs.LayerListDialog.activeLayerChange(LayerListDialog.java:310)
at org.openstreetmap.josm.gui.MapView.setActiveLayer(MapView.java:347)
at org.openstreetmap.josm.gui.MapView.addLayer(MapView.java:159)
at org.openstreetmap.josm.Main.addLayer(Main.java:298)
at org.openstreetmap.josm.plugins.validator.OSMValidatorPlugin.mapFrameInitialized(OSMValidatorPlugin.java:83)
... 35 more

Attachments (0)

Change History (3)

comment:1 Changed 14 years ago by anonymous

PS: I had to hard kill JOSM because it got stuck in an endless loop about this exception.

comment:2 Changed 14 years ago by anonymous

PPS: Sorry, wrong information. That was not directly after starting, but after loading a GPS-track.

comment:3 Changed 14 years ago by anonymous

Resolution: fixed
Status: newclosed

Update validator plugin. It must be very old.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain framm.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.