Modify

Opened 18 months ago

Closed 18 months ago

Last modified 5 months ago

#15315 closed defect (fixed)

NPE in eastNorth

Reported by: naoliv Owned by: team
Priority: normal Milestone: 17.09
Component: Core Version:
Keywords: osc osmChange Cc:

Description

I am seeing a lot of this when trying to zoom the map (and then I get only a gray screen):

java.lang.NullPointerException: eastNorth
	at java.base/java.util.Objects.requireNonNull(Objects.java:246)
	at org.openstreetmap.josm.gui.MapViewState$MapViewEastNorthPoint.<init>(MapViewState.java:629)
	at org.openstreetmap.josm.gui.MapViewState.getPointFor(MapViewState.java:178)
	at org.openstreetmap.josm.gui.draw.MapViewPath.lineTo(MapViewPath.java:102)
	at org.openstreetmap.josm.gui.draw.MapViewPath.lineTo(MapViewPath.java:90)
	at org.openstreetmap.josm.gui.draw.MapViewPath.appendWay(MapViewPath.java:171)
	at org.openstreetmap.josm.gui.draw.MapViewPath.append(MapViewPath.java:149)
	at org.openstreetmap.josm.data.osm.visitor.paint.StyledMapRenderer.getPath(StyledMapRenderer.java:1418)
	at org.openstreetmap.josm.data.osm.visitor.paint.StyledMapRenderer.forEachPolygon(StyledMapRenderer.java:1201)
	at org.openstreetmap.josm.data.osm.visitor.paint.StyledMapRenderer.drawText(StyledMapRenderer.java:1120)
	at org.openstreetmap.josm.gui.mappaint.styleelement.TextElement.paintPrimitive(TextElement.java:92)
	at org.openstreetmap.josm.data.osm.visitor.paint.StyledMapRenderer$StyleRecord.paintPrimitive(StyledMapRenderer.java:193)
	at org.openstreetmap.josm.data.osm.visitor.paint.StyledMapRenderer.paintRecord(StyledMapRenderer.java:1663)
	at org.openstreetmap.josm.data.osm.visitor.paint.StyledMapRenderer.paintWithLock(StyledMapRenderer.java:1645)
	at org.openstreetmap.josm.data.osm.visitor.paint.StyledMapRenderer.render(StyledMapRenderer.java:1599)
	at org.openstreetmap.josm.gui.layer.OsmDataLayer.paint(OsmDataLayer.java:466)
	at org.openstreetmap.josm.gui.layer.AbstractMapViewPaintable$CompatibilityModeLayerPainter.paint(AbstractMapViewPaintable.java:27)
	at org.openstreetmap.josm.gui.MapView.paintLayer(MapView.java:485)
	at org.openstreetmap.josm.gui.MapView.drawMapContent(MapView.java:575)
	at org.openstreetmap.josm.gui.MapView.paint(MapView.java:507)
	at java.desktop/javax.swing.JComponent.paintChildren(JComponent.java:908)
	at java.desktop/javax.swing.JComponent.paint(JComponent.java:1084)
	at java.desktop/javax.swing.JComponent.paintToOffscreen(JComponent.java:5256)
	at java.desktop/javax.swing.BufferStrategyPaintManager.paint(BufferStrategyPaintManager.java:246)
	at java.desktop/javax.swing.RepaintManager.paint(RepaintManager.java:1313)
	at java.desktop/javax.swing.JComponent._paintImmediately(JComponent.java:5204)
	at java.desktop/javax.swing.JComponent.paintImmediately(JComponent.java:5014)
	at java.desktop/javax.swing.RepaintManager$4.run(RepaintManager.java:857)
	at java.desktop/javax.swing.RepaintManager$4.run(RepaintManager.java:840)
	at java.base/java.security.AccessController.doPrivileged(Native Method)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:89)
	at java.desktop/javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:840)
	at java.desktop/javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:815)
	at java.desktop/javax.swing.RepaintManager.prePaintDirtyRegions(RepaintManager.java:764)
	at java.desktop/javax.swing.RepaintManager.access$1200(RepaintManager.java:69)
	at java.desktop/javax.swing.RepaintManager$ProcessingRunnable.run(RepaintManager.java:1880)
	at java.desktop/java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:313)
	at java.desktop/java.awt.EventQueue.dispatchEventImpl(EventQueue.java:764)
	at java.desktop/java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.desktop/java.awt.EventQueue$3.run(EventQueue.java:717)
	at java.desktop/java.awt.EventQueue$3.run(EventQueue.java:711)
	at java.base/java.security.AccessController.doPrivileged(Native Method)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:89)
	at java.desktop/java.awt.EventQueue.dispatchEvent(EventQueue.java:734)
	at java.desktop/java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:199)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:124)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:113)
	at java.desktop/java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:109)
	at java.desktop/java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.desktop/java.awt.EventDispatchThread.run(EventDispatchThread.java:90)

JOSM

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-09-15 01:35:48 +0200 (Fri, 15 Sep 2017)
Revision:12866
Build-Date:2017-09-15 01:32:04
URL:http://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (12866 pt_BR) Linux Debian GNU/Linux unstable (sid)
Memory Usage: 637 MB / 3072 MB (311 MB allocated, but free)
Java version: 9-Debian+0-9b181-4, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1920x1080
Maximum Screen Size: 1920x1080
Java package: openjdk-9-jre:amd64-9~b181-4
Java ATK Wrapper package: libatk-wrapper-java:all-0.33.3-13
VM arguments: [--add-modules=java.se.ee, -Dawt.useSystemAAFontSettings=on]

Attachments (0)

Change History (7)

comment:1 Changed 18 months ago by bastiK

What kind of .osm data did you open? I'm assuming it is not a simple download from the server?

comment:2 Changed 18 months ago by naoliv

I was viewing some osmChange files.
For example, downloaded https://www.openstreetmap.org/api/0.6/changeset/37667532/download, renamed to something.osc, opened in JOSM, FileUpdate data to have the complete objects.
The conflicts I ignored (I didn't solve any of them), since I was only needing to have an overview of what happened in some changesets.

comment:3 Changed 18 months ago by bastiK

Resolution: fixed
Status: newclosed

In 12876/josm:

fixed #15315 - NPE in eastNorth

comment:4 Changed 18 months ago by bastiK

Keywords: osc osmChange added
Milestone: 17.09

comment:5 Changed 18 months ago by Don-vip

In 12877/josm:

see #15315 - disable AvoidCatchingNPE

comment:6 Changed 17 months ago by bastiK

In 13033/josm:

fixed #15466 - Data filtering is not working properly for nodes (see #15315)

comment:7 Changed 5 months ago by Don-vip

Ticket #14148 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.