Modify

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#15306 closed defect (duplicate)

Just errored while browsing around with a few imagery layers open

Reported by: bgirardot Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report jcs cache Cc: wiktorn

Description

What steps will reproduce the problem?

No idea, browsing around, adding and removing imagery layers looking at this city.

URL is center point screen when error happened.
https://www.openstreetmap.org/#map=19/16.703095105257344/-92.61675038548408

see attached image for list of layers and their state.

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-06-04 17:28:58 +0200 (Sat, 04 Jun 2016)
Build-Date:2016-06-04 15:31:27
Revision:10327
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10327 en) Windows 7 64-Bit
Memory Usage: 552 MB / 910 MB (249 MB allocated, but free)
Java version: 1.8.0_111-b14, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Dataset consistency test: No problems found

Plugins:
- FastDraw (32309)
- PicLayer (32329)
- apache-commons (32584)
- buildings_tools (32309)
- ejml (32639)
- geotools (32584)
- josm-geojson (31245)
- jts (32539)
- measurement (32158)
- opendata (32158)
- turnrestrictions (32158)
- utilsplugin2 (32158)

Map paint styles:
- https://github.com/hotosm/HDM-JOSM-style/archive/master.zip

Last errors/warnings:
- E: java.lang.IllegalArgumentException: Negative position

java.lang.IllegalArgumentException: Negative position
	at sun.nio.ch.FileChannelImpl.write(Unknown Source)
	at org.apache.commons.jcs.auxiliary.disk.block.BlockDisk.write(BlockDisk.java:216)
	at org.apache.commons.jcs.auxiliary.disk.block.BlockDiskCache.processUpdate(BlockDiskCache.java:399)
	at org.apache.commons.jcs.auxiliary.AbstractAuxiliaryCacheEventLogging.updateWithEventLogging(AbstractAuxiliaryCacheEventLogging.java:65)
	at org.apache.commons.jcs.auxiliary.disk.AbstractDiskCache.doUpdate(AbstractDiskCache.java:815)
	at org.apache.commons.jcs.auxiliary.disk.AbstractDiskCache$MyCacheListener.handlePut(AbstractDiskCache.java:673)
	at org.apache.commons.jcs.engine.AbstractCacheEventQueue$PutEvent.doRun(AbstractCacheEventQueue.java:350)
	at org.apache.commons.jcs.engine.AbstractCacheEventQueue$AbstractCacheEvent.run(AbstractCacheEventQueue.java:269)
	at org.apache.commons.jcs.engine.CacheEventQueue$QProcessor.run(CacheEventQueue.java:304)

Attachments (1)

2017-09-14_11h29_24.png (692.3 KB) - added by bgirardot 2 years ago.
screenshot of layers open when errored.

Download all attachments as: .zip

Change History (7)

Changed 2 years ago by bgirardot

Attachment: 2017-09-14_11h29_24.png added

screenshot of layers open when errored.

comment:1 Changed 2 years ago by Don-vip

Cc: wiktorn added
Keywords: jcs cache added

comment:2 Changed 2 years ago by wiktorn

It's probably some bug (race condition) within JCS.

@Don-vip:
What do you think about tracking tags/commons-jcs-2.1 or tags/commons-jcs-2.2 instead of trunk for JCS?

comment:3 in reply to:  2 ; Changed 2 years ago by Don-vip

Replying to wiktorn:

What do you think about tracking tags/commons-jcs-2.1 or tags/commons-jcs-2.2 instead of trunk for JCS?

Yeah sure, good idea :)

comment:4 Changed 2 years ago by wiktorn

Resolution: duplicate
Status: newclosed

Closed as duplicate of #12909.
Please, update to new version of JOSM

comment:5 in reply to:  3 Changed 2 years ago by wiktorn

Replying to Don-vip:

Replying to wiktorn:

What do you think about tracking tags/commons-jcs-2.1 or tags/commons-jcs-2.2 instead of trunk for JCS?

Yeah sure, good idea :)

Maybe just not yet? Apart from few bug some time ago (when there was no tag that we were interested in), this hadn't bite us yet. And tracking trunk we don't need to update externals.

comment:6 Changed 2 years ago by Don-vip

Ah sorry I didn't notice the JOSM version was completely outdated here.
@bgirardot: please don't report issues against a 1 year old version of JOSM without updating first. We release a new version every month!

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.